Examples

In this section, techniques learned in previous sections are implemented to create the
geometries of real parts. It is also shown how to implement the manufacturing constraints like
draft for molded and casted parts.

These exercises have been arranged in increasing order of complexity. Techniques learned in
initial exercises are used afterwards. So it is recommended to go through the exercises one-by-
one from beginning.

Note: In this section, splines are frequently used. So you must have gone through the exercises
in “Sketched Datum Curves” sub-section that is located inside the “Datum Features” section.
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Exercise 1

In this exercise we will create a door handle. The completed part is shown below.

You will notice that the handle is slim in the center but fat at the ends. This is evident in the top
view shown in the figure below

Set the working directory to the EXAMPLES folder and open the model DOOR_HANDLE.PRT

You can see a surface on screen created by a sweep feature as shown below.

—> Modify the surface

We will redefine the Sweep feature and add relations to make it slim in center.

Right-click the “Sweep 1” in model tree and select Edit Definition.
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b &) Sweep 1
= Inserth Set Representationto  »
Delete
Group
Suppress
Rename

Edit

Edit Definition

Edit References

Pick = and sketcher will appear as shown below. (Note: You will see different colors on screen.
We use custom color settings for clear presentation.)

Notice that sketch consists of an ellipse. We will add relations so that the dimensions vary during
the sweep operation according to our requirement.

Pick 0= Reaons o the Tools tab and Relations dialog box will appear.
Now enter the following relations in the dialog box.

sd7 = 4 -1.5 *sin (trajpar * 180)

sd4 = 3.5-1.75 " sin ( trajpar * 180)

The “sd7” and “sd4” are symbols assigned to the ellipse dimensions in sketcher. These symbols
might be different depending upon the circumstances. The following figure elaborates clearly.
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Relations = [ X

File Edit Insert Parameters Utilities Show

Look In
Section kh  S2D0001

w Relations

ooy BEREX (o @ A BE

4+ {=d7 = 4-1.5 *=in ( trajpar = 180 )

54 = 3.5- 1.75 * &in ( trajpar * 180 )

p Local Parameters

OK Reset Cancel

Using the trajectory parameter, trajpar, in a relation for a sweep feature allows to map any
function, along the Origin Trajectory. The value of trajpar changes from 0 to 1 as the section is
swept along the Origin Trajectory from start to end.

Pick ol to save changes and exit the Relations dialog box.

Pick ¥ to complete the sketch.

Pick . to complete the feature and surface will appear as shown below.

Now we need to close the open ends so that quilt can be converted to a solid. For this, we will
merge an extruded surface with the swept surface. The extruded surface has already been
created but hidden.

So right-click the “Extrude 1” feature and pick Unhide.



b &) Sweep
& Insert -

Set Representation to
Delete

Group

Suppress

Rename

Edit

Edit Definition

Edit References
Pattern...

Insert Here

Setup Mote

Info

Edit Parameters

= Merging the surfaces

Chapter 4

Now select both quilts while holding down the Ctrl key as shown below.

Fick these

Pick ' on the Model tab to invoke Merge tool.

EXAMPLES

Pick on the arrow to flip its direction as shown in figure below. This is necessary to keep the

desired side of the quilt.
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Pick on this arrow

(Note: Instead of picking on arrow, you can also use or icons on the dashboard to
change the side of quilt to keep.)

Now the preview will appear as shown below.

Pick i or middle-click to complete the merge feature. The quilt will appear as shown below.

(If it does not appear as shown below then you need to redefine the merge feature and fix it.)

Notice that the joint between both quilts appears magenta which means that both surfaces have
been merged into a single quilt.

—> Solidifying the quilt

Now select the quilt as shown below.
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Select this quilt

Pick ©I on the Model tab to invoke Solidify tool and dashboard will appear as shown below.

041 % N eiyfiiso v X

References | Properties

Pick -..; or middle-click to complete the feature. The part will appear as shown below.

The black color of contours shows that now it is no more a quilt but a solid.

Select File > Save to save the work done so far.
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Exercise 2

In this exercise we will create the surface model of a hand grip.
Set the working directory to the BASICS folder and open the model HAND GRIP.PRT

The model consists of four datum curves as shown below.

/——/_/_/——_\\\

T T g e e Sa

= Creating the surface

Pick W icon to invoke the Sweep tool.

Pick the straight datum curve (Sketch 1) with left mouse pick to make it Origin Trajectory. (Set
the view to Default Orientation to avoid any confusion)

Standard Orientation

__ﬂ——f_f—_————_———_——— | Default Orientation |
(Eleack

(H BOTTOM
% [ FRONT
= FS(SKETCH_1) %LEF"
RIGHT
(HTop

+

("B Reorient..

Pick this curve

Now hold down the Ctrl key and pick the other three curves to add them as chains.

0.0o

Pick these
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The order, in which chains are selected have no effect on the sweep geometry. Only the desired

Origin Trajectory should be selected first.

. References
Pick

chains in addition to Origin Trajectory.

Trajectories X N
Orrigin [ v
Chain 1
Chain 2
Chain 3

Section plane control

MNormal To Trajectory -

Horizontalertical control

Automatic -

X direction reference at start
Default

tab to open the References slide-up panel and confirm that there are three

5
i
oo
i
oo

Detailz...

Pick 'Sweep as surface' icon ( = ) to create a surface with this sweep feature.

References | Options | Tangency @ Properties

Pick @ to sketch the cross section.

Il OWiffi oo v X

Notice that system has placed cross-hair at the start point of the Origin trajectory and also a
reference to each chain. You can rotate the view to have a look at it clearly. (Note: You will see
different colors on screen. We use custom color settings for clear presentation.)
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Pick " =Fine and sketch a three point spline that passes through the references for chains as

shown below (View shown after picking & )-

To add spline tangency dimension at a point, click the spline, then click the geometry to which
the spline tangency is to be defined and then click the endpoint where the tangency is to be
defined. Then click the middle mouse button to place the dimension.



Chapter 4 EXAMPLES

Pick ¥ to complete the sketch.

Pick i to complete the feature and surface will display as shown below.

Notice that cross-section remains aligned to the chains all along the sweep feature.

= Mirroring the surfaces

Now we will mirror the surface, so select it as shown below.

Pick this quilt

While the surface geometry is selected, pick I on th Model tab to invoke the Mirror tool.

Select the FRONT datum as Mirror plane.

Pick i to complete the feature. Part will appear as shown below.

= Merging the surfaces

Now we will merge the surfaces together.

11
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So select surfaces, shown in the figure below, while holding down the Ctrl key. (order of
selection is not important)

Select these quilts

Pick ! on the Model tab to invoke Merge tool.

Pick  “P%"* tab and change the merge type to Join.

A A Il Off 6o v X

References Options | Properties

{ | Intersect
@ Jloin

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick ‘, or middle-click to complete the merge feature.

Select File > Save to save the work done so far.
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Exercise 3

In this exercise we will fix a distorted boundary blended surface.
Set the working directory to the EXAMPLES folder and open the model BASE_NECK.PRT

The part will appear as shown below.

Distorted surface

You should notice that neck of this part appears distorted. This neck is defined by a boundary
blended surface. So we will fix this surface. This problem occurs often while creating boundary
blended surfaces, so it is important to know how to fix it.

= Modify the surface

We will redefine this surface feature and fix it.

Right-click the “Boundary Blend 1” feature in model tree and select Edit Definition.

(7] BASE_NECK.PRT
£7 RIGHT
£7 TOP
F7 FRONT Set Representationto  »
SxPRT_CSYS DE  Delete
/% BOUNDARY_P  groyp
/% BOUNDARY_H
/% MAIN_PROFILE
/A SIDE_PROFILE _Rename

Suppress

75 MAIN_TRIM Edit Definition

7% OPENING_TRI Edit References

£7 DT Fattern...

o COLUMN
> S Sweep 1 Setup Note >
b ) Extrude 1

Info k

b E]Sweep 2 ;
b 5 Extrude 2 Hide
b 5 Extrude 3 Edit Parameters

£ Boundary Blenu-

o Insert Here

13
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Notice the location of start point for fist Chain as shown below.

Now pick ““™ % tab to view Curves slide-up panel. Here pick on the second chain as shown
below.

First direction Second direction

| 1____Chain Click her...

[L_crain ]| o o
& &

| Details... | Details... |

Close blend

Now system will show the Start Point for second chain as shown below.

Start point

If you compare the location of Start Point for first and second chain then you can easily conclude
that surface is distorted due to mismatch of Start Points. So we will change the location of Start
Point of second chain so that it corresponds to the Start Point of first Chain.

Take your mouse pointer over the Start Point and hold down left mouse button. Then drag and
drop it as shown in the figure below.
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Now the surface will appear as shown below.

Apply the Tangent constraint for second chains as shown below.

i) Free

® Tangent

) Mormal

k=2t () Curvature

Pick i to complete the feature and surface will appear as shown below.

15
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Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will build a shampoo bottle. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model BOTTLE.PRT

—> Building Body
First we will build the quilts that represent the body of the bottle.
We need to offset the outer quilt to create the quilt for the step visible in above figure.

So pick the quilt as shown below. You can use the Quilt filter if you have difficulty in selecting
the quilts.

Pick this quilt

Smart
Features
Geometry
Datums
Quitts
Annotation

Smart k4

Pick 71°7s% o1 the Model tab to invoke Offset tool and enter 2 as the offset value on the

dashboard.
17



Surface Modeling - A Practical Approach Creo 1.0

to reverse the direction of feature creation so that surface is offset inwards as shown

Pick X icon to complete the feature. (Leave the offset type to Standard, which is default)

Now we will merge the quilts. So select quilts, shown in the figure below, while holding down the
Ctrl key. (Notice that offset quilt is not selected but the original quilt). You can use the Quilt filter
if you have difficulty in selecting the quilts.

Pick this quilt first Fick this quilt after holding Ctrl key

Pick &' on the Model tab to invoke Merge tool and preview will appear as shown below.
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Pick 4 or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below.

Now we will merge the new quilt (created after merge operation) with the quilt created by offset
operation.

So select quilts, shown in the figure below, while holding down the Ctrl key. (You can use the
Quilt filter if you have difficulty in selecting the quilts)

19
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Fick this quilt first Fick this quilt after holding Ctrl key

Smart
Features
Geometry
Datums
Quitts

. Annotation

Smart L4

Pick ' to invoke Merge tool and then 7 so that preview appears as shown below. (Notice the
direction of arrows)

Desired Preview

Pick X or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below. (If not then go back and fix it)
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Shaded Wiew Wireframe View

—> Building Neck

Now we will create the neck details for the bottle. For this purpose we have already created a
surface but it is hidden.

So right-click the “NECK” feature in the model tree and pick Unhide.

Now part will appear as shown below.

We will create a boundary blended surface that connects NECK with main body.

Pick “7 and select the following chain. (Place the mouse pointer over any edge of the surface
and right-click, then system will show IntentEdg tooltip. When tooltip appears, select the chain
with left mouse pick.)

21
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Pick this chain

Now hold down the Ctrl key and pick the second chain using the Intent chain technique as
shown below.

Pick this chain

IntentEdg:F11(SURFACE)

If the preview of surface appears distorted, then fix it before proceeding. The procedure to fix the
distorted boundary blended surface was explained in previous exercise.

Apply the Tangent constraints for both chains as shown below.

@ Free

Marmal

Tangent

Marmal

Curvature Cumnvature

Pick . to complete the feature and surface will display as shown below.
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= Building Bottom

Now we will create the bottom details for the bottle. For this purpose we have already created a
surface but it is hidden.

So right-click the “BOTTOM_CLOSE” feature in the model tree and pick Unhide.

We will merge the BOTTOM_CLOSE with the main quilt.

So select quilts, shown in the figure below, while holding down the Ctrl key.

Fick this quilt after holding Ctrl key

Pick this quilt first

Pick ' on the Model tab to invoke Merge tool and preview will appear as shown below.

23
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Pick X or middle-click after making sure that arrows direction is as shown in the above figure.

Pick » to access the Round tool.

Select the following edge chain for applying round.

Pick this chain

IntentEdg:F21(MERGE_4)

Enter 3 as the radius value

Pick ¥ icon to complete the feature.

= Thickening the Quilt

Before thickening the quilt, all surfaces should be merged together to form a single quilt. So first
merge operation will be performed.

First we will merge the boundary blended surface of neck with the main quilts.
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So select quilts, shown in the figure below, while holding down the Ctrl key.

Pick this quilt first Pick thi= quilt after holding Ctrl key

Pick &’ on the Model tab to invoke Merge tool.

Pick “P""* tab and change the merge type to Join.

-
1_\

ISl o0 v X

References | Options | Properties

Intersect

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick 4 or middle-click to complete the merge feature.
Now we will merge the NECK surface with the main quilts.

So select quilts, shown in the figure below, while holding down the Ctrl key.

25
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Pick this quilt first Pick this quilt after holding Ctrl key

Pick &' on the Model tab to invoke Merge tool.

Pick “PU"% tab and change the merge type to Join.

Pick X or middle-click to complete the merge feature.

The part will appear as shown below. Notice that all the edges, except at opening, in quilt appear
magenta which means that all surfaces have been merged into a single quilt

Shaded YWiew Wireframe View

Now we will thicken the quilt. So select the quilt.

Pick = to invoke Thicken tool and enter 1 as the thickness on the dashboard.

Pick 7z to reverse the direction of feature creation so that material is added to the inner side of
the surface as shown below.
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Resulting geometry direction

Pick ‘, or middle-click to complete the feature. The part will appear as shown below.

Select File > Save to save the work done so far.

27
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Exercise 5

In this exercise we will complete a surface model of a door of drawer. The completed part is
shown below.

Set the working directory to the EXAMPLES folder and open the model DRAWER_DOOR.PRT

Before creating the desired surface, first we will create the datum curves which will be used to
construct the surface.

= Creating the datum curves

We will create the datum curves using through points option.

Pick ~ Curvethrough Foints on the Model tab as shown below.

File ~ Model Analysis Annotate Render Tools View Flexible Modeling Applications

. [Za . ; B i o S
ji e i 5 F Axis , _'| sfn Revolve Hole T L
e = i?_ X Poi = il e e (= i
) w » Point '5.'1:“_:| Sweep  Round S
Regenerate Plane Sketch  Extrude
i p E ;){n Coordinate System G-f_" Swept Blend 2 Chamfer = F
Operaticns * Get Data « Shapes v Engineering *

S Curve 3

¢~ Curve through Points

ﬁ Reference ~ Curve from Equation

_#™ Graph " Curve from Cross Section
Ribbon

ﬂg Offzet Planes

Default Coordinate System

Pick the following vertex as first point for curve. (Set the view to ISO3 and part will appear as
shown below.)
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Standard Orientation
[ Default Orientation
(Bleack
\(5)BOTTOM

[ FrRONT

1501
#PMT4 502

3 -

VerexEdge:F1M{EXTRLUDE_2) iﬁ- Rearient

Pick the datum points one-by-one in the following order, PNT4 > PNTO > PNT5, as shown in
figure below.

Second Pick Third Pick Fourth Pick

Pick the following vertex as last point for curve.

Now we will specify the tangent constraints for the ends of the curve.

So pick | "** 2" ok and change the 'End condition' for Start Point to Tangent.

29
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. End= Condition | Options | Properties _ Options | Properties .

Curve side Curve side
Start Point End condition | Free :"'f @ Start Point End condition . .'I'-angen’.f v
End Point . End Point e o |
Tangent to
> | @ Select tems | Flip

Make end curve to be perpendicular
Perpendicular to

Flip

Now system wants to know a reference to which the new curve will be tangent, so pick the
following surface to make the new datum curve tangent to it.

SurtFE(EXTRUDE_1)

Now change the 'End condition' for End Point to Tangent as shown below.

| Placement _ Options | Properties |

Curve side
__StartPoint | £nyg condition -.Tangent =
| @ End Point . -
Tangent to
'@ Select items ' Flip

Make end curve to be perpendicular
Perpendicular to

Flip

Again pick the following surface to make the new datum curve tangent to it at the end point.
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SurfF8(EXTRUDE_1)

Pick W to complete the feature. The datum curve will appear as shown below.

Now we will create second curve so again pick 7~ Curve through Points

Pick the PNTG6 as first point for curve. (Set the view to ISO3 and part will appear as shown
below.)

Standard Orientation | 4 |
Default Crientation '

(Beack |
Pick this (zlsoTTOM r
|(pFrRONT
[ 1501
1502 |
1503 v
Fpy T L
PHTE:F13(DATUM POINT)

iﬁ_ Reorient...

Pick the PNTO as end point.

31



Surface Modeling - A Practical Approach Creo 1.0

4|

m_.__

Now we will specify the tangent constraints for the ends of the curve.

So pick = " 9" tah and change the End condition for Start Point to Tangent.

Now system wants to know a reference to which the new curve will be tangent, so pick the
following surface to make the new datum curve tangent to it at the start point.

SurfFa(EXTRUDE_1)

Now change the End condition for End Point to Normal.

Select the DTM_OPENING datum plane as reference as shown below.

Curve zide Curve side
| StartPoint | Eng condition || Mormal = Start Point End condition | Normal L
@ End Point - End Point :
Mormal to | hormal to
@ Select items Flip — | DTM_OPENING:FT(DAT| | Flip |

Select "™ ' to reverse the direction so that curve appears as shown in figure below.
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DhlT o
Il
el L =

Pick m to complete the feature.

= Creating the surface

Now we will create a surface with Boundary Blend Tool.

Pick “7 and select the edge shown in the figure below.

Now hold down the Ctrl key and pick the following curve as second chain.

33
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Pick in the 'Second direction' collector to activate either on dashboard or in Curves panel.

23 2 Chains | /& | Cickheretoadd tem 1

Il O o0 v X

Curves | Constraintzs | Control Points | Options P'raperties:

First d_ire;_t'rl:r_n_ _ _ _E“recund qgrgp_t_il_:m
1 Chain Click her...
2 Chain & P
e Pick here to activate
4
i Details... | | Details... |
Close blend

Pick the edge, shown in the figure below (dynamic preview off) as first chain in second direction.

Pick this edge
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Now hold down the Ctrl key and pick the datum curve, shown in the figure below as second
chain in second direction.

Pick this curve

While holding down the Ctrl key, pick the edge, shown in the figure below as last chain in second
direction.

Pick this edge

35



Surface Modeling - A Practical Approach Creo 1.0

Apply the Tangent constraints for the three chains as shown below.

Pick W to apply the changes and exit the dashboard.

Select File > Save to save the work done so far.
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Exercise 6

In this exercise we will create a model for plastic chair. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model CHAIR.PRT. Because
this part is symmetrical so we will create half side of the part and then mirror it.

Required datum curves have already been created. You are encouraged to explore the way
these curves have been defined after completing this exercise.

— Creating the surface

We will create a boundary blended surface by using the curves shown in the above figure.

Pick “7 and select the curves, while holding down the Ctrl key, in the order shown in figure
below.

First Pick Second Pick Third Pick Fn:_:urth Pick

B
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Pick in the Second Direction Collector to activate it and while holding down the Ctrl key, select
the curves shown in figure below.

First Pick

Second Pick

n.0a

Apply the Normal constraint for the chain that lies on RIGHT datum plane as shown below.

1

i/— 2
|
r- Free

Tangent

n Curvature

This surface will be mirrored about RIGHT datum plane. Therefore to maintain tangency
between original and mirrored surface, the surface has been constrained Normal to the RIGHT
datum plane.

To make the mirrored and parent surface tangent to each other, we need to make the parent
surface normal to mirror plane.

Pick ¥ to complete the feature.



= Creating the Datum Curve for Trimming

Chapter 4 EXAMPLES

Now we will create a datum curve that will lie on the surface we have created and then trim the
surface with this curve. First we will create four datum points to be used as reference for the

datum curve.

Pick ** " on the Model tab to invoke Datum Point tool.

File Model Analysis Annotate Render Tools

tll{} ’3—.; ¥ User-Defined Feature S ;r' Axis

o= B4 ~ " copy Geometry

Regenerate .

- b Eﬁhrinkwrap

b4 2
w x Point] ™

Plane

View Flexible Modeling Applications
] ¢ Revolve i Ho
D ﬁi SWeep ¥ “?l Ro

Sketch Extrude

E)é‘ Coordinate System @}a Swept Blend \-\}1 Ch

Now pick on the surface near bottom right corner. Look at the position of mouse pointer in the

figure below.

SurfF20(BOUNDARY_BLEND_1)

Pick in the Offset references collector to activate it.

$ PNT4

Like Point

Datum Point

Placement | Properties

References

SurfF2{BOUNDARY ..

A e et N
LITTEel (LRI

Offzet references
Click here to add item

OK

On

L= Fick here to activate

Cancel
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Now select the edge shown in figure below as offset reference and enter 45 as the Offset value.

Placement | Properties

References
Surf:F20{BOUNDARY... On

& PHT4

Mrffoad rir
|_||f::|_ .y

Offzet references
Edge:FZ0{BOUNDARY...|] 45.00

Pick this edge

OK Cancel

Hold down the Ctrl key and select the side edge as second offset reference. Enter 25 as the
Offset value as shown below.

Datum Point =
Placement | Properties

References
Surf,F20{BOUNDARY... On

P PNT4

Mew Point
Pick this edge

Offset | 0.00

Offzet references
Edge: F20(BOUNDARY ... 45.00

Edge:F2Z0(BOUNDARY...] 25.00

OK || Cancel

Pick - %% to complete the definition of datum point.

Now we will create another datum point so again pick * * P on the Model tab.

Pick the following datum curve as reference.



Pick this curve

Pick | "#*tEnd | t5 change the measurement reference to right end of curve

Chapter 4

Change the Offset option to Real and enter 55 as the Offset value as shown below.

23.00

EXAMPLES

Datum Point

Placement | Properties

PNTS
B Mew Point

References
Curve F14{CURVE) On
Offset ||55.00 v| Real

Offzet reference

(@ Endofcurve | NextEnd

{_) Reference

oK

Click here to a..

Cancel

Pick - 2% to complete the definition of datum point.

Again pick x x Point on the Model tab and select the following datum curve as reference.
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Pick this curve

Change the Offset option to Real and enter 25 as the Offset value as shown below.

Datum Point X
Placement | Properties
BNTE References

N Bk Curve:F17(CURNVE) On
ew Poin

Offset ||25.00 v Real ¥

Offzet reference
(@ Endofcurve | HextEnd

Reference Click here to a..

Ok Cancel [

Pick - @ to complete the definition of datum point.

Again pick x x Point on the Model tab and pick the surface near top right corner. Look at the
position of mouse pointer in the figure below.
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LT 6

Pick in the Offset references collector to activate it.

Now select the top edge of surface as offset reference and enter 35 as the Offset value as
shown below.

. 4 Datum Point X
7 Placement | Properties
+ BT References

Pick this edge Surf-F20({BOUNDARY.. On

MT &

Offset | 0.00

Offzet references
T3 Edge:F20{BOUNDARY... 35.00

Ol || Cancel

Hold down the Ctrl key and select the side edge as second offset reference. Enter 35 as the
Offset value as shown below.
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Pick this edge

Creo 1.0
Datum Point x
Placement | Properties
& PNTT References
) Surf:F20{BOUNDARY ... On
MNew Point

Offset (0

Offzet references
Edge:FZ0(BOUNDARY ... 35.00
Edge:F20{BOUNDARY... 35.00

ﬂi{ Cancel

Pick - %% to complete the definition of datum point.

Now we will create a datum curve using through points option, passing through the four points

that we just created.

Pick <~ Cunvethrough Points on the Model tab to invoke Curve through Points tool.

Pick the following vertex as first point for curve.

Pick this vertex —— -

MTE

T3

Vertex:Edge F20{BOUNDARY_BLEND_1)

Pick the datum points one-by-one in the following order, PNT4 > PNT5 > PNT6 > PNT7
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o\ 74— Fifth Pick |

Te— Fourth Pick |

Tsag—) Third Pick |

TM—| Second Pick |

Pick the following vertex as last point for curve.

Pick this vertex —h*_

Vertex Edge F20(BOUNDARY_BLEND_1)

Pick  “#*™=" {5 access the Placement panel and check the 'Place curve on surface' option.

As the Surface collector becomes active so pick the surface as shown below.
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Placement | Ends Condition | Options | Properties

Point 1 Point

Point 2 Vertex Edge:F20(BOUNDARY _
F‘u!nt'} Connect to previous point by
Point 4

Point & =

Point & fine

Add Point

VS

V’ Place curve on surface

Surface | Surf.F2ZBOUNDARY .

'Place curve on surface' option is used to create a spline curve that passes through the selected
points and lies on a specific surface patch.

Now we will specify the normal constraints for the ends of the curve.

Ends Condition

So pick tab and change the End condition for 'Start Point' to Normal.

Now system wants to know a reference to which the new curve will be normal, so select the
RIGHT datum plane as reference

Placement | Ends Condition | Options | Properties

Curve side
Start Point End condition || Mormal ¥
End Point
Mormal to

RIGHT:F1{DATUM PLA Flip

Now change the End condition for 'End Point' to Normal and select the RIGHT datum plane as
reference.



Placement Ends Condition

Curve side

Start Point
End Point

Options | Properties

Chapter 4

End condition || Mormal

Normal to

RIGHT:F1(DATUM PLA

Flip

If you look at the end of curve, you will notice that it is twisted as shown below.

It is due to the wrong direction of normal constraint. So pick

Pick . to complete the feature. The datum curve will appear as shown below.

MTE

EXAMPLES

P to reverse the direction.
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= Trimming the Quilt
Now we will trim the quilt with this curve. So first select the quilt.

Pick B on the Model tab to invoke Trim tool.

Select the newly created datum curve as trimming object and preview will appear as shown
below.

0.00

Chain

: 2 MTE
Pick this curve

—>

v

Pick “* or middle-click to complete the feature.

= Mirroring the Quilt

Now we will mirror the quilt so first select the trimmed quilt.

Pick this quilt
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Pick JC on the Model tab to invoke Mirror tool and select the RIGHT datum as Mirror plane.

Pick \, to complete the feature. Part will appear as shown below.

Now you can merge both surfaces together.

Select File > Save to save the work done so far.
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Further material is not included in the free download. You can buy the complete
tutorials at http://www.caeuniversity.com/buy. Thanks for your review of the training
material.
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