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1. Basics of Surface Modeling
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2. Datum Features
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3. Surface Quality and Analysis

Not included in free download.
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4. Examples
In this section, techniques learned in previous sections are implemented to create the
geometries of real parts. It is also shown how to implement the manufacturing constraints like
draft for molded and casted parts.
These exercises have been arranged in increasing order of complexity. Techniques learned in
initial exercises are used afterwards. So it is recommended to go through the exercises one-by-
one from beginning.

Note: In this section, splines are frequently used. So you must have gone through the exercises
in “Sketched Datum Curves” sub-section that is located inside the “Datum Features” section.
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Exercise 1

In this exercise we will create a door handle. The completed part is shown below.

You will notice that the handle is slim in the center but fat at the ends. This is evident in the top
view shown in the figure below

Set the working directory to the EXAMPLES folder and open the model DOOR_HANDLE.PRT

You can see a surface on screen created by a sweep feature as shown below.

Modify the surface

We will redefine the Sweep feature and add relations to make it slim in center.

Right-click the “Sweep 1” in model tree and select .
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Pick and sketcher will appear as shown below. (Note: You will see different colors on screen.
We use custom color settings for clear presentation.)

Notice that sketch consists of an ellipse. We will add relations so that the dimensions vary during
the sweep operation according to our requirement.

Pick on the Tools tab and Relations dialog box will appear.

Now enter the following relations in the dialog box.

sd7 = 4 - 1.5 * sin ( trajpar * 180 )

sd4 = 3.5 - 1.75 * sin ( trajpar * 180 )

The “sd7” and “sd4” are symbols assigned to the ellipse dimensions in sketcher. These symbols
might be different depending upon the circumstances. The following figure elaborates clearly.
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Using the trajectory parameter, trajpar, in a relation for a sweep feature allows to map any
function, along the Origin Trajectory. The value of trajpar changes from 0 to 1 as the section is
swept along the Origin Trajectory from start to end.

Pick to save changes and exit the Relations dialog box.

Pick to complete the sketch.

Pick to complete the feature and surface will appear as shown below.

Now we need to close the open ends so that quilt can be converted to a solid. For this, we will
merge an extruded surface with the swept surface. The extruded surface has already been
created but hidden.

So right-click the “Extrude 1” feature and pick Unhide.
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Merging the surfaces

Now select both quilts while holding down the Ctrl key as shown below. (Tip: You can use the
Quilt filter for quick selection.)

Pick on the Model tab to invoke Merge tool.

Pick on the arrow to flip its direction as shown in figure below. This is necessary to keep the
desired side of the quilt.
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(Note: Instead of picking on arrow, you can also use or icons on the dashboard to
change the side of quilt to keep.)

Now the preview will appear as shown below.

Pick or middle-click to complete the merge feature. The quilt will appear as shown below.
(If it does not appear as shown below then you need to redefine the merge feature and fix it.)

Notice that the joint between both quilts appears magenta which means that both surfaces have
been merged into a single quilt.

Solidifying the quilt

Now select the quilt as shown below.
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Pick on the Model tab to invoke Solidify tool.

Solidify dashboard will appear as shown below.

Pick or middle-click to complete the feature. The part will appear as shown below.

The black color of contours shows that now it is no more a quilt but a solid.

Select File > Save to save the work done so far.
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Exercise 2

In this exercise we will create the surface model of a hand grip.

Set the working directory to the BASICS folder and open the model HAND_GRIP.PRT

The model consists of four datum curves as shown below.

Creating the surface

Pick icon to invoke the Sweep tool.

Pick the straight datum curve (Sketch 1) with left mouse pick to make it Origin Trajectory. (Set
the view to Default Orientation to avoid any confusion)

Now hold down the Ctrl key and pick the other three curves to add them as chains.
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The order, in which chains are selected have no effect on the sweep geometry. Only the desired
Origin Trajectory should be selected first.

Pick tab to open the References slide-up panel and confirm that there are three
chains in addition to Origin Trajectory.

Pick 'Sweep as surface' icon ( ) to create a surface with this sweep feature.

Pick to sketch the cross section.

Notice that system has placed cross-hair at the start point of the Origin trajectory and also a
reference to each chain. You can rotate the view to have a look at it clearly. (Note: You will see
different colors on screen. We use custom color settings for clear presentation.)
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Pick and sketch a three point spline that passes through the references for chains as

shown below (View shown after picking ).

Now create the spline tangency dimensions as shown below.
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To add spline tangency dimension at a point, click the spline, then click the geometry to which
the spline tangency is to be defined and then click the endpoint where the tangency is to be
defined. Then click the middle mouse button to place the dimension.

Pick to complete the sketch.

Pick to complete the feature and surface will display as shown below.

Notice that cross-section remains aligned to the chains all along the sweep feature.

Mirroring the surfaces

Now we will mirror the surface, so select it as shown below.

While the surface geometry is selected, pick on the Model tab to invoke the Mirror tool.

Select the FRONT datum as Mirror plane.

Pick to complete the feature. Part will appear as shown below.
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Merging the surfaces

Now we will merge the surfaces together.

So select the surfaces, shown in the figure below, while holding down the Ctrl key. (order of
selection is not important)

Pick on the Model tab to invoke Merge tool.

Pick tab and change the merge type to Join.

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick or middle-click to complete the merge feature.

Select File > Save to save the work done so far.
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Exercise 3

In this exercise we will fix a distorted boundary blended surface.

Set the working directory to the EXAMPLES folder and open the model BASE_NECK.PRT

The part will appear as shown below.

You should notice that neck of this part appears distorted. This neck is defined by a boundary
blended surface. So we will fix this surface. This problem occurs often while creating boundary
blended surfaces, so it is important to know how to fix it.

Modify the surface

We will redefine this surface feature and fix it.

Right-click the “Boundary Blend 1” feature in model tree and select .
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Notice the location of start point for fist Chain as shown below.

Now pick tab to view Curves slide-up panel. Here pick on the second chain as shown
below.

Now system will show the Start Point for second chain as shown below.

If you compare the location of Start Point for first and second chain then you can easily conclude
that surface is distorted due to mismatch of Start Points. So we will change the location of Start
Point of second chain so that it corresponds to the Start Point of first Chain.

Take your mouse pointer over the Start Point and hold down left mouse button. Then drag and
drop it as shown in the figure below.
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Now the surface will appear as shown below.

Apply the Tangent constraint for second chains as shown below.

Pick to complete the feature and surface will appear as shown below.
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Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will build a shampoo bottle. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model BOTTLE.PRT

Building Body

First we will build the quilts that represent the body of the bottle.

We need to offset the outer quilt to create the quilt for the step visible in above figure.

So pick the quilt as shown below. You can use the Quilt filter if you have difficulty in selecting
the quilts.
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Pick on the Model tab to invoke Offset tool and enter 2 as the offset value on the
dashboard.

Pick to reverse the direction of feature creation so that surface is offset inwards as shown
below.

Pick icon to complete the feature. (Leave the offset type to Standard, which is default)

Now we will merge the quilts. So select quilts, shown in the figure below, while holding down the
Ctrl key. (Notice that offset quilt is not selected but the original quilt). You can use the Quilt filter
if you have difficulty in selecting the quilts.

Pick on the Model tab to invoke Merge tool and preview will appear as shown below.
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Pick or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below.

Now we will merge the new quilt (created after merge operation) with the quilt created by offset
operation.

So select quilts, shown in the figure below, while holding down the Ctrl key. (You can use the
Quilt filter if you have difficulty in selecting the quilts)
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Pick to invoke Merge tool and then so that preview appears as shown below.
(Notice the direction of arrows)

Pick or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below. (If not then go back and fix it)
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Building Neck

Now we will create the neck details for the bottle. For this purpose we have already created a
surface but it is hidden.

So right-click the “NECK” feature in the model tree and pick Unhide.

Now part will appear as shown below.

We will create a boundary blended surface that connects NECK with main body.

Pick and select the edge chain shown in figure below. (Tip: Place the mouse pointer over the
edge of the surface and right-click repeatedly until IntentEdg tooltip appears. When the tooltip
appears, select the chain with left mouse pick.)
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Now hold down the Ctrl key and pick the second chain using the Intent chain technique as
shown below.

If the preview of surface appears distorted, then fix it before proceeding. The procedure to fix the
distorted boundary blended surface was explained in previous exercise.

Apply the Tangent constraints for both chains as shown below.

Pick to complete the feature and surface will display as shown below.
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Building Bottom

Now we will create the bottom details for the bottle. For this purpose we have already created a
surface but it is hidden.

So right-click the “BOTTOM_CLOSE” feature in the model tree and pick Unhide.

We will merge the BOTTOM_CLOSE with the main quilt.

So select quilts, shown in the figure below, while holding down the Ctrl key.

Pick on the Model tab to invoke Merge tool and preview will appear as shown below.
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Pick or middle-click after making sure that arrows direction is as shown in the above figure.

Pick to access the Round tool.

Select the following edge chain for applying round.

Enter 3 as the radius value

Pick icon to complete the feature.

Thickening the Quilt

Before thickening the quilt, all surfaces should be merged together to form a single quilt. So first
merge operation will be performed.
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First we will merge the boundary blended surface of neck with the main quilts.

So select quilts, shown in the figure below, while holding down the Ctrl key.

Pick on the Model tab to invoke Merge tool.

Pick tab and change the merge type to Join.

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick or middle-click to complete the merge feature.

Now we will merge the NECK surface with the main quilts.

So select quilts, shown in the figure below, while holding down the Ctrl key.
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Pick on the Model tab to invoke Merge tool.

Pick tab and change the merge type to Join.

Pick or middle-click to complete the merge feature.

The part will appear as shown below. Notice that all the edges, except at opening, appear
magenta which means that all surfaces have been merged into a single quilt

Now we will thicken the quilt. So select the quilt.

Pick to invoke Thicken tool and enter 1 as the thickness on the dashboard.

Pick to reverse the direction of feature creation so that material is added to the inner side of
the quilt as shown below.
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Pick or middle-click to complete the feature. The part will appear as shown below.

Select File > Save to save the work done so far.
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Exercise 5

In this exercise we will complete a surface model of a door of drawer. The completed part is
shown below.

Set the working directory to the EXAMPLES folder and open the model DRAWER_DOOR.PRT

Before creating the desired surface, first we will create the datum curves which will be used to
construct the surface.

Creating the datum curves

We will create the datum curves using through points option.

Pick on the Model tab as shown below.

Pick the following vertex as first point for curve. (Set the view to ISO3 and part will appear as
shown below.)
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Pick the datum points one-by-one in the following order, PNT4 > PNT0 > PNT5, as shown in
figure below.

Pick the following vertex as last point for curve.

Now we will specify the tangent constraints for the ends of the curve.

So pick tab and change the 'End condition' for Start Point to Tangent.
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Now system wants to know a reference to which the new curve will be tangent, so pick the
following surface to make the new datum curve tangent to it.

Now change the 'End condition' for End Point to Tangent as shown below.

Again pick the following surface to make the new datum curve tangent to it at the end point.
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Pick to complete the feature. The datum curve will appear as shown below.

Now we will create second curve so again pick

Pick the PNT6 as first point for curve. (Set the view to ISO3 and part will appear as shown
below.)

Pick the PNT0 as end point.
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Now we will specify the tangent constraints for the ends of the curve.

So pick tab and change the End condition for Start Point to Tangent.

Now system wants to know a reference to which the new curve will be tangent, so pick the
surface shown in the figure below to make the new datum curve tangent to it at the start point.

Now change the End condition for End Point to Normal.

Select the DTM_OPENING datum plane as reference as shown below.

Select to reverse the direction so that curve appears as shown in figure below.
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Pick to complete the feature.

Creating the surface

Now we will create a surface with Boundary Blend Tool.

Pick and select the edge shown in the figure below.

Now hold down the Ctrl key and pick the following curve as second chain.
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Pick in the 'Second direction' collector to activate either on dashboard or in Curves panel.

Pick the edge, shown in the figure below (dynamic preview off) as first chain in second direction.
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Now hold down the Ctrl key and pick the datum curve, shown in the figure below as second
chain in second direction.

While holding down the Ctrl key, pick the edge, shown in the figure below as last chain in second
direction.
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Apply the Tangent constraints for the three chains as shown below.

Pick to apply the changes and exit the dashboard.

Select File > Save to save the work done so far.
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Exercise 6

In this exercise we will create a model for plastic chair. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model CHAIR.PRT. Because
this part is symmetrical so we will create half side of the part and then mirror it.
Required datum curves have already been created. You are encouraged to explore the way
these curves have been defined after completing this exercise.

Creating the surface

We will create a boundary blended surface by using the curves shown in the above figure.

Pick and select the curves, while holding down the Ctrl key, in the order shown in figure
below.
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Pick in the Second Direction Collector to activate it and while holding down the Ctrl key, select
the curves shown in figure below.

Apply the Normal constraint for the chain that lies on RIGHT datum plane as shown below.

This surface will be mirrored about RIGHT datum plane. Therefore to maintain tangency
between original and mirrored surface, the surface has been constrained Normal to the RIGHT
datum plane.

To make the mirrored and parent surface tangent to each other, we need to make the parent
surface normal to mirror plane.

Pick to complete the feature.
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Creating the Datum Curve for Trimming

Now we will create a datum curve that will lie on the surface we have created and then trim the
surface with this curve. First we will create four datum points to be used as reference for the
datum curve.

Pick on the Model tab to invoke Datum Point tool.

Now pick on the surface near bottom right corner. Look at the position of mouse pointer in the
figure below.

Pick in the Offset references collector to activate it.
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Now select the edge shown in figure below as offset reference and enter 45 as the Offset value.

Hold down the Ctrl key and select the side edge as second offset reference. Enter 25 as the
Offset value as shown below.

Pick to complete the definition of datum point.

Now we will create another datum point so again pick on the Model tab.

Pick the following datum curve as reference.
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Pick to change the measurement reference to right end of curve

Change the Offset option to Real and enter 55 as the Offset value as shown below.

Pick to complete the definition of datum point.

Again pick on the Model tab and select the following datum curve as reference.
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Change the Offset option to Real and enter 25 as the Offset value as shown below.

Pick to complete the definition of datum point.

Again pick on the Model tab and pick the surface near top right corner. Look at the
position of mouse pointer in the figure below.
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Pick in the Offset references collector to activate it.

Now select the top edge of surface as offset reference and enter 35 as the Offset value as
shown below.

Hold down the Ctrl key and select the side edge as second offset reference. Enter 35 as the
Offset value as shown below.
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Pick to complete the definition of datum point.

Now we will create a datum curve using through points option, passing through the four points
that we just created.

Pick on the Model tab to invoke Curve through Points tool.

Pick the following vertex as first point for curve.

Pick the datum points one-by-one in the following order, PNT4 > PNT5 > PNT6 > PNT7
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Pick the following vertex as last point for curve.

Pick to access the Placement panel and check the 'Place curve on surface' option.

As the Surface collector becomes active so pick the surface as shown below.
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'Place curve on surface' option is used to create a spline curve that passes through the selected
points and lies on a specific surface patch.

Now we will specify the normal constraints for the ends of the curve.

So pick tab and change the End condition for 'Start Point' to Normal.

Now system wants to know a reference to which the new curve will be normal, so select the
RIGHT datum plane as reference

Now change the End condition for 'End Point' to Normal and select the RIGHT datum plane as
reference.
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If you look at the end of curve, you will notice that it is twisted as shown below.

It is due to the wrong direction of normal constraint. So pick to reverse the direction.

Pick to complete the feature. The datum curve will appear as shown below.
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Trimming the Quilt

Now we will trim the quilt with this curve. So first select the quilt.

Pick on the Model tab to invoke Trim tool.

Select the newly created datum curve as trimming object and preview will appear as shown
below.

Pick or middle-click to complete the feature.

Mirroring the Quilt

Now we will mirror the quilt so first select the trimmed quilt.
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Pick on the Model tab to invoke Mirror tool and select the RIGHT datum as Mirror plane.

Pick to complete the feature. Part will appear as shown below.

Now you can merge both surfaces together.

Select File > Save to save the work done so far.
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Further material is not included in the free download. You can buy the complete
tutorials at http://www.caeuniversity.com/buy. Thanks for your review of the training
material.
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