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2. FACE MILLING
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3. VOLUME AND LOCAL MILLING
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4. ROUGHING AND REROUGHING
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5. PLUNGE MILLING
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6. PROFILE MILLING

Creo 4.0

Profile milling NC Sequence is a 2.5 axis sequence. It is usually used to semi-finish or finish the
vertical or slanted surfaces. The surface finish can be controlled with Step Depth adjustment or

Scallop Height parameter.

The required references are surfaces which may be the selected surfaces of either of the
Reference model, Mill Surface or Mill Volume. It automatically degouges the tool path against the

references selected for the cut geometry.

Locating Cutting Parameters

There are a lot of cutting parameters associated with the sequence. You can see all the

parameters by picking Al tab on the Edit Parameters dialog box.
Edit Parameters of Sequence "Face Milling 1" - = x
Eile Edit Information Tools
Parameters |Basic] All | Category: All categories e
5 d=
Parameter Name Face Milling 1
CUT_ANGLE 0
END_OVERTRAWVEL 5
START_OVERTRAVEL 5
SCAN_TYPE TYPE_SPIRAL
CUT_TYPE CLIMB
CLEAR_DIST 1
EAPPRDACH_DISTANCE 5
EVIT MicTANCE
oK Cancel * Show Details

If you don’t know the exact location of a parameter then it is better to arrange the parameters
alphabetically by picking Tools > Sort Parameters > By Parameter Name and then you can

easily locate the desired parameters.

12
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Edit Parameters of Sequence "Face Milling 1" - & x

File Edit Information Tools

Parameters |Basic| All | C  Relations —i:.
5 Sort Parameters Vo Default Sort
Parameter Name Parameter columns.. oy Fmmeierblore
STEPOVER_ADJUST Visibilify by Parameter]l
TRIM_TO_WORKPIECE O Show All Value Columns
LACE OPTION NO
CUSTOMIZE_AUTO_RETRACT YES
BEOUND_CURVE NO
CLEAR_DIST 1
PULLOUT_DIST -
INITED NCT UCHTUT Rt
| OK | ‘ Cancel #+ Show Details

This can also be achieved by picking on the column "Parameter Name".

Edit Parameters of Sequence "Face Milling 1" - & x
Eile Edit Information Tools
Parameters i@@| Category:! All categories v
5 []
Parameter Name Face Milling 1
NUMBER_CUTS 2 .
SCAN_TYPE TYPE_SPIRAL
CUT_TYPE CLIMB
STEPOVER_ADJUST YES
TRIM_TO_WORKPIECE NO
LACE_OPTION NO
CUSTOMIZE_AUTO_RETRACT YES
Dl KM IR IC (Al ol

Ok | [cancel|  # Show Detais

13
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EXERCISE 1

In this exercise we will define a profile milling NC Sequence to machine vertical walls of a block.
The topics covered in this exercise are as follows

%+ Defining a new Profile Milling NC Sequence
« Selecting the surfaces using Loop option

% Creating smooth entry/exit motions

% Optimizing the entry/exit conditions

Set the working directory to INSERT and open the model insert.asm.

For better visualization it is good to display the workpiece in wireframe. So select View

|
Manager icon =@ to launch the View Manager Dialog box and double click the predefined style
state Wireframe.

View Manager X
Orient Appearance A

Simp Rep Style Sections Layers

New Edit ~|| ® Options ~

Names

Blank

+ Wireframe

Default Style

Master Style

Properties > > Close

Select  ©°%  to exit the dialog box.

To define a new profile milling NC Sequence, select Profile Milling icon ( J—} ) on Mill tab.

14
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Annotate Tools View Applications Mill

n. j & Mill Volume :fp I Face 15 Surface Milling H;_T 4 Engraving
skatch Mill 9 Mill Surface Roughing 2 Re-rough L2 Finishing Trajectory ¥ Round
tem Window 7 Drill Group = |Jl Profile Milling|&- Corner Finishing Milling ~ 9 Chamfer
Manufacturing Geometry - Milling ~
Pick the T icon and Tools Setup dialog box will pop up.
2 No too v | 5o K+ NC_ASM_DEF_CSYS:F4(CS
Reference Parameters Clearance Check Surfaces Options

In the Tools Setup dialog box pick FEM20 from the list and select = “¢

Pick  "¢®"®"°® tah and notice that the Machining Reference collector becomes active.

T | o1:FEMm20 + & % NC_ASM_DEF_CSYS:F4(CS
Reference Parameters Clearance Check Surfaces Options
Type
Surface T

Machining References:
o Select items

Details

Here we will use the Loop selection technique to select the desired surfaces quickly.

Now select the top face of the reference model as shown below.

15
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Pick this surface

Now hold down Shift key and place mouse pointer over any edge forming the boundary of the
selected surface.

Edge:F7(ROUND_1)kINSERT

Pick on the edge with left mouse to select the Loop Surfaces while Shift key is held down. The
selected surfaces will appear as shown below.

Type
! Surface I'J

Machining References:

' Loop Surfaces

Scallop Surfaces:
Click here to add item

l.Detailsi

16
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Loop option is used to select a closed loop of surfaces by choosing a face they surround.

Now pick |_Parameters | 41 and enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 5
CLEAR_DIST 1
SPINDLE_SPEED 3000

Now pick | ""°Pe€S [ 4ah and enter PROFILE as the name of the sequence.

To display the toolpath on screen pick —H " icon. Play Path Dialog box will appear.

>

Click the Play Forward button and toolpath will appear as shown below.

Zoom to the toolpath and look at it carefully, you will notice that the tool plunges directly to the
next slice.

17
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Direct plunge is not a good practice. To introduce smooth entry/exit into the cut, parameters
need to be changed.

>
So pick Parameters 4k and then —  icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 30

You can see all these parameters by picking Al

category as shown below.

tab and changing to “Entry/Exit Motions”

Edit Parameters of Sequence "PROFILE" - B X

File Edit Information Tools

Parameters |Basic| All Category: | Entry/Exit Motions -
d=

Parameter Name = PROFILE

CLEAR_DIST 1

CUT_ENTRY_EXT LEAD_IN

CUT_EXIT_EXT LEAD_OUT

END_MOTION DIRECT

ENTRY_ANGLE 90

EXIT_ANGLE 90

EXIT_DISTANCE =
HELICAL_DIAMETER =

LEAD_RADIUS 30
NORMAL_LEAD_STEP 0
OK Cancel * ishow Details

Pick = ©€ to apply the changes and exit the Edit Parameters Dialog box.

Now play the tool path using PLAY PATH dialog box. From TOP view it will appear as shown
below.

18
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=]

-

PROFILE MILLING

Although now tool enters and exits into the cut very smoothly but it is wasting a lot of time in non-

cutting motion. To reduce this non-cutting time, again pick '

following parameters. You will find these by picking
Motions” category.

All

e
- in Parameters panel and set the

tab and changing to “Entry/Exit

ENTRY_ANGLE

50

EXIT_ANGLE

50

Pick to apply the changes and exit the Edit Parameters Dialog box.

Now play the tool path using PLAY PATH dialog box. From TOP view it will appear as shown

below.

=]

£l

Notice that the non-cutting motion has been reduced significantly. The Entry and Exit angles
must be sufficient large so that tool makes the plunge motion when it is out of the workpiece.

The entry/exit parameters can be readily understood from the figure below.

19
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LEAD OUT 0
l EXIT_ANGLE = 80

A

—LEAD_RADIUS

T ANGLE

|
ENTRY_AMGLE |
" =

!

LEAD M EMTRY_AMGLE = 70"

It is always advantageous to use a large LEAD_RADIUS because larger the radius, smoother
the entry/exit into cut. But it also increases the idle time while the tool completes its non-cutting
movement. To reduce this non-cutting time we have set the ENTRY_ANGLE and EXIT_ANGLE
to a smaller value than default. By doing this we have achieved both i.e. smoother motion by
setting a large LEAD_RADIUS value and reduction in non-cutting time by smaller entry/exit
angles.

As the toolpath looks satisfactory so change the following parameters for final toolpath
computation.

| STEP_DEPTH 2

Pick ol to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.

20



Chapter 6 PROFILE MILLING

EXERCISE 2

In this exercise first we will define a Mill Surface to find the area which previous Ball End Mill
cutter could not machine. Then we will machine this surface with a Profile Milling NC Sequence.
The topics covered in this exercise are as follows

% Defining a Mill Surface as “Machinable Area”
+ Creating smooth entry/exit motions

The Machinable Area Mill Surface is an advanced technique that calculates whether the
selected surfaces can be entirely machined with the selected cutting tool, and creates explicit
surface representations of the millable area (the portion of the selected surfaces that can be
milled), as well as of the remainder area (the portion that can not be milled with the selected tool).

This technique allows to automate surface selection for subsequent machining with a smaller
tool or with a different machining strategy.

You have to specify surfaces to be milled, additional surfaces for gouge checking (if any), the
cutting radius of a ball end mill tool and the tool axis orientation. The system then calculates the
machinable area based on tool contact and gouge avoidance.

The manufacturing model, referred in this exercise, has been finish machined in the previous
chapter “Volume and Local Milling” with a ball end mill of diameter 10mm. So for this exercise we
assume that the reference model was previously finished with the ball end mill.

Set the working directory to TOP_COVER and open the manufacturing model top_cover.asm

For better visualization it is good to display the workpiece in wireframe. So pick =@ icon to
launch the View Manager Dialog box and double click the predefined style state Wireframe.

First of all we will define a Mill Surface to be later referenced in the Profile sequence.

So pick j on the Mill tab to invoke the Mill Surface Tool.

Analysis Annotate Toaols View Applications Mill

F o, et |_—'th Mill Yolume _rJ— A Face [iZ, Surface Milling i 4]/ Engraving
e, |
g il = = "

Ew [T Mill Surface ¥ Re-rough I Finishing “ Round
Sketch Mill Roughing | Trajectory

‘dinate System Window % Drill Group - _?-_i' Profile Milling I~ Corner Finishing Milling = [ Chamfer

aturmn * Manufacturing Geometry = Milling =

Pick = icon to give a name to this volume.

Enter MS_A as the name of the mill surface and pick = ©X

Pick 17 icon to define a "Machinable Area Reference" surface.
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Model Analysis Annotate Tools View Applications Mill Mill Surface

"\J et e Revolve ."I_.J ¥ Trim ¥ Round Tf/ I:' %, Sloped )
ket | Birude ﬁil Sweep Merge _] Extenc ¢ Draft Boundary Eill L Machinable Area Reference
stem # Swept Blend *| Offset Blend N Remove X
| Shapes~ ‘ Editing ~ Engineering Surfacing ™ | Controls

System will ask to select the surfaces for finding the machinable area. So pick the highlighted
surface of reference model shown in the figure below.

Select| % or middle-click to proceed.

Select X

Select 1 or more items.

oK Cancel

In the SRF PRT SEL menu, check the Add Ref Prts option then select Done/Return.

Menu Manager

' SRF PRT SEL

v Add Ref Pris
Sel Surf

Done/Return

When Add Ref Prts (Add Reference Parts) option is checked, system uses all the surfaces of the
reference model to check gouging against.

Now the system will ask to enter radius of ball end mill for calculating Machinable Area.

22
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So enter 5.2 and pick c&a icon or middle-click.

Although we should enter 5 as we used Ball end mill of diameter 10 to machine the cavity in a

previous NC Sequence, we have entered a larger value just to make sure that we get continuous
and smoother surface.

Now select the top surface of the reference model as the direction reference. The surface is
highlighted in the figure below.

You may also pick the retract plane or any other surface or plane that is parallel to the retract
plane.

Make sure that arrow points upward then select Okay.

This direction of the arrow specifies the tool axis orientation.

Double-click the Srf Option in the dialog box.

23
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Creo 4.0

SURFACE: Machinable Area x
Element Info
Machine Srfs Defined
Check Srfs Defined
Tool Radius Defined
Tool Axis Defined
Srf Option Defined
Define Refs Info
OK Cancel Preview

In the MILLABLE OR REMAINING menu select Find Remaining Area > Done.

¥ MILLABLE OR REMA

Menu Manager

Find Millable Area

Find Remaining Area

Done
CQuuit

Find Remaining Area option finds the portion of the surface that can not be milled with the

specified tool.

Select  “€  to exit the dialog box. The surface will appear as shown below.

Now we will trim the unwanted part of the surface. We will use the extrude tool to trim the

unwanted part of the surface.

4
So pick -~ icon to invoke the Extrude Tool.

24
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Analysis Annotate Tools View Applications Mill Mill Surface

@ 5% Revolve | @ Trin ¥ Round I,/II/ I:' %) Sloped =
— L - h -a: "y . E, % g
Eadrale .:HSweep L Draft Boundang il Machinable Area Reference
#' Swept Blend 7| Offset Blend S Remove x
Shapes~ Editing ™ Engineering Surfacing ™ Controls
Pick = Define. tab in the Placement panel.
4k ~|[154.09 - H T I ® 5w 60 v x
_ b e
Placement Options | Properties
Sketch
® Select 1 item Define..

Pick ASM_RIGHT as the Sketch Plane ASM_TOP datum as Right Orientation Reference.

Sketch X
Placement
Sketch Plane
Plane ASM_RIGHT:F1(DATUM PLANE)

Sketch Orientation
Sketch view direction | Flip |

Reference | ASM_TOP:F2(DATUM PLANE)

Orientation || Right i~

Sketch Cancel

Now sketch a rectangle after choosing suitable references as shown below.
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35.00

e i
L:'— 6.00

Creo 4.0

Exact dimensions are not important. The size of rectangle should be such that it encompasses
the upper part of the visible surface.

Pick v to complete the section

Pick v so that the extruded surface trims the existing quilt.

Select Through All for both the Side1 and Side 2 in the Options slide-up panel as shown below.

= i Ol Quilt | 1 item(s)
Placement Options Properties
Depth

Side 1 | 4 EThrough All

Side 2 | 4 £ Through All

Pick on the Material Side arrow to flip the direction as shown below.

26
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Chapter 6 PROFILE MILLING

Now the system will keep the inner side of the sketch.

-
Pick the |V_’ icon to exit the Extrude tool.

The mill surface will appear as shown below (after highlighting).

Pick ¥ and it completes the definition of the mill surface. if you don’t get the shown result then
you need to redefine the features and fix the problem otherwise you will not be able to do the
remaining exercise.

Analysis Annotate Tools View Applications Mill Mill Surface
ZF o Revolve -TJ | & Trim ¥ Round [ '{// I:' %, Sloped =

e 4 Extend | O . i i
Bt “;Sweep Merge ; E & Draft Seundaty il 4 Machinable Area Reference
# Swept Blend 7 Offset Blend Y Remove X
Shapes~ Editing = | Engineering Surfacing ™ Controls |

The references for a profile milling NC Sequence can also be selected before invoking the NC
Sequence. In this exercise we will do so.

So select the the previously defined “MS_A” mill surface in the model tree and pick Profile
Milling as shown below.

27
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o TOP_COVER.ASM

 ASM_RIGHT
7 ASM_TOP
7 ASM_FRONT
¥+ ASM_DEF _CSYS
™ FSETPO
¥ SUPERMAX ; —
E Mo S AT
ﬂﬁ.DTM1 AT ﬁ I

OPD10 [SUPERMAX]

SRR

» (@ TOP_COVER.PRT
» <7 TOP_COVER_WP.PRT
(-] Surface id 858 [MS_A - MILL SURFACE]
> (2 Extrude 1 [MS_A - MILL SURFACE]
# Insert Here

A Profile Milling

Insert a profile milling step.

Pick the ]T icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box pick FEM10 from the list, then select = ©%

Pick | €7 {ah and notice that the Machining References collector contains the selected

surfaces.
Reference Parameters Clea
Type
Surface g

Machining References:
Quilt Surfaces

Details
A
Scallop Surfaces:
Click here to add item
Details

28



Chapter 6 PROFILE MILLING

Make sure the arrow attached to the mill surface points away from the surface. This direction
indicates side of surface to be machined.

| |
Now pick | "Mt [ ab and then " icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 0.5
CLEAR_DIST 1
SPINDLE_SPEED 4000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 15
EXIT_ANGLE 15

Pick E to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.
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As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH 0.2

Remember never to use WALL_SCALLOP_HGT parameter for controlling the surface finish,
while machining with a flat end mill.

Properties

Now pick tab and enter CORNER as the name of the sequence.

Pick W to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 3

In this exercise we will define a profile milling NC Sequence to machine a sharp corner with a
single pass of cutter.

Set the working directory to COVER_INSERT and open cover_insert.asm
, 5 .
To define a new profile milling NC Sequence, select Profile Milling icon ( &— ) on Mill tab.

From the drop-down list in front of 1|T icon, pick FEM25

Tﬂ' 2 No tool el ,:.._i. %j ACSO:FA(CSYS)
01 :FEM25
@ Mo too [ .
| ¥ Edit Tools.. lameters | Clearance _ Check Surfaces | thmns

Alternatively you can pick the 1|T icon to access Tools Setup dialog box and then select the tool.

Pick  "€®"®"°®  tah and notice that the Machining Reference collector becomes active.

Select the model surfaces (while holding down the Ctrl key) as shown in the figure below.

= relividual Surfaces

Now pick | "M [ ab and then " icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.
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CUT_FEED 1200
STEP_DEPTH 50

CLEAR _DIST 1
SPINDLE_SPEED 3000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20

The large value of STEP_DEPTH will force the tool to machine only the last slice.

Pick = “X  to apply the changes and exit the Edit Parameter Dialog box.

Properties

Now pick tab and enter CORNER as the name of the sequence.

Play the toolpath using PLAY PATH dialog box and notice that the tool is machining the
complete surface with only a single pass as shown below.

N

Pick bl to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 4

In this exercise we will use the profile milling NC Sequence to finish a hole. We will also learn the
following

7
X4

D)

How to control the plunge location of the tool
How to perform multi-pass machining

How to mirror a NC Sequence

Playing the tool path for multiple Sequences

R/ *
RXCER X4

*
X4

L)

We assume that the hole has been previously drilled with the drill of diameter 12mm.

Set the working directory to LID_CAVITY and open the manufacturing model lid_cavity.asm.
To define a new profile milling NC Sequence, select Profile Milling icon ( Ul—} ) on Mill tab.

From the drop-down list in front of rﬂ. icon, pick FEM10

Pick | "¢®" {ah and notice that the Machining Reference collector becomes active.

Select the model surfaces (while holding down the Ctrl key) as shown in the figure below.

e ' 2
Now pick | " @Tete’s [ tab and then " icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 2
CLEAR_DIST 1
SPINDLE_SPEED 5000
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COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 8

Pick = “X  to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

Hole | Isometric View |
3 1,

Toal

Notice that there is no lead in or lead out motion. System also warns about this by showing this
message.

AWARNING: Lead out motion will cause gouging, it is ignored.

It is so because lead radius value is larger than the radius value toolpath consists of. This fact
can be elaborated by the following figure.

" T

Tool
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Please notice that “10” is the radius of the hole and 5 is the radius of the tool path arc. In this
case tool will gouge the part while making lead in or lead out motion therefore system has
ignored them.

So we should set the lead radius less than 5 (radius of toolpath arc) to make sure that tool
makes lead in and lead out motions.

So set the following parameter in Edit Parameters Dialog box.

LEAD_RADIUS 4

Play the toolpath using Screen Play. It should appear as shown below.

As we assumed at the start of the exercise that the hole was pre-drilled with the drill of 12mm
diameter . So the tool will be cutting material during plunge motion because there is enough
material at the walls of the hole. The tool must plunge to the next slice at the center of the hole to
avoid cutting of material during plunge motion.

Options

So pick tab and click inside the Approach Axis collector to activate it.
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s Annotate  Tools  View

plications  Mill Profile Milling

. & & [ W-n [ =

Check Surfaces Options Tool Motions Process Properties

Cutting Tool Adapter
I | &
Approach Axis:

‘_ Select 1 item ‘

O First Slice Only
Exit Axis:
‘ Click here to add item ‘

[ Last Slice Only

Select the axis AA_1 as Approach axis as elaborated below.

AA_T:F10(DATUM AXIS)

Now pick in the Exit Axis collector to activate it and select the axis AA_1 as exit axis.
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Cutting Tool Adapter

Approach Axis:
AA_T:F10(DATUM AXIS)
L1 First Slice Only

Exit Axis:
AA_1:F10(DATUM AXIS)

L] Last Slice Only

Pick PArAMELErs | 4ab and set the following parameters

| PLUNGE_FEED 100

PLUNGE_FEED parameter controls the feed rate along the plunge motion. By default it is set to
dash (-) in which case the CUT_FEED is used as PLUNGE_FEED.

Play the toolpath on screen using PLAY PATH dialog box and notice that the tool is plunging
right on the axis AA_1 as shown below (tool not shown).

e B

You should notice that tool is climb milling the hole surfaces.
We can machine the hole in multiple passes so that we don’t have to define separate sequences

for semi-finishing and finishing toolpaths.

2y
Pick '~ in the Parameters panel and set following parameters to machine the hole in two steps.
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NUM_PROF_PASSES

PROF_INCREMENT

These parameters can be found in “Cut Depth and Allowances” Category as shown below.

Edit Parameters of Sequence "Profile Milling 1* - & X
File Edit Information Tools
Parameters |Basic| All | Category:| Cut Depth and Allowances |~
2 d=
Parameter Name Profile Milling 1
TOLERANCE 0.01
NUM_PROF_PASSES 2
PROF_INCREMENT 0.3
PROF_STOCK_ALLOW 0
CHK_SRF_STOCK_ALLOW - =
oK Cancel #* Show Details

NUM_PROF_PASSES together with PROF_INCREMENT allows to create multiple profiling

passes horizontally offset from each other.

NUM_PROF_PASSES specifies the number of passes that will be generated.

PROF_INCREMENT specifies the horizontal distance between the passes generated according
to NUM_PROF_PASSES.

Play the toolpath on screen using PLAY PATH dialog box. It will appear as shown below.
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Notice that the tool first machines the walls from top to bottom of the hole at the offset specified
by PROF_INCREMENT then retracts and again machines the walls from top to bottom without
PROF_INCREMENT. This type of machining is called PASS BY PASS scanning. We can
machine the hole by fist making the profile passes specified by the NUM_PROF_PASSES at the
given z level and then plunging down to the next slice. This type of machining is called
SLICE_BY_SLICE scanning. The scanning strategy is specified by the SLICE_PATH_SCAN
parameter.

As the toolpath looks satisfactory so change the following parameters.

STEP_DEPTH 0.5

Properties

Now pick tab and enter FINISH as the name of the sequence.

Pick v to save the changes and close the dashboard.
Now we will mirror this sequence to machine the second hole.

So select the FINISH sequence in the model tree and pick Edit > Mirror Step on the Mill tab.

uring Model Analysis Annotate Tools View Applications Mill

:i::;J D / Axis :J, & Mill Volume Tr I Face = sy
nan| . | =¥ i _.-"
=* Point ~ : 3 Mi . 7 Re-roug} IAFi
Pattern = Plane Point Sketch Mill = Witk Roughing Re-rough e
T i+ Coordinate System Window 5 Drill Group * o profile Milling - Cc
Edit~ Datum ~ Manufacturing Geometry ™ N
Mirror Step |

In the NC Sequences Mirroring dialog box, pick | &/t

Mirror NC Sequences

1: FINISH, Operation: OP010

Mirror plane:

Select...

Cutting conditions: ® Keep O Mirror

oK Cancel
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Select the datum ASM_RIGHT as mirroring plane.

Mirror NC Sequences x

‘ 1: FINISH, Operation: OPO10 ‘

Mirror plane:

Plane id #3 [select..]

Cutting conditions: ® Keep O Mirror

oK Cancel

Notice that the option “Keep” is selected by default for Cutting Conditions in the dialog box

Pick to complete the mirroring operation.
Select the MIRROR_FINISH sequence in the model tree and pick Play Path.

[@ LID_CAVITY.ASM
£ ASM_RIGHT
7 ASM_TOP
£7 ASM_FRONT
=%+ ACSD

» (@ LID_CAVITY.PRT
i® FSETPO

R T N
(%]
e
o

I MACHO1

Y oP010 [MACHO1]
; AA1

ﬁ';;l. FI.NISH. [OP010] | 1l Play Path
«J2. MIRROR FINISH [OP010]:
% Insert Here

Display toolpath.

Play the toolpath on screen using PLAY PATH dialog box. It will appear as shown below.
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Notice that tool is Climb milling the hole surfaces. It is so because the option “Keep” is selected
for Cutting Conditions in the NC Sequences Mirroring dialog box

Now we will play the tool path for both of the sequences together.

Select the both sequences in the model tree while holding down the Ctrl key and pick Play Path.

[0 LD _CAVITY.ASM

7 ASM_RIGHT
7 ASM_TOP
7 ASM_FRONT
%+ ACSO
» (@ LID_CAVITY.PRT
& FSETPD D .
& ADTMA4 ® 3
T# MACHO1 e
J§ opo10 IMACHO TS
{AAT Ll Play Path
:; g;{rwrmm Display toolpath.

® Insert Here

Click the Play Forward button |;J in the Play Path Dialog box. Toolpath will appear as
shown below.

41



Creo NC - A Practical Approach Creo 4.0

Select File > Save to save the manufacturing model.
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EXERCISE 5

In this exercise we will define a profile milling NC Sequence to machine an undercut, with a
special round insert milling cutter.

The topics covered in this exercise are as follows
% Defining a side milling cutter
+ Selection of surfaces by loop option

% Checking gouges visually, by placing the tool at desired location on the tool path

The cutter to be used in this exercise is shown below.

Found Insert Cutter from Sandvil

Set the working directory to BACK_PLATE and open the manufacturing model back plate.asm.

Change the view to Front and zoom in to the reference part and see that lower surfaces of the
plate form an undercut.

-.‘—-

Conventionally, to machine this undercut we will need to machine first from top side and then
invert the plate and machine the bottom side i.e. two separate operations in Creo NC. By using
the special round insert cutter we will machine the complete plate with only one operation.

R

1
To define a new profile milling NC Sequence, select Profile Milling icon ( »— ) on Mill tab.

Pick the T icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box, define a new “Side Milling” cutter of diameter 25. Other parameter
of the tool should be as shown below.
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General | Settings CutData BO

Name:
SIDEZ2S

Type:
SIDE_MILLING -

Material:

Units:
Millimeter *

Number of Flutes:

4+ Hide Details

Geometry

Offset Table

d

Creo 4.0

75

Pick = “PPY tab and tool will appear in the Tools List.

oK Cancel

To see the tool in separate window click 2 in the dialog box and the detailed sketch of the tool

will appear as shown below.

Fa

SIDEZ5

[’16

25

i

Pick = ©1°s¢ | to close this window.
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Select L 9K | to complete the definition of the tool.

Pick Reference

PROFILE MILLING

tab and notice that the Machining Reference collector becomes active.

Here we will use the Loop selection technique to select the desired surfaces quickly.

Now select the bottom surface of the reference model as shown below. (Set the view to ISO2 to

avoid any ambiguity.)

Standard Orientation
Default Orientation

(Hleack

(K BOTTOM

() FRONT

1501

1503

iﬁ_ Reorient...

Now hold down Shift key and select any edge forming the inner loop of selected surface as

shown below.

Pick this edge

After releasing the Shift key, the selected loop of surfaces will be highlighted as shown below.

45



Creo NC - A Practical Approach Creo 4.0

Type
‘ Surface I'I

Machining References:

Loop Surfaces

e ey

_DEF_CSYS

Details
Scallop Surfaces:

Click I'_uere to add item

<

Now pick . "@Me€s  tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 3

CLEAR DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 20
EXIT_ANGLE 20

We have set the large value of STEP_DEPTH to make the computation of the toolpath faster.
Later when the toolpath has been fine tuned, we will change it to suit the surface finish required.

Pick| Ok !to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box and it will appear as shown below.
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Change the view to Front and zoom-in to see that toolpath has followed the surface forming
undercut as shown below (in Wireframe mode).

'3 X

Eﬂlaj |-jn_||:E] :':f‘:'{, q PN

Standard Orientation
Default Orientation

W
=

To check visually if the tool is gouging anywhere on the part, pick i icon on the PLAY PATH

dialog box.

PLAY PATH x
File View NCL File
P CL Data
-4
|44 4
Tool Clearance... Position Cutting Tool| [}
Display Speed
=
L
Slow Fast
Close

Now pick on the toolpath as shown below.

5

— | Pick here ontoolpath

47



Creo NC - A Practical Approach Creo 4.0

The tool will move to the picked point as shown below.

=

il

Notice that tool shank is clear of the reference part surfaces and does not gouges the part
anywhere.

To be sure, that the tool does not violate the reference part, we should perform the gouge
checking.

So select -‘!J' icon on the dashboard as shown below.

Annotate Tools View Applications Mill Profile Milling
) & & WRn B x
_I:J
“heck Surfaces Options Tool Motions Process Properties ..Ef
1

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.

Menu Manager

¥ MFG CHECK

Gouge Check
Done/Return
¥ SRF PRT SEL
[ Add Ref Pris|
Sel Surf

Done/Return
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When Add Ref Prts option is checked, system adds all surfaces of the reference part for gouge

checking.

Select Done > Run.

Menu Manager

* MFG CHECK

Gouge Check

Done/Return
» SRF PRT SEL
v Add Ref Prts
Sel Surf
| DunefReturn|

System will report that no gouges are detected.

Menu Manager

* MFG CHECK

Done/Return

¥ GOUGE CHECK
Surfaces
Tolerance
Step

Done/Return

EINo gouges were detected.

It is always good practice while machining undercut to use larger values for ENTRY_ANGLE and
EXIT_ANGLE parameter. So that on the retract path tool does not gouges the part.

As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH

0.2

Now pick Properties

Pick bl to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.

tab and enter UNDERCUT as the name of the sequence.
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EXERCISE 6

In this exercise we will define a profile milling NC Sequence to machine an undercut with a T-slot
cutter.

The topics covered in this exercise are as follows

% Defining a new profile milling NC Sequence to machine and undercut
Defining a new Key cutter

Introduction to NORMAL_LEAD_ STEP parameter

Inserting a CL Command at the end of CL Data

Patterning a NC Sequence

Generating CL Data for a patterned NC Sequence

Gouge checking patterned NC Sequence

X3

*¢

X/
°

X3

*¢

X/
°

X3

*¢

X/
°

Set the working directory to FLOAT _PLATE and open the manufacturing model float_plate.asm.

Change the view to FRONT and zoom-in to the reference part and see that each bore has an
undercut.

|Inder Cut

To define a new profile milling NC Sequence, select Profile Milling icon ( _,—} ) on Mill tab.

Pick the T icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box, define a new tool of type “Key Cutter” with a diameter 16. Other
parameter of the tool should be as shown below.

50



Chapter 6 PROFILE MILLING

General | Settings CutData BOM & Offset Table

Name: Geometry

T SLOT
Type: | - —

KEY CUTTER -
Material: & (s — -

Units: ol : e
Millimeter ¥ |<7 4>|

Number of Flutes:

4 Hide Details . OK || Cancel

Pick .~ “PPY  tab and tool will appear in the Tools List.

To see the tool in separate window click &2 and the detailed sketch of the tool will appear as
shown below.

T_SLOT - 0O X

40,00

Pick  €°s¢ | to close this window.
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OK

Select to complete the definition of the tool.

Pick  "€®™®"°® {ah and notice that the Machining Reference collector becomes active.

Select the surfaces forming undercut of first hole as shown in the figure below (view is set to
ISO2). It is important to select the surfaces belonging to the first instance in the pattern as it will
allow to reference pattern the NC Sequence.

Standard Orientation —

Default Orientation

(Hleack

(EsoTTOM

() FRONT

1501

1503 v

ig_ Reorient...

: ' >
Now pick = "#@Mete’s  tab and then " icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 800
STEP_DEPTH 2

CLEAR _DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 15
ENTRY_ANGLE 25
EXIT_ANGLE 25

It is always good practice while machining undercut to use larger values for ENTRY_ANGLE and
EXIT_ANGLE parameter. So that on the retract path, tool does not gouges the part.

Pick = “X to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.
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Front Wiew Top View

To be sure, that the tool does not violate the reference part, we should perform the gouge
checking.

So select —-”!IJ' icon on the dashboard as shown below.

Annotate Tools View Applications Mill .Pmﬁ{eMinng

B @ WEn #Fx
J

“heck Surfaces Options Tool Mations Process Properties

e

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.

Menu Manager

¥ MFG CHECK

Gouge Check
Done/Return
w SRF PRT SEL
[ Add Ref Pris|
Sel Surf

Done/Return
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When Add Ref Prts option is checked, system adds all surfaces of the reference part for gouge

checking.

Select Done > Run.

Menu Manager

¥ MFG CHECK

Gouge Check

Done/Return
w SRF PRT SEL
vl Add Ref Prts
Sel Surf
| Dnne;’Return|

Menu Manager

¥ MFG CHECK

Gouge Check
Done/Return

* GOUGE CHECK
Surfaces
Tolerance
Step

Done/Return

System will report gouges by the following message at message area.

Gouges were detected.
AxTool gouges into part by -1.2322 .

Tool is gouging the part during plunge and retract motion. So we should modify the toolpath so
that tool clears the reference part during motions along z-axis.

So set the following parameter.

NORMAL_LEAD_STEP

You can find this parameters by picking ' #' | tab and changing to “Entry/Exit Motions” category

NORMAL_LEAD_STEP is the length of the linear movement that is normal to the lead-in or lead-

out motion.

54



Chapter 6 PROFILE MILLING

-
-

4l
&

LEAD OUT—> «LEAD_IN
/
i
N.L S
2 T
fe——
N.L S

MN_L S = NORMAL_LEAD_STEP

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

-,

To perform gouge checking pick —i" icon and check the Add Ref Prts option.
Select Done > Run. System will report that no gouges are detected.

Now we will insert an an Optional Stop at the end of the CL Data.

Soselect. 1291 Motions [y h and pick on |CLCommand |jeon
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Options Tool Motions Process Properties

<start of tool path= Profile Milling Cut
1. Full Depth Cut id 1043
1.1 Auto Plunge id 1045

1.2 Follow Cut id 1044 ! Tangent Exit ]
% Insert Here
Goto Point h
CL Command
In the CL Command dialog box pick | "M€" jcon.
CL Command X
Insert Menu
Command Location
Independent *
Cancel

In the “cmd edit” menu select LOADTL-OPTSTOP > OPTSTOP.
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..................................

AIR-CLRSRF
COOLNT-FROM
GOHOME-LINTOL
LOADTL-OPSTOP
ORIGIN-POSTN
PPFUN-ROTABL
SELCTL-TMARK
TOOLNO-UNITS
CYCLES
PROBE_CYCLES
PROBE_SETUP
SYNC_PT

Chapter 6

Menu Manager
¥ cmd edit
LOADTL
MACHIN
MODE
MULTAX
MULTAX on_off
OFSTNO
OPSKIP
OPSTOP

OPTSTOP command will appear in the dialog box as shown below.

| Independent

CL Command X

Insert

Command Location

oK Cancel

Menu

Select

Properties

Now pick

9K to exit the CL Command dialog box.

Pick h to save the changes and close the dashboard.

PROFILE MILLING

tab and enter UNDERCUT as the name of the sequence.
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Now we will pattern the sequence to machine all the undercuts. We will use the Reference
Pattern technique.

So right-click the NC Sequence in the model tree and pick Pattern

O FLOAT_PLATE.ASM

7 ASM_RIGHT

7 ASM_TOP

7 ASM_FRONT

2 ASM_DEF_CSYS

8 FSETPO

[T¥ SUPERMAX ; o515

£ ADTM1 . E& i

4 oP010 [SUPERMAX] :
> (3 FLOAT PLATEPRT L=
» &J 1. FACE [OPO10]

J 2. UNDERCUT [OP010]

#® [nsert Here

i Pattern

Create multiple instances of a feature to form a
pattern.

Notice that Reference is selected by default as shown below.

Reference ||| Reference type | Group *

Options Properties

Pick i icon or middle-click to complete the pattern.

Now we will create the CL Data file for the patterned toolpath. To do this first we will create a set
of patterned sequences.

t Save CL File for a Set

Selec on the Manufacturing tab as shown below.

|l | 2N Process Manager =" @ Mill Volume T Turn Profile '; +
g _J RAPID 5710004
== = B e FEDRAT B0,
. . o L=
Opeatin User Defined Mill (9 Mill Surface 14 Stock Boundary Play Savea Posta
- Window 37 Drill Group Path~ | CLFile™ CL File
Process ~ Manufacturing Geometry ~ Validate ~ | ma Save a CL File

| Save CL File for a Set
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Pick Create in the OUTPUT SET menu and enter Set_ UNDERCUT as the name of the set and
hit Enter key.

In the CREATE SET menu, select the first instance of the pattern and system will ask to include

all instance in the set. Pick . "®  to confirm as shown below.

Menu Manager
P QUTPUT SET
Delete i
w CREATE SET
L1OP010
[11. FACE
vl *2. UNDERCUT
[ 3. Profile Milling
L1 4. Profile Milling
L1 5. Profile Milling
[1 6. Profile Milling
Confirmation * 1 |O 7. profile Milling
Select All
e Pattern leader chosen. Do you want to include all instances in the set ? —
Done Sel
b bt Quit Sel

Select Done Sel in the CREATE SET menu.

Now select the Set_UNERCUT in the SELECT SET menu.

Menu Manager

w \OUTPUT SET.

Create
Modify
Delete
| Info
Done/Return
w SELECT SET
' |set_UNDERCUT |

In the PATH menu pick File and then Done
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Pick - 9 in the Save a Copy dialog box. The file set_undercut.ncl.1 will be created.

To display the toolpath on screen select Display > Done on the PATH menu.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

60

Menu Manager
¥ PATH
|

Rotate
Translate
Scale
Mirror
Units
Done Qutput
¥ PLAY PATH
' L Compute CL

Done

¥ QUTPUT TYPE
'MICLFile
LIMCD File

M Interactive
L1Batch

Ll Compute CL

Done
Chuit

Menu Manager

Rotate
Translate
Scale
Mirror

Units

Done QOutput

Menu Manager

w PATH

Display

File

Rotate

Translate

Scale

Mirror

Units

Done Output
¥ PLAY PATH
L Compute CL

Creo 4.0
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To perform gouge checking pick Validate > Gouge Check on the Manufacturing tab as shown
below.

UU =) Process Manager & Mill Volume Th Turn Profile U H?PTD S?EDH

—_— ) B —? FEDRAT GOOK3.
& i —

Opertion J User Defined Mill (™9 Mill Surface I Stock Boundary Play Savea Posta
<5 Step Parameters | Window 5% Drill Group Path~ | CLFile~ CLFile
Process ~ _ Manufacturing Geometry ™ Validate ~ | Output ™

|_-'J Gouge Check

Select the newly created file set_undercut.ncl and pick [EEpen ‘

Check the box Add Ref Prts and select Done > Run.

Menu Manager Menu Manager
¥ SRF PRT SEL ¥ GOUGE CHECK
[“'Add Ref Prts Filename

Sel Surf —p Surfaces
Done/Return Tolerance
Step
Run
Done/Return

System will report that no gouges are detected.

Although we could insert an optional stop in Edit Parameters Dialog box, but it will only appear at
the end of patterned MCD data i.e. once in the tape file. By inserting CL Command at the end of
CL Data, the Optional Stop will appear at the end of each patterned instance i.e. 6 times in tape
file for above case as shown in the figure below.
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E set_undercut.tap - Notepad |Z|[E||3__(|
File Edit Format Yiew Help

ooot1o

M1 GA0GE0GA4G40G49
M3 MOG T

Ma MO3 52000

h01

M1

So the machine operator may have the option to stop the machine at the end of machining each
bore and check the cutter condition or may perform some other task.

Select File > Save to save the manufacturing model.
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EXERCISE 7

In this exercise first we will define a “Sloped” mill surface and then use the profile milling NC
Sequence to machine it.

The topics covered in this exercise are as follows.

% Defining a Sloped Mill Surface
+« Introduction to Check Surfaces functionality
% Setting the “Configuration file” option related to check surfaces.

While finish machining a part it is preferable to machine the steep walls with a constant Z type
toolpath (as Profile and Volume Milling NC Sequence offer) and shallow surfaces with a little
step over (as Surface Miling NC Sequence offers). Sloped Mill Surface is used to classify
surfaces into Steep (near vertical) and Shallow (near horizontal) areas.

The criterion to classify surfaces into Steep and Shallow areas is the Slope Angle. At any given

point, Slope angle is defined as the angle between Surface Normal and the Direction Vector as
elaborated in the following figure.

Slope Angle

.\.

a+—— [lirection Vectaor

%
Surface Normal — 3

Direction vector is always parallel to the Z-axis and Surface Normal depends upon the topology
of the surface.

So a Flat surface has Slope angle of 0° and a Vertical surface has Slope Angle of 90°.

During the definition of Sloped Surface, we specify a Draft Angle. If a surface patch has Slope
angle greater than this Draft Angle it is considered a Steep area and if its value is lesser then it is
considered as Shallow area.

During the definition of Sloped Surface, we have the option either to keep the steep or shallow
side of the selected surfaces. When we select Keep Steep Side, the system keeps only those
portions of the selected surfaces where the Slope Angle is greater than the specified Draft Angle
value. And when we select to Keep Shallow Side, the system keeps only those portions of the
selected surfaces where the Slope Angle is less than the specified Draft Angle value.

Set the working directory to BASE_PUNCH and open the manufacturing model base_punch.asm.
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First of all we will define a Mill Surface to be later referenced in the Profile sequence.

So pick j on the Mill tab to invoke the Mill Surface Tool.

Analysis Annotate Tools View Applications Mill
A = [ Mill Volume Try - Face T, Surface Milling d]7 Engraving
Ew (T Mill Surface Ff Re-rough LA Finishing “ Round
Sketch Mill Roughing Trajectory
‘dinate System Window =5~ Drill Group - l_,i Profile Milling - Comer Finishing Milling ~ 1 Chamfer
atum T Manufacturing Geometry Milling ~

Pick iy icon to specify a name to this surface.
Enter MS_A as the name of the mill surface and pick | “X

Pick ' P%¢ joon to create a Sloped mill surface.

Analysis Annotate Tools View Applications Mill Mill Surface
% ‘?’ B i ) g * G
_l,‘ Jo Revolve Al ¥ Round .' / I:‘ ;SIoped
! - :' Evtand r 3 L 2 . o
Extrude ..iSweep e Dra Boundary Eil Machinable Area Reference
# Swept Blend | Offset Blend Y Remove x
Shapes~ Editing ~ Engineering Surfacing ™ Controls

We will use the Seed and Boundary surface selection method to speed up the surface selection
process.

Select the model surface as shown in the figure below as the seed surface.

Pick this surface

Now hold down the Shift key and select the following two highlighted surfaces as Boundary
surfaces.
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Pick these surfaces

After relieving the Shift key the system will highlight the selected surfaces as shown below.

Undary Surfaces

| 9K or middle-click.

Select X

Select 1 or more items.

| OK | |Cancel|

Now select the top surface of the reference model as the direction reference. Make sure that
arrow points upward. This direction is used for measuring the slope angle.
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Crv/Edg/Axis
Csys
Quit

Then select Okay.

Crv/Edg/Axis
Csys

Quit

Flip

Okay

In the message area system will ask to enter the Draft angle value. This value is used to classify
surfaces as steep or shallow.

Enter 60 and hit Enter key or middle-click.

Now select Keep Steep Side > Done

Menu Manager
Keep Steep Side

Keep Shallow Side
Done
Quit

Select | 9K to exit the dialog box.

Pick ¥ and it completes the definition of the mill surface.

To define a new profile milling NC Sequence, select Profile Milling icon ( D—u ) on Mill tab.
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From the drop-down list in front of ﬁ. icon, pick BEM10

01:BEM10

- Glé%x

ASM_DEF_CSYS:F4(CSYS) |

Chapter 6

‘ Reference

Parameters

Clearance

Check Surfaces

Options

PROFILE MILLING

Pick

Reference

tab and notice that the Machining Reference collector becomes active.

Pick the currently defined mill surface MS_A and make sure that arrow points outward as shown
in figure below.

Now pick

Parameters

=
tab and then
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1000
STEP_DEPTH 3

CLEAR DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 15
EXIT_ANGLE 15

icon on the Parameters panel to open the Edit
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Pick‘ Lo ‘to apply the changes and exit the Edit Parameter Dialog box.

Creo 4.0

Play the toolpath using PLAY PATH dialog box and notice that tool is gouging the part as shown

below. (You can also use the Gouge Check functionality i.e. by picking i.£; to confirm gouging)

To avoid the gouging we will declare the reference part to act as check surfaces.

To avoid the gouging Creo NC provides the function of Check Surfaces. Although system
automatically checks gouging against the surfaces selected as cut geometry (Mill Surface in this
case) but it does not perform gouge checking against the reference part surfaces while
computing the toolpath. So by declaring a surface to be Check Surface we explicitly tell the

system to avoid gouging them while computing the toolpath.

Pick Check Surfaces

below.

T | o1:8em10 -

ASM_DEF_CSYS:F4(C5Y5)

on the dashboard and check the Add Reference Parts option as shown

| Reference Parameters Clearance Check Surfaces

Options

Tool Motions

Add Reference Parts

Check Surfaces:

I Use Mill Stock Allowance

All Solid Surfaces
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When Add Ref Prts (Add Reference Parts) option is checked, system uses all the surfaces of the
reference model to check gouging against.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

To perfrom gouge checking, pick !il icon on the dashboard as shown below.

Annotate  Tools  View  Applications  Mill Profile Milling

9] & WREn B x

“heck Surfaces Options Tool Motions Process Properties ‘

o ] [

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.

Menu Manager

Gouge Check

Don EE(Retu m

[#Add Ref Prts
Sel Surf
Done/Return

69



Creo NC - A Practical Approach Creo 4.0

Now the system will ask to select the surfaces for checking gouges. As Add Ref Prts is already
checked so select Done > Run.

Menu Manager Menu Manager
¥ MFG CHECK ¥ MFG CHECK
Done/Return Done/Return
w SRF PRT SEL . GOUGE CHECK
v Add Ref Prts Surfaces
Sel Surf Tolerance
| Done/Return | . Step
Done/Return

System will report that no gouges are detected.

EINo gouges were detected.

As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH 0.2

Properties

Now pick tab and enter STEEP as the name of the sequence.

Pick i to save the changes and close the dashboard.

Note: We can set the Configuration file option chk_part_surfs_profpock to Yes to force the
system to add all the surfaces of the reference part as Check surfaces for profiling sequences.

To blank the Mill Surface MS_A, select ~d8iank jcon on the View tab.
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Manufacturing Model Analysis

/% ® Hide -4 Blank @
= we] W @ O
Layers $ Unbic Scenes Appearances | Refit Zoom
% Status ~ £J Shade ¥ ”
Visibility Appearance ¥

Chapter 6 PROFILE MILLING

Annotate Tools View
"'!'4 %l Pan
to Zoom In HQ_“ZDDm il Sawn
L Pan Zoom Orientai

Orientation ™

Pick the MS_A quilt on the screen and then middle-click.

Select File > Save to save the manufacturing model.
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7. SURFACE AND CUT LINE MILLING

Further material is not included in the free download. You can buy the complete
tutorials at http://www.caeuniversity.com/buy. Thanks for your review of the training
material.
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