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5. PLUNGE MILLING
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6. PROFILE MILLING
Profile milling NC Sequence is a 2.5 axis sequence. It is usually used to semi-finish or finish the
vertical or slanted surfaces. The surface finish can be controlled with Step Depth adjustment or
Scallop Height parameter.

The required references are surfaces which may be the selected surfaces of either of the
Reference model, Mill Surface or Mill Volume. It automatically degouges the tool path against the
references selected for the cut geometry.

Locating Cutting Parameters

There are a lot of cutting parameters associated with the sequence. You can see all the

parameters by picking tab on the Edit Parameters dialog box.

If you don’t know the exact location of a parameter then it is better to arrange the parameters
alphabetically by picking Tools > Sort Parameters > By Parameter Name and then you can
easily locate the desired parameters.
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This can also be achieved by picking on the column "Parameter Name".
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EXERCISE 1

In this exercise we will define a profile milling NC Sequence to machine vertical walls of a block.

The topics covered in this exercise are as follows

 Defining a new Profile Milling NC Sequence
 Selecting the surfaces using Loop option
 Creating smooth entry/exit motions
 Optimizing the entry/exit conditions

Set the working directory to INSERT and open the model insert.asm.

For better visualization it is good to display the workpiece in wireframe. So select View
Manager icon to launch the View Manager Dialog box and double click the predefined style
stateWireframe.

Select to exit the dialog box.

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.
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Pick the icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box pick FEM20 from the list and select .

Pick tab and notice that the Machining Reference collector becomes active.

Here we will use the Loop selection technique to select the desired surfaces quickly.

Now select the top face of the reference model as shown below.
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Now hold down Shift key and place mouse pointer over any edge forming the boundary of the
selected surface.

Pick on the edge with left mouse to select the Loop Surfaces while Shift key is held down. The
selected surfaces will appear as shown below.
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Loop option is used to select a closed loop of surfaces by choosing a face they surround.

Now pick tab and enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 5
CLEAR_DIST 1
SPINDLE_SPEED 3000

Now pick tab and enter PROFILE as the name of the sequence.

To display the toolpath on screen pick icon. Play Path Dialog box will appear.

Click the Play Forward button and toolpath will appear as shown below.

Zoom to the toolpath and look at it carefully, you will notice that the tool plunges directly to the
next slice.
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Direct plunge is not a good practice. To introduce smooth entry/exit into the cut, parameters
need to be changed.

So pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 30

You can see all these parameters by picking tab and changing to “Entry/Exit Motions”
category as shown below.

Pick to apply the changes and exit the Edit Parameters Dialog box.

Now play the tool path using PLAY PATH dialog box. From TOP view it will appear as shown
below.
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Although now tool enters and exits into the cut very smoothly but it is wasting a lot of time in non-

cutting motion. To reduce this non-cutting time, again pick in Parameters panel and set the

following parameters. You will find these by picking tab and changing to “Entry/Exit
Motions” category.

ENTRY_ANGLE 50
EXIT_ANGLE 50

Pick to apply the changes and exit the Edit Parameters Dialog box.

Now play the tool path using PLAY PATH dialog box. From TOP view it will appear as shown
below.

Notice that the non-cutting motion has been reduced significantly. The Entry and Exit angles
must be sufficient large so that tool makes the plunge motion when it is out of the workpiece.

The entry/exit parameters can be readily understood from the figure below.
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It is always advantageous to use a large LEAD_RADIUS because larger the radius, smoother
the entry/exit into cut. But it also increases the idle time while the tool completes its non-cutting
movement. To reduce this non-cutting time we have set the ENTRY_ANGLE and EXIT_ANGLE
to a smaller value than default. By doing this we have achieved both i.e. smoother motion by
setting a large LEAD_RADIUS value and reduction in non-cutting time by smaller entry/exit
angles.

As the toolpath looks satisfactory so change the following parameters for final toolpath
computation.

STEP_DEPTH 2

Pick to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 2

In this exercise first we will define a Mill Surface to find the area which previous Ball End Mill
cutter could not machine. Then we will machine this surface with a Profile Milling NC Sequence.
The topics covered in this exercise are as follows

 Defining a Mill Surface as “Machinable Area”
 Creating smooth entry/exit motions

The Machinable Area Mill Surface is an advanced technique that calculates whether the
selected surfaces can be entirely machined with the selected cutting tool, and creates explicit
surface representations of the millable area (the portion of the selected surfaces that can be
milled), as well as of the remainder area (the portion that can not be milled with the selected tool).

This technique allows to automate surface selection for subsequent machining with a smaller
tool or with a different machining strategy.

You have to specify surfaces to be milled, additional surfaces for gouge checking (if any), the
cutting radius of a ball end mill tool and the tool axis orientation. The system then calculates the
machinable area based on tool contact and gouge avoidance.

The manufacturing model, referred in this exercise, has been finish machined in the previous
chapter “Volume and Local Milling” with a ball end mill of diameter 10mm. So for this exercise we
assume that the reference model was previously finished with the ball end mill.

Set the working directory to TOP_COVER and open the manufacturing model top_cover.asm

For better visualization it is good to display the workpiece in wireframe. So pick icon to
launch the View Manager Dialog box and double click the predefined style stateWireframe.

First of all we will define a Mill Surface to be later referenced in the Profile sequence.

So pick on the Mill tab to invoke the Mill Surface Tool.

Pick icon to give a name to this volume.

Enter MS_A as the name of the mill surface and pick .

Pick icon to define a "Machinable Area Reference" surface.
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System will ask to select the surfaces for finding the machinable area. So pick the highlighted
surface of reference model shown in the figure below.

Select or middle-click to proceed.

In the SRF PRT SEL menu, check the Add Ref Prts option then select Done/Return.

When Add Ref Prts (Add Reference Parts) option is checked, system uses all the surfaces of the
reference model to check gouging against.

Now the system will ask to enter radius of ball end mill for calculating Machinable Area.
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So enter 5.2 and pick icon or middle-click.

Although we should enter 5 as we used Ball end mill of diameter 10 to machine the cavity in a
previous NC Sequence, we have entered a larger value just to make sure that we get continuous
and smoother surface.

Now select the top surface of the reference model as the direction reference. The surface is
highlighted in the figure below.

You may also pick the retract plane or any other surface or plane that is parallel to the retract
plane.

Make sure that arrow points upward then select Okay.

This direction of the arrow specifies the tool axis orientation.

Double-click the Srf Option in the dialog box.
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In the MILLABLE OR REMAINING menu select Find Remaining Area > Done.

Find Remaining Area option finds the portion of the surface that can not be milled with the
specified tool.

Select to exit the dialog box. The surface will appear as shown below.

Now we will trim the unwanted part of the surface. We will use the extrude tool to trim the
unwanted part of the surface.

So pick icon to invoke the Extrude Tool.
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Pick tab in the Placement panel.

Pick ASM_RIGHT as the Sketch Plane ASM_TOP datum as Right Orientation Reference.

Now sketch a rectangle after choosing suitable references as shown below.
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Exact dimensions are not important. The size of rectangle should be such that it encompasses
the upper part of the visible surface.

Pick to complete the section

Pick so that the extruded surface trims the existing quilt.

Select Through All for both the Side1 and Side 2 in the Options slide-up panel as shown below.

Pick on the Material Side arrow to flip the direction as shown below.
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Now the system will keep the inner side of the sketch.

Pick the icon to exit the Extrude tool.

The mill surface will appear as shown below (after highlighting).

Pick and it completes the definition of the mill surface. if you don’t get the shown result then
you need to redefine the features and fix the problem otherwise you will not be able to do the
remaining exercise.

The references for a profile milling NC Sequence can also be selected before invoking the NC
Sequence. In this exercise we will do so.

So select the the previously defined “MS_A” mill surface in the model tree and pick Profile
Milling as shown below.
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Pick the icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box pick FEM10 from the list, then select .

Pick tab and notice that the Machining References collector contains the selected
surfaces.



Chapter 6 PROFILE MILLING

29

Make sure the arrow attached to the mill surface points away from the surface. This direction
indicates side of surface to be machined.

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 0.5
CLEAR_DIST 1
SPINDLE_SPEED 4000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 15
EXIT_ANGLE 15

Pick to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.
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As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH 0.2

Remember never to use WALL_SCALLOP_HGT parameter for controlling the surface finish,
while machining with a flat end mill.

Now pick tab and enter CORNER as the name of the sequence.

Pick to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 3

In this exercise we will define a profile milling NC Sequence to machine a sharp corner with a
single pass of cutter.

Set the working directory to COVER_INSERT and open cover_insert.asm

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.

From the drop-down list in front of icon, pick FEM25

Alternatively you can pick the icon to access Tools Setup dialog box and then select the tool.

Pick tab and notice that the Machining Reference collector becomes active.

Select the model surfaces (while holding down the Ctrl key) as shown in the figure below.

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.
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CUT_FEED 1200
STEP_DEPTH 50
CLEAR_DIST 1
SPINDLE_SPEED 3000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20

The large value of STEP_DEPTH will force the tool to machine only the last slice.

Pick to apply the changes and exit the Edit Parameter Dialog box.

Now pick tab and enter CORNER as the name of the sequence.

Play the toolpath using PLAY PATH dialog box and notice that the tool is machining the
complete surface with only a single pass as shown below.

Pick to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 4

In this exercise we will use the profile milling NC Sequence to finish a hole. We will also learn the
following

 How to control the plunge location of the tool
 How to perform multi-pass machining
 How to mirror a NC Sequence
 Playing the tool path for multiple Sequences

We assume that the hole has been previously drilled with the drill of diameter 12mm.

Set the working directory to LID_CAVITY and open the manufacturing model lid_cavity.asm.

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.

From the drop-down list in front of icon, pick FEM10

Pick tab and notice that the Machining Reference collector becomes active.

Select the model surfaces (while holding down the Ctrl key) as shown in the figure below.

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 2
CLEAR_DIST 1
SPINDLE_SPEED 5000
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COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 8

Pick to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

Notice that there is no lead in or lead out motion. System also warns about this by showing this
message.

It is so because lead radius value is larger than the radius value toolpath consists of. This fact
can be elaborated by the following figure.
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Please notice that “10” is the radius of the hole and 5 is the radius of the tool path arc. In this
case tool will gouge the part while making lead in or lead out motion therefore system has
ignored them.

So we should set the lead radius less than 5 (radius of toolpath arc) to make sure that tool
makes lead in and lead out motions.

So set the following parameter in Edit Parameters Dialog box.

LEAD_RADIUS 4

Play the toolpath using Screen Play. It should appear as shown below.

As we assumed at the start of the exercise that the hole was pre-drilled with the drill of 12mm
diameter . So the tool will be cutting material during plunge motion because there is enough
material at the walls of the hole. The tool must plunge to the next slice at the center of the hole to
avoid cutting of material during plunge motion.

So pick tab and click inside the Approach Axis collector to activate it.
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Select the axis AA_1 as Approach axis as elaborated below.

Now pick in the Exit Axis collector to activate it and select the axis AA_1 as exit axis.
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Pick tab and set the following parameters

PLUNGE_FEED 100

PLUNGE_FEED parameter controls the feed rate along the plunge motion. By default it is set to
dash (-) in which case the CUT_FEED is used as PLUNGE_FEED.

Play the toolpath on screen using PLAY PATH dialog box and notice that the tool is plunging
right on the axis AA_1 as shown below (tool not shown).

You should notice that tool is climb milling the hole surfaces.

We can machine the hole in multiple passes so that we don’t have to define separate sequences
for semi-finishing and finishing toolpaths.

Pick in the Parameters panel and set following parameters to machine the hole in two steps.
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NUM_PROF_PASSES 2
PROF_INCREMENT 0.3

These parameters can be found in “Cut Depth and Allowances” Category as shown below.

NUM_PROF_PASSES together with PROF_INCREMENT allows to create multiple profiling
passes horizontally offset from each other.
NUM_PROF_PASSES specifies the number of passes that will be generated.
PROF_INCREMENT specifies the horizontal distance between the passes generated according
to NUM_PROF_PASSES.

Play the toolpath on screen using PLAY PATH dialog box. It will appear as shown below.
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Notice that the tool first machines the walls from top to bottom of the hole at the offset specified
by PROF_INCREMENT then retracts and again machines the walls from top to bottom without
PROF_INCREMENT. This type of machining is called PASS_BY_PASS scanning. We can
machine the hole by fist making the profile passes specified by the NUM_PROF_PASSES at the
given z level and then plunging down to the next slice. This type of machining is called
SLICE_BY_SLICE scanning. The scanning strategy is specified by the SLICE_PATH_SCAN
parameter.

As the toolpath looks satisfactory so change the following parameters.

STEP_DEPTH 0.5

Now pick tab and enter FINISH as the name of the sequence.

Pick to save the changes and close the dashboard.

Now we will mirror this sequence to machine the second hole.

So select the FINISH sequence in the model tree and pick Edit > Mirror Step on the Mill tab.

In the NC Sequences Mirroring dialog box, pick
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Select the datum ASM_RIGHT as mirroring plane.

Notice that the option “Keep” is selected by default for Cutting Conditions in the dialog box

Pick to complete the mirroring operation.

Select the MIRROR_FINISH sequence in the model tree and pick Play Path.

Play the toolpath on screen using PLAY PATH dialog box. It will appear as shown below.
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Notice that tool is Climb milling the hole surfaces. It is so because the option “Keep” is selected
for Cutting Conditions in the NC Sequences Mirroring dialog box

Now we will play the tool path for both of the sequences together.

Select the both sequences in the model tree while holding down the Ctrl key and pick Play Path.

Click the Play Forward button in the Play Path Dialog box. Toolpath will appear as
shown below.
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Select File > Save to save the manufacturing model.
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EXERCISE 5

In this exercise we will define a profile milling NC Sequence to machine an undercut, with a
special round insert milling cutter.

The topics covered in this exercise are as follows

 Defining a side milling cutter
 Selection of surfaces by loop option
 Checking gouges visually, by placing the tool at desired location on the tool path

The cutter to be used in this exercise is shown below.

Set the working directory to BACK_PLATE and open the manufacturing model back_plate.asm.

Change the view to Front and zoom in to the reference part and see that lower surfaces of the
plate form an undercut.

Conventionally, to machine this undercut we will need to machine first from top side and then
invert the plate and machine the bottom side i.e. two separate operations in Creo NC. By using
the special round insert cutter we will machine the complete plate with only one operation.

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.

Pick the icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box, define a new “Side Milling” cutter of diameter 25. Other parameter
of the tool should be as shown below.
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Pick tab and tool will appear in the Tools List.

To see the tool in separate window click in the dialog box and the detailed sketch of the tool
will appear as shown below.

Pick to close this window.
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Select to complete the definition of the tool.

Pick tab and notice that the Machining Reference collector becomes active.

Here we will use the Loop selection technique to select the desired surfaces quickly.

Now select the bottom surface of the reference model as shown below. (Set the view to ISO2 to
avoid any ambiguity.)

Now hold down Shift key and select any edge forming the inner loop of selected surface as
shown below.

After releasing the Shift key, the selected loop of surfaces will be highlighted as shown below.



Creo NC - A Practical Approach Creo 4.0

46

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1200
STEP_DEPTH 3
CLEAR_DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 20
EXIT_ANGLE 20

We have set the large value of STEP_DEPTH to make the computation of the toolpath faster.
Later when the toolpath has been fine tuned, we will change it to suit the surface finish required.

Pick to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box and it will appear as shown below.
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Change the view to Front and zoom-in to see that toolpath has followed the surface forming
undercut as shown below (in Wireframe mode).

To check visually if the tool is gouging anywhere on the part, pick icon on the PLAY PATH
dialog box.

Now pick on the toolpath as shown below.
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The tool will move to the picked point as shown below.

Notice that tool shank is clear of the reference part surfaces and does not gouges the part
anywhere.

To be sure, that the tool does not violate the reference part, we should perform the gouge
checking.

So select icon on the dashboard as shown below.

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.
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When Add Ref Prts option is checked, system adds all surfaces of the reference part for gouge
checking.

Select Done > Run.

System will report that no gouges are detected.

It is always good practice while machining undercut to use larger values for ENTRY_ANGLE and
EXIT_ANGLE parameter. So that on the retract path tool does not gouges the part.

As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH 0.2

Now pick tab and enter UNDERCUT as the name of the sequence.

Pick to save the changes and close the dashboard.

Select File > Save to save the manufacturing model.
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EXERCISE 6

In this exercise we will define a profile milling NC Sequence to machine an undercut with a T-slot
cutter.

The topics covered in this exercise are as follows

 Defining a new profile milling NC Sequence to machine and undercut
 Defining a new Key cutter
 Introduction to NORMAL_LEAD_STEP parameter
 Inserting a CL Command at the end of CL Data
 Patterning a NC Sequence
 Generating CL Data for a patterned NC Sequence
 Gouge checking patterned NC Sequence

Set the working directory to FLOAT_PLATE and open the manufacturing model float_plate.asm.

Change the view to FRONT and zoom-in to the reference part and see that each bore has an
undercut.

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.

Pick the icon and Tools Setup dialog box will pop up.

In the Tools Setup dialog box, define a new tool of type “Key Cutter” with a diameter 16. Other
parameter of the tool should be as shown below.
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Pick tab and tool will appear in the Tools List.

To see the tool in separate window click and the detailed sketch of the tool will appear as
shown below.

Pick to close this window.
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Select to complete the definition of the tool.

Pick tab and notice that the Machining Reference collector becomes active.

Select the surfaces forming undercut of first hole as shown in the figure below (view is set to
ISO2). It is important to select the surfaces belonging to the first instance in the pattern as it will
allow to reference pattern the NC Sequence.

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 800
STEP_DEPTH 2
CLEAR_DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 15
ENTRY_ANGLE 25
EXIT_ANGLE 25

It is always good practice while machining undercut to use larger values for ENTRY_ANGLE and
EXIT_ANGLE parameter. So that on the retract path, tool does not gouges the part.

Pick to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.
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To be sure, that the tool does not violate the reference part, we should perform the gouge
checking.

So select icon on the dashboard as shown below.

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.
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When Add Ref Prts option is checked, system adds all surfaces of the reference part for gouge
checking.

Select Done > Run.

System will report gouges by the following message at message area.

Tool is gouging the part during plunge and retract motion. So we should modify the toolpath so
that tool clears the reference part during motions along z-axis.

So set the following parameter.

NORMAL_LEAD_STEP 5

You can find this parameters by picking tab and changing to “Entry/Exit Motions” category

NORMAL_LEAD_STEP is the length of the linear movement that is normal to the lead-in or lead-
out motion.
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Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

To perform gouge checking pick icon and check the Add Ref Prts option.

Select Done > Run. System will report that no gouges are detected.

Now we will insert an an Optional Stop at the end of the CL Data.

So select tab and pick on icon.
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In the CL Command dialog box pick icon.

In the “cmd edit” menu select LOADTL-OPTSTOP > OPTSTOP.
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OPTSTOP command will appear in the dialog box as shown below.

Select to exit the CL Command dialog box.

Now pick tab and enter UNDERCUT as the name of the sequence.

Pick to save the changes and close the dashboard.
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Now we will pattern the sequence to machine all the undercuts. We will use the Reference
Pattern technique.

So right-click the NC Sequence in the model tree and pick Pattern

Notice that Reference is selected by default as shown below.

Pick icon or middle-click to complete the pattern.

Now we will create the CL Data file for the patterned toolpath. To do this first we will create a set
of patterned sequences.

Select on the Manufacturing tab as shown below.
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Pick Create in the OUTPUT SET menu and enter Set_UNDERCUT as the name of the set and
hit Enter key.

In the CREATE SET menu, select the first instance of the pattern and system will ask to include

all instance in the set. Pick to confirm as shown below.

Select Done Sel in the CREATE SET menu.

Now select the Set_UNERCUT in the SELECT SET menu.

In the PATH menu pick File and then Done
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Pick in the Save a Copy dialog box. The file set_undercut.ncl.1 will be created.

To display the toolpath on screen select Display > Done on the PATH menu.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.
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To perform gouge checking pick Validate > Gouge Check on the Manufacturing tab as shown
below.

Select the newly created file set_undercut.ncl and pick

Check the box Add Ref Prts and select Done > Run.

System will report that no gouges are detected.

Although we could insert an optional stop in Edit Parameters Dialog box, but it will only appear at
the end of patterned MCD data i.e. once in the tape file. By inserting CL Command at the end of
CL Data, the Optional Stop will appear at the end of each patterned instance i.e. 6 times in tape
file for above case as shown in the figure below.
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So the machine operator may have the option to stop the machine at the end of machining each
bore and check the cutter condition or may perform some other task.

Select File > Save to save the manufacturing model.
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EXERCISE 7

In this exercise first we will define a “Sloped” mill surface and then use the profile milling NC
Sequence to machine it.

The topics covered in this exercise are as follows.

 Defining a Sloped Mill Surface
 Introduction to Check Surfaces functionality
 Setting the “Configuration file” option related to check surfaces.

While finish machining a part it is preferable to machine the steep walls with a constant Z type
toolpath (as Profile and Volume Milling NC Sequence offer) and shallow surfaces with a little
step over (as Surface Milling NC Sequence offers). Sloped Mill Surface is used to classify
surfaces into Steep (near vertical) and Shallow (near horizontal) areas.

The criterion to classify surfaces into Steep and Shallow areas is the Slope Angle. At any given
point, Slope angle is defined as the angle between Surface Normal and the Direction Vector as
elaborated in the following figure.

Direction vector is always parallel to the Z-axis and Surface Normal depends upon the topology
of the surface.

So a Flat surface has Slope angle of 00 and a Vertical surface has Slope Angle of 900.

During the definition of Sloped Surface, we specify a Draft Angle. If a surface patch has Slope
angle greater than this Draft Angle it is considered a Steep area and if its value is lesser then it is
considered as Shallow area.

During the definition of Sloped Surface, we have the option either to keep the steep or shallow
side of the selected surfaces. When we select Keep Steep Side, the system keeps only those
portions of the selected surfaces where the Slope Angle is greater than the specified Draft Angle
value. And when we select to Keep Shallow Side, the system keeps only those portions of the
selected surfaces where the Slope Angle is less than the specified Draft Angle value.

Set the working directory to BASE_PUNCH and open the manufacturing model base_punch.asm.
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First of all we will define a Mill Surface to be later referenced in the Profile sequence.

So pick on the Mill tab to invoke the Mill Surface Tool.

Pick icon to specify a name to this surface.

Enter MS_A as the name of the mill surface and pick .

Pick icon to create a Sloped mill surface.

We will use the Seed and Boundary surface selection method to speed up the surface selection
process.

Select the model surface as shown in the figure below as the seed surface.

Now hold down the Shift key and select the following two highlighted surfaces as Boundary
surfaces.
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After relieving the Shift key the system will highlight the selected surfaces as shown below.

Select or middle-click.

Now select the top surface of the reference model as the direction reference. Make sure that
arrow points upward. This direction is used for measuring the slope angle.
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Then select Okay.

In the message area system will ask to enter the Draft angle value. This value is used to classify
surfaces as steep or shallow.

Enter 60 and hit Enter key or middle-click.

Now select Keep Steep Side > Done

Select to exit the dialog box.

Pick and it completes the definition of the mill surface.

To define a new profile milling NC Sequence, select Profile Milling icon ( ) on Mill tab.
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From the drop-down list in front of icon, pick BEM10

Pick tab and notice that the Machining Reference collector becomes active.

Pick the currently defined mill surface MS_A and make sure that arrow points outward as shown
in figure below.

Now pick tab and then icon on the Parameters panel to open the Edit
Parameters Dialog box . Enter the following values/relations and parameters.

CUT_FEED 1000
STEP_DEPTH 3
CLEAR_DIST 1
SPINDLE_SPEED 2000
COOLANT_OPTION ON
CUT_ENTRY_EXT LEAD_IN
CUT_EXIT_EXT LEAD_OUT
LEAD_RADIUS 20
ENTRY_ANGLE 15
EXIT_ANGLE 15
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Pick to apply the changes and exit the Edit Parameter Dialog box.

Play the toolpath using PLAY PATH dialog box and notice that tool is gouging the part as shown

below. (You can also use the Gouge Check functionality i.e. by picking to confirm gouging)

To avoid the gouging we will declare the reference part to act as check surfaces.

To avoid the gouging Creo NC provides the function of Check Surfaces. Although system
automatically checks gouging against the surfaces selected as cut geometry (Mill Surface in this
case) but it does not perform gouge checking against the reference part surfaces while
computing the toolpath. So by declaring a surface to be Check Surface we explicitly tell the
system to avoid gouging them while computing the toolpath.

Pick on the dashboard and check the Add Reference Parts option as shown
below.
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When Add Ref Prts (Add Reference Parts) option is checked, system uses all the surfaces of the
reference model to check gouging against.

Play the toolpath using PLAY PATH dialog box. It should appear as shown below.

To perfrom gouge checking, pick icon on the dashboard as shown below.

Now the system will ask to select the surfaces for checking gouges. As we want to check the
gouges for the surfaces of complete part so check the Add Ref Prts option.
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Now the system will ask to select the surfaces for checking gouges. As Add Ref Prts is already
checked so select Done > Run.

System will report that no gouges are detected.

As the toolpath looks satisfactory so change the following parameters for good surface finish.

STEP_DEPTH 0.2

Now pick tab and enter STEEP as the name of the sequence.

Pick to save the changes and close the dashboard.

Note: We can set the Configuration file option chk_part_surfs_profpock to Yes to force the
system to add all the surfaces of the reference part as Check surfaces for profiling sequences.

To blank the Mill Surface MS_A, select icon on the View tab.
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Pick the MS_A quilt on the screen and then middle-click.

Select File > Save to save the manufacturing model.
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7. SURFACE AND CUT LINE MILLING

Further material is not included in the free download. You can buy the complete
tutorials at http://www.caeuniversity.com/buy. Thanks for your review of the training
material.
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