
Exercise 21

In this exercise we will analyze a rubber disc subjected to pressure loading. The disc is modeled as an
axisymmetric part. The geometry considered is shown in the figure below.

Pick File > Set Work Directory and set the work directory to the DiscFlange folder

Open the model database DiscAxi.cae.

The model consists of a single part, Disc. The disc shown in above figure has an outer radius of 0.1 m and
a thickness of 0.005 m. It is assumed to be made from rubber, which is modeled as a Mooney-Rivlin
material with C10= 0.5 MPa and C01 = 0.14 MPa. The disc is meshed with bilinear axisymmetric
quadrilateral elements with reduced integration and hybrid formulation (CAX4RH). Hybrid elements are
used because the material is nearly incompressible material. The disc is loaded with a uniform pressure of
200 kPa.

Defining Step

We assume that load is applied slowly such that inertia effects can be neglected. So analysis will be
performed using the Static, General procedure.

The step has already been defined with a total time period set to 1.0. As the large deformations are
expected to occur, Nlgeom option has been set to On. The incrementation has been set to Automatic type
with an initial increment size of 0.01 and a maximum increment size of 0.05

Defining Load

A uniform pressure load is applied across the bottom of the disc. The load has already been defined.

Boundary Conditions

Boundary conditions required for the analysis have already been defined.

The boundary condition “BC-Fixed” constrains all the degrees of freedom of the bottom edge of the disc.
The boundary condition “BC-Symm” applies a symmetric constraint to the edge at the center of the disc.
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Field Output Request

We will plot the history of applied pressure during postprocessing. This information can be plotted by
requesting P, Pressure loads output variable.

Change to Step module.

Open the Field Output Manager by picking .

Select the F-Output-1 field and pick Edit as shown below.

Check the P, Pressure loads variable (located under the Forces/Reactions container).

Pick OK to apply and exit.

Pick Dismiss to close the manager.

Defining Material Model

A material has already been defined, we will edit its definition to add hyperelastic properties.

Change to Property module.

Open the Material Manager by picking .
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Select the Rubber and pick Edit.

In the Edit Material dialog box, pick Elasticity > Hyperelastic in the Mechanical menu.

Pick Mooney-Rivlin as strain energy potential.

Select Coefficients as input source.

Enter C10 = 0.5E6 and C01 = 0.14E6 as shown below.
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Pick OK to apply and exit.

Job Submission

All the information required for analysis has been set up. Now we can submit the job for analysis.

So change to Job module and pick to open the job manager.

Pick Create and create a job named Bulge or whatever name you would like.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Pick Results to view the results in Visualization module.

Postprocessing

Pick to plot contours on deformed shape. The contour plot of von Mises stress will appear as shown
below.

We can view the axisymmetric simulation results in three dimensions by sweeping them about the
rotational axis to a specific angle. This give a three-dimensional visual effect. So first we will sweep the
simulation results for better understanding.

While in the Visualization module, pick View > ODB Display Options from the main menu bar and check
the "Sweep elements" option located under the Sweep/Extrude tab.
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Enter 25 as the number of segments for a finer view of the model.

Pick OK to apply and exit the dialog box. The 1800 representation of simulation results will appear as
shown below.

It can be seen that as the disc bulges, thickness of the disc decreases significantly in the center of the disc.

Now we will plot the thickness of the disc at the centerline .

Pick and Create XY Data dialog box will appear.

Pick ODB field output > Continue

In the Position field, select Unique Nodal and check the U2 checkbox.
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Under the Elements/Nodes tab, pick the Node sets as method and select the NODE_CENTERBOTTOM
and NODE_CENTERTOP.

Check Highlight items in viewport in the dialog box to highlight the nodes in viewport. The following
figure also shows the node labels for later reference.

Pick Save to save the plot and then pick OK to confirm.

The current thickness can be computed by using the following relation

Current thickness = Undeformed thickness - (Displacement of Bottom Node - Displacement of top node)

So we need to operate on the the displacement plots to obtain current thickness plot.

Again pick and select Operate on XY data option.

Pick Continue to proceed.

Enter 0.005 in the expression field. Remember this is the undeformed thickness of disc.

Then complete the expression as shown below. Notice the “-” signs according to the above relation.

Pick Plot Expression tab and graph will appear as shown below (after modifying the title of vertical axis).
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It can be seen that thickness reduces to about 0.0013 m.

As the plot looks satisfactory so pick Save As to save the plot and enter CurrentThickness as name.

Now we will plot the thickness strain at the center of the disc versus the displacement of the center node
along axis.

First we will plot the thickness strain at the centerline .

Pick and Create XY Data dialog box will appear.

Pick ODB field output > Continue

In the Position field, select Unique Nodal and check the LE22 checkbox.

Under the Elements/Nodes tab, pick the Node sets as method and select the NODE_CENTERBOTTOM.

Pick Save to save the plot and then pick OK to confirm.

Now we will combine the plots to produce the desired strain-displacement plot.

Again pick and select Operate on XY data option.
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Pick Continue to proceed.

In the Operate on XY Data dialog box, pick combine(X,X) operator.

Then double-click the “U:U2…….” data and then “LE:LE22…….” data in the list and expression will
appear as shown below.

Pick Plot Expression tab and graph will appear as shown below.

Now we will plot the applied pressure versus the displacement of the center node.

First we will plot the history of applied pressure.

Pick and Create XY Data dialog box will appear.

Pick ODB field output > Continue

In the Position field, select Element Face and check the P:Pressure loads checkbox.
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In the Elements/Nodes tab, pick Element sets as method and select the ELEMENT_CENTER. This
element has already been defined for the ease of use.

Pick Save to save the plot and then pick OK to confirm.

Now we will combine the plots to produce the desired pressure-displacement plot.

Again pick and select Operate on XY data option.

Pick Continue to proceed.

In the Operate on XY Data dialog box, pick combine(X,X) operator.

Then double-click the “U:U2…….” data and then “P P1:…….” data in the list and expression will appear
as shown below.

Pick Plot Expression tab and graph will appear as shown below.

Such graphs can be useful to compare the results to physical test.

Select File > Save to save the changes we made so for.
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Exercise 22

In this exercise we will analyze a viscoelastic sheet subjected to constant pressure load. The sheet is
modeled assuming plane stress conditions. The material is assumed linear viscoelastic. The geometry
considered is shown in the figure below.

Pick File > Set Work Directory and set the work directory to the SheetVisco folder

Open the model database Sheet.cae.

The model consists of a single part, Sheet. It is assumed to be made from polyethylene, which is modeled
as a linear elastic material with a Young’s modulus of 1.08 GPa and a Poisson’s ratio of 0.4. It is meshed
using second order plane stress quadrilateral elements with reduced integration (CPS8R). The sheet is
loaded with a pressure of 10 MN/m.

Defining Step

The analysis will be performed in two steps. The load is applied in the first step. We assume that load is
applied slowly such that inertia effects can be neglected. So analysis will be performed using the Static,
General procedure. This step has already been defined. The static procedure does not allow viscous
material behavior so the response is purely elastic during first step. To simulate the viscoelastic response a
second step using the quasi-static procedure (Visco procedure) will be defined. In this step load stays
constant and the material is allowed to creep for 5000 seconds.

Change to Step module.

Pick to create a new step and select the Visco procedure.
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Pick Continue and Edit Step dialog box will appear. Notice that by default NLgeom option is set to On.
Enter 5000 as the time timer period.

Under the Incrementation tab, set the initial increment size to 0.1, minimum to 0.001 and maximum to 500

Enter 0.002 as viscoelastic strain error tolerance.

Strain error tolerance is the tolerance value for the maximum difference in the creep strain increment over
a time increment.

Strain error tolerance is usually the same order of magnitude as the maximum elastic strain. (Maximum
elastic strain at the end of first step is 9.3 x 10-3 in this exercise.)
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Pick OK to complete the definition of step.

Defining Load

A uniform pressure load is applied on the top edge of the sheet. The load has already been defined.

Boundary Conditions

Boundary conditions required for the analysis have already been defined.

The boundary condition “BC-BottomEdge” applies the symmetry boundary condition to the bottom edge
of the sheet. The boundary condition “BC-Node” constrains the movement of the bottom left node along x-
axis.

Defining Material Model

A material has already been defined, we will edit its definition to add viscoelastic properties.

Change to Property module.

Open the Material Manager by picking .

Select the Polyethylene and pick Edit.

In the Edit Material dialog box, pick Elasticity > Viscoelastic in the Mechanical menu.

The viscous behavior will be modeled by a time dependent shear relaxation modulus which is expanded in
a Prony series with three terms. It is assumed that no volumetric relaxation occurs and hence bulk modulus
is independent of time. Therefor relative moduli for bulk modulus are set to 0. The relative moduli and
time constants to specify the Prony series are as follow:
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i P
ig P

ik P
i

1 0.1 0 10
2 0.15 0 200
3 0.1 0 1000

Pick Time as domain and enter the relative moduli and time constants as shown below.

Pick OK to apply and exit.

Job Submission

All the information required for analysis has been set up. Now we can submit the job for analysis.

So change to Job module and pick to open the job manager.

Pick Create and create a job named Creep or whatever name you would like.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Pick Results to view the results in Visualization module.

Postprocessing

Pick and Create XY Data dialog box will appear.
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Pick ODB field output > Continue

In the Position field, select Unique Nodal and check the LE22 checkbox.

Under the Elements/Nodes tab, pick the Node sets as method and select the SHEET-1.TOPNODE

Check Highlight items in viewport in the dialog box to highlight the nodes in viewport.

Pick Plot tab and graph will appear as shown below (after modifying the axis limits).
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It can be seen that sheet creeps for 5000 seconds as the load is kept constant during second step.
Furthermore solution appears to be steady state as 5000 seconds is a long time compared with material
time constants.

By plotting the S22, it can be seen that stress almost stays constant as shown below.

Select File > Save to save the changes we made so for.
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Exercise 23

In this exercise we will investigate stress relaxation in a viscoelastic sheet subjected to constant strain. The
sheet is modeled assuming plane stress conditions. The material is assumed linear viscoelastic. The
geometry considered is shown in the figure below.

The sheet is symmetric so only quarter of the geometry is considered.

Pick File > Set Work Directory and set the work directory to the SheetVisco folder

Open the model database Sheet_Hole.cae.

The model consists of a single part, Sheet. It is assumed to be made from polyethylene, which is modeled
as a Neo-Hookean material with C10= 186 MPa and D=0.001 MPa-1. It is meshed using second order plane
stress quadrilateral elements with reduced integration (CPS8R).

Defining Step

The analysis will be performed in two steps. A strain is imposed using displacement boundary condition in
the first step. This loading is performed using the Static, General procedure. The static procedure does not
allow viscous material behavior so the response is purely elastic during first step. To simulate the
viscoelastic response a second step using the quasi-static procedure (Visco procedure) has been defined. In
this step strain stays constant and the material relaxes for 2E6 seconds. Both steps have already been
defined.

Boundary Conditions

Two boundary conditions required for the analysis have already been defined.

The boundary condition “BC-BottomEdge” applies the symmetry boundary condition to the bottom edge
of the sheet. The boundary condition “BC-LeftEdge” applies the symmetry boundary condition to the left
edge of the sheet. We will create another boundary condition to impose the fixed displacement to the right
edge of the sheet.

To define boundary condition, change to Load module.
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Pick to open Boundary Condition Manager.

Pick Create to define a new boundary condition.

Enter BC-RightEdge as name.

Pick Impose Strain as step. This is the step defined with static procedure.

Pick Displacement/Rotation as type.

Pick Continue and system will ask you to pick the region. As we have already defined a set, so pick Sets
and select the Sheet-1.RightEdge.

Pick Continue to proceed and enter 0.0035 as magnitude of displacement in U1 direction as shown below.
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Pick OK in the Edit Constraint dialog box to apply changes and exit.

Pick Dismiss to close the manager.

Material Model

A material model has already been defined where the instantaneous behavior of the viscoelastic material is
defined by hyperelastic properties. The viscous behavior is modeled by a time-dependent shear modulus
which is expanded in a Prony series with five terms. It is assumed that no volumetric relaxation occurs and
hence bulk modulus is independent of time. Therefor relative moduli for bulk modulus are set to 0. The
relative moduli and time constants to specify the Prony series are as follow:

i P
ig P

ik P
i

1 0.001 0 10
2 0.0015 0 200
3 0.003 0 1000
4 0.04 0 10000
5 0.05 0 1000000

Job Submission

All the information required for analysis has been set up. Now we can submit the job for analysis.

So change to Job module and pick to open the job manager.

Pick Create and create a job named Relaxation or whatever name you would like.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Pick Results to view the results in Visualization module.

Postprocessing

Pick and Create XY Data dialog box will appear.

Pick ODB field output > Continue

In the Position field, select Unique Nodal and check theMises checkbox.
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Under the Elements/Nodes tab, pick the Node sets as method and select the SHEET-1.NODERIGHT

Pick Plot tab and graph will appear as shown below (after modifying the axis limits).

It can be seen that stress relaxes for 2E6 seconds as the strain is kept constant during second step.

By plotting the LE11, it can be seen that strain stays constant as shown below.

Select File > Save to save the changes we made so for.

Note: Generally it is not recommended to plot stress values at nodes as those are extrapolated from
integration points.
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Exercise 24

In this exercise we will investigate stress relaxation in a viscoelastic bushing using a nonlinear viscoelastic
model. The bushing is modeled assuming plane strain conditions. The geometry considered is shown in the
figure below.

Pick File > Set Work Directory and set the work directory to the BushingVisco folder.

Open the model database Sheet_Hole.cae.

The model consists of a single part, Bushing. It is assumed to be made from EPDM rubber, which is
modeled as a Neo-Hookean material with C10= 186 MPa and D=0.001 MPa-1. It is meshed using first order
plane strain quadrilateral elements with reduced integration (CPE4R).

Defining Step

The analysis will be performed in two steps. A strain is imposed using displacement boundary condition in
the first step. This loading is performed using the Static, General procedure. The static procedure does not
allow viscous material behavior so the response is purely elastic during first step. To simulate the
viscoelastic response a second step using the quasi-static procedure (Visco procedure) has been defined.
During this step, strain stays constant and the material relaxes for 2000 seconds. In this step the initial
increment size is set to 0.01, minimum to 1E-6 and maximum size to 200. A viscoelastic strain error
tolerance of 0.1 has been set.

Strain error tolerance is the tolerance value for the maximum difference in the creep strain increment over
a time increment.

Strain error tolerance is usually the same order of magnitude as the maximum elastic strain. (Maximum
elastic strain at the end of first step is 9.9 x 10-1 in this exercise.)
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Boundary Conditions

The bushing is glued to a rigid fixed cylindrical part on the outside. This is modeled by fixing the
displacements degrees of freedom of outer edge. The boundary condition “BC-OuterEdge”, which has
already been defined, constrains the degrees of freedom of the outer edge of the bushing.
The bushing is glued to a rigid shaft on the inside. The inner edges of the bushing are connected using a
kinematic coupling constraint to a reference point located in the center. Therefor displacement of the
reference point represents the displacement of shaft. Now we will create a boundary condition to impose
the displacement to the reference point.

To define boundary condition, change to Load module.

Pick to open Boundary Condition Manager.

Pick Create to define a new boundary condition.

Enter BC-RP as name.

Pick Step-1 as step. This is the step defined with static procedure.

Pick Displacement/Rotation as type.

Pick Continue and system will ask you to pick the region. As we have already defined a set, so pick Sets
and select the Set-RP.

Pick Continue to proceed and enter 0.01 as magnitude of displacement in U1 direction as shown below.
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Pick OK in the Edit Constraint dialog box to apply changes and exit.

Pick Dismiss to close the manager.

Material Model

A material model has already been defined where the instantaneous behavior of the viscoelastic material is
defined by hyperelastic properties. EPDM exhibits nonlinear viscoelastic properties. Now we will define
the viscoelastic behavior by using Power-law strain hardening model. We will use the following values of
constants in the law.

A 3.0E-39
n 6.0
m -0.15
r 0.9

Here r is the stiffness ratio.

To define the nonlinear viscoelastic model, editing of the keywords file is required.

PickModel > Edit Keywords > Bushing from the main menu.

Enter the following keywords after the ‘*Hyperelastic, new hooke, text.

, Moduli=instantaneous

MODULI=INSTANTANEOUS is used to indicate that the hyperelastic material constants define the
instantaneous behavior.

Use the Add After tab after placing the cursor at the end of data line of Hyperelastic keyword and enter
following.

*VISCOELASTIC, NONLINEAR, NETWORKID=1, SRATIO=0.9, LAW=STRAIN
3.0E-39, 6.0, -0.15

The keyword property editor after editing is shown below.
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Pick OK to apply and exit.

Job Submission

All the information required for analysis has been set up. Now we can submit the job for analysis.

So change to Job module and pick to open the job manager.

Pick Create and create a job named Relaxation or whatever name you would like.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Pick Results to view the results in Visualization module.

Postprocessing

Pick and Create XY Data dialog box will appear.
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Pick ODB field output > Continue

In the Position field, select Integration Point and check theMises checkbox.

Under the Elements/Nodes tab, pick the Elements sets as method and select the BUSHING-1.ELEMTOP

Pick Plot tab and graph will appear as shown below. The time axis is shown using log scale.

It can be seen that stress relaxes for 2000 seconds as the strain is kept constant during second step.

Select File > Save to save the changes we made so for.
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