
Exercise 16

In this exercise we will perform the stress analysis of a door seal.

Pick File > Set Work Directory and set the work directory to SealDoor folder

Open the model database SealDoor.cae. It will appear as shown below.

The model consists of two parts: door and seal. The door is modeled as an analytical rigid part. The seal is
assumed to be made of rubber, which is modeled as an incompressible Mooney-Rivlin material with C10=
3.1 MPa and C01 = 0.85 MPa. A coefficient of friction of 0.15 is assumed between contacting surfaces. The
seal is meshed with bilinear plane strain quadrilateral elements with reduced integration and hybrid
formulation (CPE4RH).

Analysis Steps

The analysis will be performed in one step. The step has already been defined with a total time period set
to 1.0 and the initial time increment to 0.01

As seal is modeled as a hyperelastic material, it may undergo large deformations. To take into account
these large deformations, NLgeom option has been toggled on in the step.

Contact Interactions

A contact interaction between surfaces of the door and the seal has already been defined. We will define
one more to take into account self-contact of the seal surfaces.

Change to Interaction module and open the Interaction Manager by picking .
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Pick Create to define a new interaction.

Enter Seal-Seal as the name of the interaction.

Pick Initial in the Step field.

Select Self-contact as type.

A self-contact interaction allows to define contact between different areas of a single surface.

Pick Continue to proceed.

We have already defined a surface so pick Surfaces on the right side of the prompt area and select the
Seal-1.Surf-SelfContact.



3

Self-contact interaction models contact between a single surface and itself by specifying only a single
surface.

Pick Continue and Edit Interaction dialog box will appear.

Each contact interaction must refer to a contact interaction property that governs the interaction behavior.
The desired property has already been created and is selected by system automatically as shown below.

In this dialog box, there is no option to pick among finite-sliding and small-sliding as seen in surface-to-
surface type contact interaction dialog box.

By default self-contact uses finite sliding option and small sliding option is not available.
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Pick OK and it completes the definition of interaction. It can be seen in the Interaction Manager that newly
created interaction has been propagated.

Pick Dismiss to close the manager.

Boundary Conditions

Boundary conditions required for the analysis have already been defined. The boundary conditions “Door”
and “Seal” constrain the the motion of the respective parts. Door is moved by a magnitude of 0.015 in the
y-direction during Step-1.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named Door_Close or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

If you look in the message area, the following message can be seen.

“Job Door_Close aborted due to errors.”

We will attempt to find the cause of this error in the Visualization module. So pick Results to view the
results in the Visualization module.
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Diagnosing the error

Pick to plot the contours on deformed shape. It can be seen in the figure below that contact establishes
successfully and job runs till 105th increment completing the 0.3673 of step time.

To investigate the cause of analysis termination, pick Tools > Job Diagnostics and Job Diagnostics dialog
box will appear. It can be seen that during the 105th increment, system makes 6 attempts before aborting
the analysis. After the first attempt, Abaqus/Standard reduces the increment size to 25% of its previous
value and makes another attempt. This process of cutbacks is repeated five times and then analysis is
stopped.

All the attempts for this increment have failed because the solution appears to be diverging as shown for
the 5th attempt in the figure below.
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Also notice that increment size for the 5th attempt has reached minimum value specified in the step
definition (1e-05).

If the time increment becomes smaller than the minimum you specified or more than 5 attempts are needed,
Abaqus/Standard stops the analysis.

During the 5th attempt, there have been total 6 iterations, and 4 of them are severe discontinuity iterations
as shown in the figure below. It can also be seen that during the severe discontinuity iterations there are no
contact openings/overclosures changes happening.



7

Establishing contact conditions is a common source of difficulty in a static contact analysis. If any contact
changes are detected in the current iteration, Abaqus/Standard labels it a severe discontinuity iteration. If
an analysis terminates, the Contact tab in the Job Diagnostics dialog box gives information about the
contact region where changes in the contact status prevent Abaqus from accepting the solution for an
Abaqus/Standard step. Chattering is a common difficulty preventing the contact convergence. The contact
diagnostics tool makes it very easy to detect chattering in a model. When a node’s status changes from
closed to open in one iteration and in the next iteration its contact status changes from open to closed; it is
said to be chattering and is an indication of instability in the contact.

Abaqus/Standard does not issue any warning message during 105th increment which means it has not
detected any solver problem.

Using Unsymmetric Solver

We already know that friction adds unsymmetric terms to the system of equations. In the current problem,
a coefficient of friction of 0.15 is specified for both contact interactions. By looking at the surfaces
involved in self-contact, it can be said that they have high curvature. Relative finite sliding of high
curvature surfaces when solved with surface-to-surface discretization, causes the magnitude and influence
of unsymmetric terms to be significant which combined with the presence of friction could be causing the
convergence difficulties. So we will use the unsymmetric solver for the current problem.

Change to Step module and open the Step Manager by picking .
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Select the Step-1 in the manager and pick Edit.

Under the Other tab select the Unsymmetric as shown below.

Unsymmetric option is used to invoke the unsymmetric storage and solution scheme.

Pick OK to apply the changes and exit.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select Door_Close and pick Submit > OK.

Notice that analysis job is again aborted. We will attempt to find the cause of this error in the Visualization
module. So pick Results to view the results in the Visualization module.

Pick to plot the contours on deformed shape. It can be seen in the figure below that job runs till 62nd
increment, completing the 0.6516 of step time as compared to 0.3673 of step time with 104 increments in
the previous case. It shows that convergence rate has improved significantly.
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To investigate the cause of analysis termination, pick Tools > Job Diagnostics and Job Diagnostics dialog
box will appear.

It can be seen that during the 62nd increment, system makes 6 attempts before aborting the analysis. During
the 5th attempt, there have been total 5 iterations and all of them are severe discontinuity iterations as
shown in the figure below. In all the iterations, it is reported (in the Summary tab) that neither the field
equations, nor the contact has converged.

In the above figure, it can be seen that in the 1ST iteration, contact status for node “45” changes from closed
to open. In the next iteration, contact status for the same node changes from open to closed as shown in the
figure below.



Solving Contact Problems Abaqus 2016

10

If contact status for a node changes from closed to open, it is recorded as an “opening.” If contact status
changes from open to closed, it is recorded as an “overclosure.”

When a node’s status changes from closed to open in one iteration and in the next iteration its contact
status changes from open to closed; it is said to be chattering and is an indication of instability in the
contact.

A large amount of strain energy can be stored in the contacting bodies. If the bodies separate suddenly, this
energy will be released. Local instabilities could arise in a static analysis due to contact openings as the
release of accumulated strain energy cannot be dissipated into kinetic energy.

During the attempt, warning messages appear in 1st, 2nd and 5th iterations. In the 1st iteration “Negative
eigenvalues” warning message appears as shown in the figure below.
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“Negative eigenvalue” messages appear due to some instability in the system.

It can be presumed that unstable contact is the cause of instability in the system. To stabilize the contact,
some form of damping will be required to dissipate the released energy.

Introducing Contact Stabilization

We will introduce the automatic contact stabilization to alleviate the convergence difficulties. This requires
to define contact controls.

So change to Interaction module and pick Interaction > Contact Controls > Create from the menu bar
(alternatively, double-click the Contact Controls in the Model Tree).

Enter Stabilize as the name of the Contact Controls.

Make sure that "Abaqus/Standard contact controls" option is selected and pick Continue.

In the Edit Contact Controls dialog box, toggle on Automatic stabilization.

When automatic stabilization option is selected, the default damping coefficient calculated automatically
by Abaqus/Standard is used. It introduces viscous damping for relative motions of the contact pair at all
slave nodes.
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Enter 0.001 as the stabilization factor to scale down the default damping factor.

Stabilization factor is used to scale the default damping coefficient by a specified factor to minimize the
effects of stabilization on the solution.

Pick OK to apply the changes and exit the dialog box.

Open the Interaction Manager by picking .

Pick the interaction “Seal-Seal” under column “Initial” and pick Edit.
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In the Edit Interaction dialog box, select the Stabilize in Contact controls field.

Pick OK to apply the changes and exit the dialog box.

Pick Dismiss to close the manager.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select Door_Close and pick Submit > OK.

Notice that analysis job is again aborted.

We will attempt to find the cause of this error in the Visualization module. So pick Results to view the
results in the Visualization module.

Pick to plot the contours on deformed shape. It can be seen in the figure below that job runs till 156th
increment, completing the 0.9761of step time as compared to 0.6516 of step time in the case without
stabilization. It shows that automatic contact stabilization has helped to advance the simulation.

To investigate the cause of analysis termination, pick Tools > Job Diagnostics and Job Diagnostics dialog
box will appear.

It can be seen that during the 156th increment, system makes 6 attempts before aborting the analysis.
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During the 5th attempt, there have been total 4 iterations and and all of them are severe discontinuity
iterations as shown in the figure below. In all the iterations, it is reported that neither the field equations,
nor the contact has converged. In the Contact tab, the contact chattering can be observed in all the
iterations during the attempt.

Furthermore during the attempt, warning messages appear in 1st and 4th iterations. In the 4th iteration
“Negative eigenvalues” warning message appear as shown in the figure above.

The contact chattering and warning messages give an indication of instability in the contact interaction.

It can be concluded that contact stabilization has helped to advance the solution but as the damping
coefficient is ramped down to 0 at the end of the step, analysis job suffers convergence difficulties. There
could be two ways to fix this problem. One is to specify a larger value of the damping coefficient, and
other is to specify a nonzero value for the ramp-down factor at the end of the step. By default, ramp-down
factor is equal to zero so that the damping vanishes completely at the end of the step. We will perform the
analysis using both ways and compare the results.

First we will specify a larger value of the damping coefficient and see how it affects the analysis.

Change to Interaction module and pick Interaction > Contact Controls > Manager from the menu bar.
The manager will appear as shown below.
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Pick the “Stabilize” in the manager and pick Edit.

Enter 0.01 as the stabilization factor. Also notice that fraction of damping at end of the step is set to 0 by
default.

When fraction of damping at end of step is set to zero, the damping is completely removed by the end of
the step therefore, generally, damping has negligible effect on the converged solution.

Pick OK to apply the changes and exit.

Pick Dismiss to close the manager.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select Door_Close and pick Submit > OK.

Notice that analysis job completes successfully.

Pick Results to view the results in the Visualization module.
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Pick to plot the contours on deformed shape. It can be seen in the figure below that job completes in
165 increments.

We can conclude that a larger value of contact stabilization has helped to overcome all the contact
difficulties. Now we will use the previous value of damping coefficient, for which analysis could not
converge, but this time we will specify a nonzero value for the ramp-down factor.

Again change to Interaction module and pick Interaction > Contact Controls > Manager from the
menu bar.

Pick the “Stabilize” in the manager and pick Edit.

Enter 0.001 as stabilization factor and specify 0.15 for the “Fraction of damping at end of step” field.

When a value of 1 is specified for the “Fraction of damping at end of step” field, damping coefficient is not
ramped down over the step.
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When “Fraction of damping at end of step” field is set to zero, Abaqus ramps down the contact
stabilization such that no contact stabilization remains at the end of the step. This guarantees that the
viscous forces decrease to zero, thus avoiding any discontinuity in the forces at the start of the next step.

Pick OK to apply the changes and exit.

Pick Dismiss to close the manager.

Now we will submit a new job.

Pick Create and create a job named Door_Close_FE or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Pick Results to view the results in the Visualization module.

Pick to plot the contours on deformed shape. It can be seen in the figure below that job completes in
177 increments.

Postprocessing

For a three-dimensional visual effect, we will extrude the simulation results. This helps a lot to understand
the contour plots.

While in the Visualization module, pick View > ODB Display Options and check the "Extrude elements"
option located under the Sweep/Extrude tab.

Enter 0.01 in the Depth field located under Sweep/Extrude tab.

Pick OK to apply and exit the dialog box.

Now select CPRESS as output variable in the Field Output toolbar.
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Now the simulation results will appear as shown below.

It can be seen that value of maximum contact pressure for both cases differs. So we can conclude that
different stabilization schemes have an effect on the analysis solution.

It is almost impossible to see the contact pressure distribution in the self-contact area of the seal. To help
the visualization of results, we will set the scale factor to less than unity.

So pick and set the scale factor to 0.7 in in the Common Plot Options dialog box.

Now the simulation results will appear as shown below.
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The introduction of contact stabilization in a problem can change the solution significantly. Although the
automatically calculated damping coefficient typically provides enough damping to stabilize a problem, it
is not certain that the value is unnecessarily high and distorting the solution. Therefore it is necessary to
verify that the inclusion of contact stabilization does not significantly alters the solution. The simplest
method is to compare the energy dissipation due to stabilization (ALLSD) to the elastic strain energy of the
model (ALLSE) or the internal energy of the model (ALLIE). Smaller the value of dissipation energy as
compared to the internal energy of the model, the better.

To plot these energies, pick and Create XY Data dialog box will appear.

Pick ODB history output > Continue

In the History Output dialog box, select ALLSD and ALLSE.

Pick Plot and the graph will appear. The following figure compares the energy histories as shown below.
Note: The y-axis is displayed in a base 10 logarithmic scale.)
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It can be seen that the dissipation energy is less than 1% of the strain energy of the model for both cases.
So it can be concluded that contact stabilization has a negligible effect on the solution.

Select File > Save to save the changes we made so for.

Note: In this example a coarse mesh has been used to limit the problem size to less than 1000 nodes (a
limitation of student version of Abaqus). It is recommended to use a fine mesh of linear, reduced-
integration elements (CAX4R, CPE4R, CPS4R, C3D8R, etc.) for simulations involving very large mesh
distortions
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Exercise 17

In this exercise we will perform the stress analysis of a door seal using softened contact approach.

Pick File > Set Work Directory and set the work directory to SealDoor folder

Open the model database SealDoor_Softened.cae.

In the previous exercise, automatic contact stabilization was used to alleviate the convergence difficulties.
In the current exercise, instead of using contact stabilization, “softened” pressure-overclosure relationship
will be introduced to overcome the convergence problems at the contact interface.

The “softened” contact pressure-overclosure relationships are usually used to model a soft, thin layer on
surfaces. In Abaqus/Standard they are also sometimes used because they can make it easier to resolve the
contact difficulties. Three types of softened contact relationships are available in Abaqus: exponential,
linear and tabular.

The analysis will be completed in one step. The unsymmetric equation solver has been specified for the
step. Two contact interactions have already been defined in the model. In this exercise, we will create three
contact interaction properties and prescribe softened pressure-overclosure relationship for each by using a
linear, a tabular and an exponential law.

Defining Contact Interaction Property

We will define a new contact interaction property using “Exponential” pressure-overclosure relationship.
This contact property will be specified for the self-contact interaction which has already been defined.

So change to Interaction module.

Pick to create a new contact interaction property.

Select Contact as type and enter Exponential-Friction as name of the property.
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Pick Continue and Edit Contact Property dialog box will appear.

PickMechanical > Tangential Behavior to specify tangential behavior (friction).

Pick Penalty as friction formulation and enter 0.15 as friction coefficient.

PickMechanical > Normal Behavior to specify normal behavior.

In the Pressure-Overclosure field, select Exponential.

When Exponential is selected in Pressure-Overclosure field, the contact pressure is an exponential function
of clearance between the surfaces. In an exponential pressure-overclosure relationship, the surfaces begin
to transmit contact pressure once the clearance between them, measured in the contact (normal) direction,
reduces to a specified value (co). The contact pressure transmitted between the surfaces then increases
exponentially as the clearance continues to diminish. The exponential relation is illustrated in the following
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figure.

To specify an exponential relation, it is required to specify co and po (the contact pressure at zero clearance).

Enter 2E6 as the contact pressure at zero clearance and 5E-6 as the clearance at zero contact pressure as
shown in the figure below.

.

Pick OK to apply the changes and exit the dialog box.

Modifying Contact Interaction

Open the Interaction Manager by picking .
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Pick the “Seal-Seal” interaction under column “Initial” and pick Edit.

Pick Exponential-Friction as the contact interaction property.

Pick OK to apply the changes and exit the dialog box.

Pick Dismiss to close the manager.
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Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named DoorClose_Exponential or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Defining Contact Interaction Property

We will define another contact interaction property using “Linear” pressure-overclosure relationship. This
contact property will be used for the self-contact interaction which has already been defined.

So change to Interaction module.

Pick to create a new contact interaction property.

Select Contact as type and enter Linear-Friction as name of the property.

Pick Continue and Edit Contact Property dialog box will appear.

PickMechanical > Tangential Behavior to specify tangential behavior (friction).

Pick Penalty as friction formulation and enter 0.15 as friction coefficient.

PickMechanical > Normal Behavior to specify normal behavior.

In the Pressure-Overclosure field, select Linear.

When Linear is selected in Pressure-Overclosure field, the contact pressure is a linear function of the
clearance between the surfaces. In a linear pressure-overclosure relationship the surfaces transmit contact
pressure when the overclosure between them, measured in the contact (normal) direction, is greater than
zero. It is required to specify the slope (contact stiffness) of the pressure-overclosure relationship, which
usually depends on the modulus of elasticity of underlying material. The linear relation is illustrated in the
following figure.
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Enter 1E11 as the contact stiffness as shown in the figure below.

Pick OK to apply the changes and exit the dialog box.

Modifying Contact Interaction

Open the Interaction Manager by picking .

Pick the “Seal-Seal” interaction under column “Initial” and pick Edit.

Pick Linear-Friction as the contact interaction property.

Pick OK to apply the changes and exit the dialog box.

Pick Dismiss to close the manager.
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Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named DoorClose_Linear or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Postprocessing

In the Visualization module it can be seen that with the Linear pressure-overclosure relation, contact
resolution has not been very accurate and penetration can be observed as shown in the figure below.

If we compare both techniques, it can be observed that analysis performed with linear relation completes
with only 26 increments, and with exponential relation it takes 53 increments. This shows a remarkable
improvement as compared to the solution obtained using contact stabilization in the previous exercise with
165 increments.

If we plot CPRESS, it can be observed that with the linear relation a maximum contact pressure of 3.56
MPa occurs and when exponential relation is specified a maximum contact pressure of 3.96 MPa can be
observed which is closer to the maximum pressure of 3.93 MPa with contact stabilization (which we
observed in the previous exercise).

We can conclude that “softened” contact has overcome the convergence difficulties arising due to
instabilities at the contact interface. The results obtained by specifying “softened” contact are not as
accurate as obtained with “hard” contact due to underlying assumptions in pressure-overclosure
relationships.
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When linear relation is specified, it is recommended to start with a small value of contact stiffness and then
increase it depending upon the penetration observed in simulation results. The following figure compares
the influence of contact stiffness on the simulation results.

It can be seen that as the contact stiffness is increased, penetration decreases. If the contact stiffness is
further increased to 2E11, the analysis will be aborted.

If an infinite value of contact stiffness is used, the results would be similar to those obtained with hard
contact. If a lower value of contact stiffness is used for a given problem, it might result in considerable
penetration and if a higher value of contact stiffness is used it might cause convergence difficulties.
Therefore some trials might be needed to find a suitable value of contact stiffness for a given problem.

Defining Contact Interaction Property

We will define another contact interaction property using “Tabular” pressure-overclosure relationship. This
contact property will be used for the self-contact interaction which has already been defined.

So change to Interaction module.

Pick to create a new contact interaction property.

Select Contact as type and enter Tabular-Friction as name of the property.

Pick Continue and Edit Contact Property dialog box will appear.

PickMechanical > Tangential Behavior to specify tangential behavior (friction).

Pick Penalty as friction formulation and enter 0.15 as friction coefficient.

PickMechanical > Normal Behavior to specify normal behavior.

In the Pressure-Overclosure field, select Tabular.

Tabular law is used to define a pressure-overclosure relationship in tabular form in which the contact
pressure is a piecewise linear function of the overclosure between the surfaces. To define a piecewise-
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linear relationship in tabular form, data pairs (pi,hi) of pressure versus overclosure (clearance corresponds
to negative overclosure) are specified as shown in the figure below.

In this relationship the surfaces transmit contact pressure when the overclosure between them, measured in
the contact (normal) direction, is greater than h1, where h1 is the overclosure at zero pressure. So the
surfaces can transmit pressure even there is a clearance between them.

Enter -2E-5 as the overclosure at 0 contact pressure and 0 as the overclosure for 4E6 contact pressure and
2E-5 as the overclosure for 10E6 contact pressure as shown in the figure below.

The data must be specified as an increasing function of pressure and overclosure. The data table must
begin with a zero pressure. The pressure-overclosure relationship is extrapolated beyond the last
overclosure point by continuing the same slope.

Pick OK to apply the changes and exit the dialog box.

Modifying Contact Interaction
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Open the Interaction Manager by picking .

Pick the “Seal-Seal” interaction under column “Initial” and pick Edit.

Pick Tabular-Friction as the contact interaction property.

Pick OK to apply the changes and exit the dialog box.

Pick Dismiss to close the manager.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named DoorClose_Tabular or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Postprocessing

In the Visualization module it can be seen that with the Tabular pressure-overclosure relation, a gap
remains between the self-contacting surfaces of the seal as shown in the figure below.

This gap can be reduced/eliminated by modifying the tabular relation. We will modify the “Tabular-
Friction” contact property such that a lower contact pressure is generated at the contact interface.

So change to Interaction module and open the Interaction Property Manager by picking .

Select Tabular-Friction and then pick Edit to modify the selected interaction property.
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For the normal behavior option, enter 1E6 as contact pressure for the 0 overclosure as shown in the figure
below.

Pick OK to apply the changes and exit the dialog box.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select DoorClose_Tabular and pick Submit > OK and notice that job completes successfully. In the
Visualization module it can be seen that gap no long appear between the self-contacting surfaces of the
seal as shown in the figure below.

It can be observed that analysis performed with tabular relation completes with 37 increments and a
maximum contact pressure of 3.73 MPa occurs.

A tabular relation can also be used instead of a linear relation as the linear pressure-overclosure
relationship is identical to a tabular relationship with two data points, when the first data point is located at
the origin.

It is important to consider that, when exponential or tabular pressure-overclosure relationships are used, the
contacting surfaces can transmit pressure even there is a clearance between them
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It can be concluded that “softened” contact is useful in the problems which face convergence difficulties,
especially when the distribution of contact pressure is not very important. It requires some effort and
forethought to determine the different parameters required for “softened” pressure-overclosure relations to
obtain results with acceptable accuracy.

Select File > Save to save the changes we made so for.
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Exercise 18

In this exercise we will perform the stress analysis of a jounce bumper.

A jounce bumper is used as part of shock isolation system in a vehicle to absorb impact and dampen
vibrations.

Pick File > Set Work Directory and set the work directory to JounceBumper folder

Open the model database Bumper.cae. It will appear as shown below.

The model consists of four axisymmetric parts: top plate, bottom plate, mandrel and jounce bumper. All
the parts except the jounce bumper are modeled as analytical rigid parts. There is an initial interference
between jounce bumper and mandrel. The jounce bumper is assumed to be made of rubber, which is
modeled as a Mooney-Rivlin material with C10= 5.2 MPa, C01 = 0.98 MPa and D=0.002 MPa-1. A
coefficient of friction of 0.05 is assumed between contacting surfaces. The bumper is meshed with bilinear
axisymmetric quadrilateral elements with reduced integration and hybrid formulation (CAX4RH).

Analysis Steps

The analysis will be performed in two steps. In the first step, interference between the jounce bumper and
mandrel is resolved. In the second step top plate is moved downwards which compresses the bumper
between bottom and top plates. The steps have already been defined.
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As the top plate moves downward, large deformations and self-contact take place, making the problem
highly non-linear. To take into account the large deformations, NLgeom option has been toggled on in both
steps. As the problem is highly nonlinear initial increment size has been set to 0.001 and minimum
increment size has been set to 1E-6 expecting that Abaqus might need to make very small increments to
resolve convergence difficulties.

Furthermore due to large relative sliding of surfaces and friction, it is expected that the magnitude and
influence of unsymmetric terms would be significant. So the unsymmetric solver has been specified for
this step.

Contact Interactions

Three contact interactions have already been defined. We will define one more to take into account the
self-contact of the bumper surfaces.

Change to Interaction module and open the Interaction Manager by picking .

Pick Create to define a new interaction.

Enter Bumper-Bumper as the name of the interaction.

Pick Step-2 in the Step field.

Select Self-contact as type.
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A self-contact interaction allows to define contact between different areas of a single surface.

Pick Continue to proceed.

We have already defined a surface so pick Surfaces on the right side of the prompt area and select the
Bumper-1.Outer.

It is very difficult to predict areas where self-contact will occur. To avoid any problems during analysis
and for ease of selection, complete outside surface of the bumper has been included in the surface
definition. This requires more computational resources as the scope of contact searches is expanded.

Pick Continue and Edit Interaction dialog box will appear.

Pick Friction2 as contact interaction property and Stabilize as contact control.
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As finite relative sliding of surfaces and large deformations will occur, contact convergence difficulties are
expected to happen. Therefore contact controls with automatic stabilization have been selected to alleviate
the convergence difficulties.

Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Boundary Conditions

Boundary conditions required for the analysis have already been defined. The boundary conditions
“BottomPlate” and “TopPlate” and “Mandrel” constrain the the motion of the respective parts. The top
plate is moved by a magnitude of 0.03 in the y-direction during Step-2.

History Output Requests

We want to plot load versus displacement curves for the top plate. This information is not included by
default in the ODB file. We will request two history output variables for that purpose.

Change to Step module.

Open the History Output Manager by picking .

Pick Create to define a new history output request.

Enter Load-Displacement as the name and pick “Step-2” in the Step column.
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Pick Continue to proceed.

In the Domain field, change to Set and select Set-RP.

Set-RP is a geometry set that contains the reference point of the top plate.

Check the RF2 and U2 variables as shown below.

Pick OK to apply and exit.

Pick Dismiss to close the manager.
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Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named Bumper_Compress or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

If you look in the message area, the following message can be seen.

“Job Bumper_Compress aborted due to errors.”

We will attempt to find the cause of this error in the Visualization module. So pick Results to view the
results in the Visualization module.

Diagnosing the error

Pick to plot the contours on deformed shape. It can be seen in the figure below that analysis job runs
till 164th increment completing the 0.9485 of step time in Step-2.

To investigate the cause of analysis termination, pick Tools > Job Diagnostics and Job Diagnostics dialog
box will appear. It can be seen that during the 164th increment, system makes 4 attempts before aborting
the analysis. After the first attempt, Abaqus/Standard reduces the increment size to 25% of its previous
value and makes another attempt. This process of cutbacks is repeated three times and then analysis is
stopped.

All the attempts for this increment have failed because the solution appears to be diverging as shown for
the 3rd attempt in the figure below.
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Also notice that increment size for the 3rd attempt has reached minimum value specified in the step
definition (1e-06).

If the time increment becomes smaller than the minimum you defined or more than 5 attempts are needed,
Abaqus/Standard stops the analysis.

During the 3rd attempts, it can be seen that total 4 iterations, and none of them is a severe discontinuity
iteration.

Abaqus/Standard does not issue any warning message during 3rd attempt which means it has not detected
any solver problem.

Using Line Search

In strongly nonlinear problems the Full Newton solution technique, which is used in Abaqus/Standard by
default, may sometimes diverge during equilibrium iterations. To handle such difficulties, Abaqus provides
the line search algorithm which can be considered as convergence enhancement technique. The line search
algorithm detects divergence and applies a scale factor to the computed displacement correction. The aim
is to find a better configuration which would help to overcome divergence.

By default, the line search algorithm is not enabled when using Full Newton method. We will activate the
line search algorithm to overcome the diverging solution.

Change to Step module and open the General Solution Controls Manager by picking Other > General
Solution Controls > Manager .
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Select the Step-2 in the manager and pick Edit.

Pick Continue to close the warning message.

In the General Solution Controls Editor, pick Specify and set the maximum number of line search
iterations to 5 as shown in the figure below.

Line search is not only useful in situations where equilibrium is not achieved due to divergence but it can
also increase the convergence rate for the problems with slow convergence.

Pick OK to apply the changes and exit.

Pick Dismiss to close the manager.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select Door_Close and pick Submit > OK.
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Pick Results to view the results in the Visualization module.

Postprocessing

Pick to plot the contours on deformed shape. The final deformed shape of the bumper will appear as
shown in the figure below.

To plot load versus displacement curves for the top plate, pick and Create XY Data dialog box will
appear.

Pick ODB history output > Continue

In the History Output dialog box, select RF2 and U2 and then pick Save As

Pick combine (XY,XY) as operation and check the Swap variables option so that displacement is plotted
along the x-axis.
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Enter Load-Displacement as name of the plot.

Pick OK and graph will appear as shown below.

Select File > Save to save the changes we made so for.

Note: In this example a coarse mesh has been used to limit the problem size to less than 1000 nodes (a
limitation of student version of Abaqus). It is recommended to use a fine mesh of linear, reduced-
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integration elements (CAX4R, CPE4R, CPS4R, C3D8R, etc.) for simulations involving very large mesh
distortions.
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Exercise 19

In this exercise heat transfer analysis of a bolted flange joint is performed by defining thermal contact
conductance as a function of contact pressure.

Bolted joints are widely used in many engineering structures. To determine the temperature distribution on
the mating components accurately, it is important to model the heat transfer across a bolted joint
realistically. The heat transfer depends strongly on the contact pressure at the interface. In this exercise,
the conductive heat transfer between the contact surfaces is modeled by defining thermal contact
conductance as a function of contact pressure. The simulation is performed by using coupled temperature-
displacement analysis.

Pick File > Set Work Directory and set the work directory to BoltedFlange folder

Open the model database Joint.cae. It will appear as shown below. As the problem is rotational symmetric,
so only 22.5° segment of the assembly is considered for the analysis.

The assembly consists of four three-dimensional, deformable parts: flange1, flange2, bolt and nut. The bolt
and nut hold the both flanges together. All the parts are assumed to be made from steel with a Young’s
modulus of 200 GPa and a Poisson’s ratio of 0.3. All the parts are meshed with 8-node, thermally coupled
and fully integrated, brick elements (C3D8T).

Analysis Steps

The analysis will be performed in two steps. In the first step, a bolt load is applied to model the tension in
the bolt using a static, general analysis procedure. In the second step a surface heat flux is applied on a
surface of the flange1 and heat transfer takes place from the flange1 to flange2. The second step is
performed with fully coupled thermal-stress analysis procedure.

The steps have already been defined. For the second step, a time period of 0.05 s is set for the transient
analysis.
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Load and Boundary Conditions

An initial temperature of 20o C is specified for the flange2, bolt and nut by defining predefined temperature
fields in the Initial step. Similarly an initial temperature 200o C is specified for the flange1. In the second
step a surface heat flux load is applied on a surface of the flange1.

A bolt load is applied by specifying a length adjustment to model the pre-tension in the bolt during first
step. In the second step, length of the fastener is fixed.

Symmetry boundary conditions have been applied on the symmetric faces of the assembly.

Defining Contact Interaction Property

In this section, a contact interaction property will be defined to be used for all contact interactions. The
conductive heat transfer between the contacting surfaces is modeled by including thermal conductance in
the contact property definition. We will define thermal contact conductance as a function of contact
pressure in this property.

So change to Interaction module.

Pick to create a new contact interaction property.

Select Contact as type and enter Friction-Conductance as name of the property.

Pick Continue and Edit Contact Property dialog box will appear.

PickMechanical > Tangential Behavior to specify tangential behavior (friction).

Pick Penalty as friction formulation and enter 0.1 as friction coefficient.

Pick Thermal > Thermal Conductance to specify thermal conductance.

Select the Use only pressure-dependency data.

Enter 5 as conductance for 0 pressure, 1000 for 2E6, 10000 for 5E6, 30000 for 10E6, 60000 for 15E6,
80000 for 20E6 and 120000 for 25E6 as shown in the figure below.



Solving Contact Problems Abaqus 2016

46

The tabular data must start at zero contact pressure. The value of conductance remains constant for contact
pressures outside of the interval defined by the data points.

Pick OK to apply the changes and exit the dialog box.

Defining Contact Interactions

Now we will use the contact detection tool to identify potential contact pairs in the model. The contact
detection tool is a fast and easy way to define contact interactions and tie constraints in a three-dimensional
model.

While the Interaction module is active, pick and Find Contact Pair dialog box will appear.

We don’t need to change any default setting for this exercise, so pick Find Contact Pairs tab.
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Notice that contact detection tool finds 6 contact pairs as shown in the figure below.

The contact detection dialog box lists each contact pair candidate and its default parameters in a tabular
format assigned to detected contact pairs. Notice that “Friction-Conductance” property has been assigned
to all the contact pairs.

It is desired to create a tie constraint between the bolt and nut surfaces. Type column indicates that a
contact interaction (CP-5-Bolt-1-Nut-1) will be created between bolt and nut surfaces by default. We need
to change the type parameter for this contact pair.
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So pick on cell under Type column for the CP-5-Bolt-1-Nut-1 contact pair and change it to Tie as shown in
the figure below.

Pick OK and Abaqus will create 5 contact interactions and 1 tie constraint which will appear in the model
tree.

These contact interactions and constraints can be edited like manually created interactions and constraints.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named FlangeJoint or any other suitable name.
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Pick Continue and then OK.

Pick Submit to submit the job for analysis and notice that job completes successfully.

Postprocessing

Select FlangeJoint job in the manager and pick Results

Pick to plot the contours on deformed shape.

We are interested in the temperature distribution in the flange2. So we will remove other parts from display.

So pick and select Part instances as the entities to remove.

Now select the flange2 in the viewport and pick Done.

Select NT11 in the Field Output toolbar.

The temperature distribution will appear as shown in the figure below.

Now we will plot the contours of contact pressure.

Select CPRESS as output variable in the Field Output toolbar. The contact pressure distribution will
appear as shown in the figure below.
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Higher temperature can be observed in the areas where contact pressure is higher. It can be attributed to the
contact pressure dependent contact conductance.

Select File > Save to save the changes we made so for.
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Exercise 20

In this exercise a disc brake system is analyzed.

A disc brake system is used to stop or adjust the speed of a vehicle with changing road and traffic
conditions. In a disc brake system, a set of pads is pressed against a rotating disc and due to friction, heat is
generated at the disc-pad interface. The heat transfers to the pad and disc increases their temperature.
Temperature changes cause the deformation of the disc and the pad and as a result contact pressure
distribution changes continuously. In this exercise a disc brake system is analyzed using fully coupled
temperature-displacement analysis procedure.

Pick File > Set Work Directory and set the work directory to DiscBrake folder

Open the model database Brake.cae. It will appear as shown below. As the disc is symmetric about a plane
normal to the axis, only half of the assembly is considered for the analysis (assuming that
thermomechanical loads applied to the system are also symmetric ).

The assembly consists of four three-dimensional instances: pin1, pin2, pad and disc. The pad represents the
back plate and friction material together. The pad is split and one side is assigned the section properties of
friction material and other is assigned the section properties of steel. The disc is assumed to be made from
cast iron with a Young’s modulus of 90 GPa and a Poisson’s ratio of 0.26. Thermal properties are also
specified for all the materials. Both the disc and the pad are meshed with 8-node, thermally coupled and
fully integrated, brick elements (C3D8T).

Analysis Steps

The analysis will be performed in two steps. In the first step, a force is applied to the pins which push the
pad and contact is established between the disc and the pad. This step is performed using a static, general
analysis procedure. In the second step, the disc is rotated at a constant angular velocity by defining a
boundary condition. The second step is performed with fully coupled thermal-stress analysis procedure.

The steps have already been defined. For the second step, a time period of 0.1 s is set for the transient
analysis.
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Load and Boundary Conditions

An initial temperature of 20o C is specified for the disc and the pad by defining predefined temperature
fields in the Initial step. In the first step, a concentrated force is applied to the pins which push the pad and
contact is established between the disc and the pad.

It is assumed that vehicle is moving downhill and brake is applied to maintain a constant velocity.
Therefore, in the second step, the disc is rotated at a constant angular velocity by defining a boundary
condition. Symmetry boundary condition has been applied on the disc face lying on the symmetry plane.

The pad is fixed such that it can only move along the axis of the disc.

Defining Contact Interaction Property

A contact interaction property, named “Friction”, has already been defined which will be used for the
contact interaction between the pins and the pad.

In this section, a contact interaction property will be defined to be used for the contact interaction between
the pad and the disc.

So change to Interaction module.

Pick to create a new contact interaction property.

Select Contact as type and enter Friction-Heat as name of the property.

Pick Continue and Edit Contact Property dialog box will appear.

PickMechanical > Tangential Behavior to specify tangential behavior (friction).

Pick Penalty as friction formulation

Select the Use temperature-dependent data.

In the literature it is reported that coefficient of friction is dependent on temperature. Typically, coefficient
of friction increases with increasing temperature initially and after reaching its peak value starts decreasing.

Enter 0.3 as friction coefficient for 20 temperature, 0.35 for 100, 0.37 for 150, 0.4 for 250, 0.3 for 350,
0.25 for 450 and 0.2 for 475 as shown in the figure below.
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Now we will define thermal contact conductance. It is assumed that the thermal contact conductance is a
function of gap clearance.

Pick Thermal > Thermal Conductance to specify thermal conductance.

Notice that the Use only clearance-dependency data option is selected by default.

Enter 1E6 as conductance for 0 clearance, 5E5 for 1E-6 and 0 for 5E-5 as shown in the figure below.
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The tabular data must start at zero clearance.
It is assumed that conduction is almost perfect therefore a large value for the contact conductance at 0
clearance has been specified.

In this model thermal contact conductance will remain constant at the zero clearance value for all contact
pressures. Another approach is to define contact conductance as a function of both clearance and contact
pressure.

Now we will specify heat generation due to the dissipation of energy created by the frictional sliding of
contacting surfaces.

Pick Thermal > Heat Generation to specify thermal conductance.

It is assumed that all the frictional energy is dissipated as heat, therefore the fraction of dissipated energy
caused by friction that is converted to heat is set to 1.0 (default).

It is also assumed that all the heat is distributed equally between the disc and the pad, therefore fraction of
converted heat distributed to slave is set to 0.5 (default).

Pick OK to apply the changes and exit the dialog box.

Defining Contact Interactions

Now we will use the contact detection tool to identify potential contact pairs in the model. The contact
detection tool is a fast and easy way to define contact interactions and tie constraints in a three-dimensional
model.

While the Interaction module is active, pick and Find Contact Pair dialog box will appear.

We don’t need to change any default setting for this exercise, so pick Find Contact Pairs tab.

Notice that contact detection tool finds 3 contact pairs as shown in the figure below.
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The contact detection dialog box lists each contact pair candidate and its default parameters in a tabular
format assigned to detected contact pairs. Notice that “Friction” property has been assigned to all the
contact pairs. As we intend to use “Friction-Heat” property for the interaction between the pad and the disc,
we need to modify the property for this interaction.

So pick on cell under Property column for the CP-1-Disc-1-Pad-1 contact pair and change it to Friction-
Heat as shown in the figure below.

Pick OK and Abaqus will create 3 contact interactions will appear in the model tree.

Now we will define a surface film condition interaction to model heat transfer from the disc surface due to
convection. Two surface film condition interactions have already been defined to model the convective
heat transfer from the cylindrical surfaces of the disc.

Open the Interaction Manager by picking . It will appear as shown below.
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Three newly created contact interactions and two film condition interactions can be seen in the manager.

Pick Create to define a new interaction.

Enter FilmBrakeSurface as the name of the interaction.

Pick Step-2 in the Step field.

Select Surface film condition as type.

Pick Continue to proceed.

Select the surface highlighted in the figure below.
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Pick Done and Edit Interaction dialog box will appear.

Enter 40 as film coefficient and 20 as sink temperature as shown in the figure below.

Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.
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So change to Job module and open the Job Manager by picking .

Pick Create and create a job named Downhill or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis and notice that job completes successfully.

Solution Controls

Select Downhill job in the manager and pickMonitor

In the Job Monitor it can be seen under the Data File tab that it takes 145 increments and 280 seconds
(wallclock time) to complete the job as shown below. (Note: Computational time will be different on
different machines depending upon the configuration.)

We will modify some solution controls such that solution time is reduced without affecting the accuracy.

Change to Step module and open the Step Manager by picking .

Select the Step-2 in the manager and pick Edit.

For the solution technique, select Separated under the Other tab.
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Although in a disc brake system mechanical and thermal solutions evolve simultaneously, the coupling
between the mechanical and thermal fields is weak. Therefore the set of equations can be approximated
such that the mechanical and thermal equations can be solved separately. This results in a less costly
solution.

Select Symmetric as the equation solver.

In the approximated set of equations, the subproblems may be fully symmetric or approximated as
symmetric, so that the less costly symmetric storage and solution scheme can be used. This results in
further savings in computational cost.

Select Parabolic as the extrapolation.

When parabolic option is selected, system uses a quadratic extrapolation, in time, of the previous two
incremental solutions to begin the nonlinear equation solution for the current increment.

Pick OK to apply the changes and exit.

Job Submission

Now we can submit the job for analysis.



Solving Contact Problems Abaqus 2016

60

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named DownhillSC or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis and notice that job completes successfully.

Select DownhillSC job in the manager and pickMonitor

In the Job Monitor it can be seen under the Data File tab that it takes 100 increments and 110 seconds
(wallclock time) to complete the job as shown below.

Note: Computational time will be different on different machines depending upon the system configuration.

Postprocessing

Select DownhillSC job in the manager and pick Results

Pick to plot the contours on deformed shape.

We are interested in the temperature distribution on the disc surface. So we will remove other parts from
display.

So pick and select Part instances as the entities to remove.
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Now select the disc in the viewport and pick Done.

Select NT11 in the Field Output toolbar.

Similarly plot the temperature distribution for Downhill job and you will notice that temperature
distribution is very much same for both jobs.

The following figure compares the temperature distribution for both cases.

So we can conclude that introduction of solution controls does not affect the solution accuracy but has
reduced the computational costs significantly.

Select File > Save to save the changes we made so for.
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