
Exercise 21

In this exercise we will use general contact approach to define contact interaction and perform the stress
analysis of assembly. We will also compare the results with contact pair approach.

Pick File > Set Work Directory and set the work directory to Sandwich folder

Open the model database SandwichShell.cae. It will appear as shown below.

The assembly consists of three three-dimensional, deformable parts: punch, die and blank. The punch
presses the blank against the die. The punch and die are assumed to be made from steel with a Young’s
modulus of 200 GPa and a Poisson’s ratio of 0.3. The blank is assumed to be made from aluminum with a
Young’s modulus of 70 GPa and a Poisson’s ratio of 0.3. The blank is meshed with linear, fully integrated,
quadrilateral shell elements (S4). The punch and die are meshed with 8-node, fully integrated, brick
elements (C3D8).

In the model tree, it can be seen that there are two models. In the “ContactPair” model, contact has been
defined by creating contact pair interactions. We will define a general contact interaction in the
“ContactGeneral” model in this exercise.

Analysis Steps

The analysis will be performed in one step. The step has already been defined with a total time period set
to 1.0 and the initial time increment to 0.01.
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Load and Boundary Conditions

Boundary conditions required for the analysis have already been defined. The punch is moved by a
magnitude of 0.0016 in the y-direction with the “Punch” boundary condition. By taking advantage of
symmetry, only a small portion of the assembly is modeled. Symmetry boundary conditions have been
defined accordingly.

Defining Contact Interactions

Now we will create a general contact interaction to define contact for the entire model..

First Change to Interaction module and make sure that ContactGeneral model is active.

Open the Interaction Manager by picking .

Pick Create to define a new interaction.

Enter All_General as the name of the interaction.

Pick Initial in the Step field.

In Abaqus/Standard general contact can be defined only in the initial step.

Select General contact and pick Continue to proceed.

In the Edit Interaction dialog box, pick Friction as the global contact interaction property.

This contact property is assigned globally to the general contact interaction. It is also possible to assign a
contact property individually to particular regions within a general contact domain.
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Notice that All* with self is selected by default. This is the simplest way to define the contact domain.

When “All* with self” option is used, Abaqus/Standard generates a surface that contains all exterior
element faces (with some exceptions) in the model and solves a self-contact problem for this all-inclusive
surface. The surface can span many disconnected regions/bodies in the model. Self-contact for the surface
that spans multiple bodies implies self-contact for each body as well as contact between the bodies. It is
not required to select any region/surface for a general contact interaction when “All* with self” option is
used.

Pick OK and it completes definition of the interaction.

Minimum initial gap between the blank and other parts is equal to the half of shell thickness. The general
contact interaction will account for the initial thickness of the blank by default.

General contact automatically accounts for thicknesses and offsets associated with shell surfaces.

Pick Dismiss to close the manager.
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Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named SandwichGeneral or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that job completes successfully.

An analysis job, named SandwichPair, has already been created for the ContactPair model. Also submit
this job so that a comparison could be made.

Postprocessing

Now we will compare the simulation results obtained by using contact pair approach with general contact
approach.

Select SandwichGeneral job in the manager and pick Results. Similarly open the SandwichPair job in the
visualization module.

First we will compare the stress distribution in the blank. So we will remove other parts from display.

So pick and select Part instances as the entities to remove.

Now select the blank in the viewport and pick Done.

Pick to plot the contours on deformed shape.

The following figure compares the distribution of von Mises stresses on the SNEG face of the shell for
both cases. (Note: Legend is same for both plots).
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It can be seen that stress distribution is almost similar for both cases.

Now we will plot the contours of contact pressure.

Select CPRESS as output variable for SandwichGeneral and CPRESS SNEG as output variable in the
Field Output toolbar for SandwichPair. The contact pressure distribution will appear as shown in the figure
below.

When general contact approach is used, the convention for reporting contact pressure is different from the
convention used for contact pairs. If contact output is requested for shell elements modeled with general
contact, the data for the SPOS and SNEG surfaces is not reported in separate data sets. Therefore the
comparison is not very helpful.

Now we will compare the contact pressure distribution on the die surface.

Pick to display all the parts on screen.

Pick and select the die in the viewport and pick Done.

Select CPRESS as output variable for both analysis jobs. The contact pressure distribution will appear as
shown in the figure below.
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It can be seen that contact pressure distribution is different for both cases. It can also be observed that the
contact pressure extends beyond the actual contact region when contact is modeled with general contact
approach. It is because the contour plots are constructed by interpolating nodal values, which can cause
nonzero values to appear outside of the contact region.

In the Job Monitor it can be seen on the Data File tab that it takes 26 seconds (wallclock time) to
complete the job for the model with contact pairs and 35 seconds for the model with general contact as
shown below.

Contact pairs often result in more efficient analyses as compared to general contact approach. It is because
Abaqus/Standard generates a surface that contains all exterior element faces in the model (when “All* with
self” option is used) and solves a self-contact problem for this all-inclusive surface as compared to contact
pair approach where typically only those surfaces are selected where contact is anticipated. Inclusion of
surfaces that never come into contact takes additional computation resources and hence general contact is
often less computational efficient.
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Select File > Save to save the changes we made so for.
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Exercise 22

In this exercise we will simulate the upsetting of a tubular rivet using general contact approach to define
contact interaction. We will also compare the results with contact pair approach.

Tubular rivets are similar to solid rivets, except they have a partial hole at the tail end. The purpose of this
hole is to reduce the amount of force required to upset the rivet.

Pick File > Set Work Directory and set the work directory to Rivet folder

Open the model database TubularRivet.cae. It will appear as shown below.

The assembly consists of two axisymmetric parts: rivet and punch. The punch is modeled as discrete rigid
part. The staple is assumed to be made from an alloy with a Young’s modulus of 200 GPa and a Poisson’s
ratio of 0.3. A coefficient of friction of 0.05 is assumed between contacting surfaces. The rivet is meshed
with bilinear axisymmetric quadrilateral elements with reduced integration (CAX4R).

In the model tree, it can be seen that there are two models. In the “ContactPairs” model, contact has been
defined by creating contact pair interaction. In the “ContactGeneral” model, contact will be defined by
using general contact interaction.

Analysis Steps

The analysis will be performed in one step. The step has already been defined with a total time period set
to 1.0 and the initial time increment to 0.01. Due to large relative sliding of surfaces and friction, it is
expected that the magnitude and influence of unsymmetric terms would be significant. So the unsymmetric
solver has been specified for this step. As the rivet is upset by the punch, large deformations take place. To
take into account the large deformations, NLgeom option has been toggled on.
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Boundary Conditions

Boundary conditions required for the analysis have already been defined. The punch is moved by a
magnitude of 0.004 in the y-direction with the “Punch” boundary condition.

Defining Contact Interaction

Now we will create a general contact interaction to define contact for the entire model..

First Change to Interaction module and make sure that ContactGeneral model is active.

Open the Interaction Manager by picking .

Pick Create to define a new interaction.

Enter All_General as the name of the interaction.

Pick Initial in the Step field.

In Abaqus/Standard general contact can be defined only in the initial step.

Select General contact and pick Continue to proceed.

In the Edit Interaction dialog box, pick Friction as the global contact interaction property.

Notice that All* with self is selected by default. This is the simplest way to define the contact domain.



Solving Contact Problems Abaqus 2016

10

Pick OK and it completes definition of the interaction.

Pick Dismiss to close the manager.

Field Output Requests

We will plot contact normal force (CNORMF) for comparison purposes. This information is not included
by default in the ODB file. We will modify the existing field and request CFORCE variable.

If CFORCE is requested, the variables CNORMF (normal contact force) and CSHEARF (shear contact
force) become available in the output database.

Change to Step module.

Open the Field Output Manager by picking .

Select the F-Output-1 field and pick Edit as shown below.

Check the CFORCE variable (located under the Contact container).
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Pick OK to apply and exit.

Pick Dismiss to close the manager.

Job Submission

All the information required for analysis for the ContactPairs model has already been set up. We will
submit an analysis job for the model.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named UpsetPairs (or any other suitable name) for the ContactPairs model .

Pick Continue and then OK.

Pick Submit to submit the job for analysis and notice that job completes successfully.

All the information required for analysis of the ContactGeneral model has now been set up. So we can
submit a job for analysis.

Pick Create and create a job named UpsetGeneral (or any other suitable name) for the ContactGeneral
model.

Pick Continue and then OK.

Pick Submit to submit the job for analysis and notice that job is aborted due to errors.
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Diagnosing the error

Both the ContactPairs and the ContactGeneral models have the same parameters set for analysis except the
different approaches to define contact. We know that when general contact approach is used,
Abaqus/Standard automatically generates a surface and assigns master and slave roles. So we will
investigate how general contact approach is handling the surface definition and master-slave roles.

We will try to find the cause of the errors in UpsetGeneral job in the Visualization module.

So pick Results to view the results in the Visualization module.

Pick to open the Create Display Group dialog box. (alternatively pick Tools > Display Group >
Create).

Pick Surface as the Item and Internal sets as the Method.

Check Highlight items in viewport

Pick General_Contact_Faces_1 and system will highlight the automatically generated internal surface as
shown below.
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Abaqus automatically generates internal surfaces using the naming convention General_Contact_Faces_k,
where k corresponds to an automatically assigned component number. By default, the lowered-number
component surfaces will act as master surfaces to the higher-numbered component surfaces.
Abaqus/Standard assigns default pure master-slave roles for contact involving disconnected bodies within
the general contact domain.

As there are two disconnected bodies in the general contact domain, two internal component-surfaces, i.e.
General_Contact_Faces_1 and General_Contact_Faces_2, are generated. The internal surface without a
component number, i.e. General_Contact_Faces, contains all surface faces included in the general contact
domain. The General_Contact_Faces_1 will act as master surface to the General_Contact_Faces_2.

Next pick General_Contact_Faces_2 and system will highlight the automatically generated internal surface
as shown below.

We can conclude that the internal surface containing all exterior element faces of the rivet is acting as
master surface. This is in contrast to the ContactPairs model, where a surface defined on the exterior faces
of the rivet acts as slave surface. So we will modify the general contact interaction to override the default
master-slave assignment. (Note: Although there are other ways to fix the error, our aim is to make the
changes in a way so that the solution is comparable to the solution obtained with contact pair approach.)

Modifying Contact Interaction

Open the Interaction Manager by picking .

Pick the “All_General” interaction under column “Initial” and pick Edit.
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Pick under the Contact Formulation tab to specify master-slave assignments.

The surfaces required to assign master-slave roles have already been defined and therefore appear in the
Edit Master-Slave Assignments dialog box.

Pick Punch-1.Surf-Top and Rivet-1.Surf-Bottom in the first and second columns respectively to define
the surface pairings.

Pick in the dialog box to transfer the selection to the list of Master-Slave Assignments.

SelectMASTER in the third column to specify that the first surface is the master surface
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Pick OK to apply the changes and exit dialog box.

Notice that Edit Interaction dialog box shows the number of Master-slave assignments as shown below.

Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select UpsetGeneral and pick Submit > OK and notice that job completes successfully.
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Comparing the Results

Now we will compare the results obtained from both models.

So pick Results to view the results in the Visualization module.

Pick to plot the contours on deformed shape.

Select PEEQ in the Field Output toolbar.

The following figure compares the distribution of equivalent plastic strain. (Note: Legend is same for both
plots).

The contour plots show that the equivalent plastic strain distribution is similar for both cases.

Select CPRESS as output variable in the Field Output toolbar.

The contact pressure distribution will appear as shown in the figure below.
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It can be seen that maximum contact pressure value is quite different for both cases. The convention for
computing contact pressure is different for the general contact and contact pair approaches. CPRESS is
computed from the contact normal force (the CNORMF vector, which is reported at the element nodal
positions), therefore we will compare the contact normal force distribution instead.

Select CNORMF as output variable in the Field Output toolbar.

The contact normal force distribution will appear as shown in the figure below.

It can be seen that maximum values of contact normal force are different for both cases. This difference
could be due to automatic surface smoothing.

By default, Abaqus/CAE automatically detects all circumferential, spherical, and toroidal surfaces in the
general contact domain that can be smoothed and applies the appropriate smoothing.

So for comparison purpose, we will modify the general contact interaction to prevent automatic surface
smoothing of the model.

Modifying Contact Interaction

Open the Interaction Manager by picking .

Pick the “All_General” interaction under column “Initial” and pick Edit.

Pick under the Surface Properties tab.
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Toggle off the Automatically assign smoothing for geometric faces option.

Pick OK to apply the changes and exit dialog box.

Notice that Edit Interaction dialog box shows that no surface smoothing assignment is applied in the model
as shown below.
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Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Now we will resubmit the job.

So change to Job module and open the Job Manager by picking .

Select UpsetGeneral and pick Submit > OK and notice that job completes successfully.

Comparing the Results

Now we will compare the results obtained from both models.

So pick Results to view the results in the Visualization module.

Pick to plot the contours on deformed shape.

Select CNORMF as output variable in the Field Output toolbar.

The contact normal force distribution will appear as shown in the figure below.



Solving Contact Problems Abaqus 2016

20

It can be seen that maximum values of contact normal force are almost same for both cases.

Select File > Save to save the changes we made so for.
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Exercise 23

In this exercise we will perform the stress analysis of a jounce bumper. We will use general contact
approach to define the contact interactions.

Pick File > Set Work Directory and set the work directory to JounceBumperLight folder

Open the model database Bumper.cae. It will appear as shown below.

The model consists of four axisymmetric parts: top plate, bottom plate, mandrel and jounce bumper. All
the parts except the jounce bumper are modeled as discrete rigid parts. There is an initial interference
between jounce bumper and mandrel. The jounce bumper is assumed to be made of rubber, which is
modeled as a Mooney-Rivlin material with C10= 5.2 MPa, C01 = 0.98 MPa and D=0.002 MPa-1. A
coefficient of friction of 0.1 is assumed between contacting surfaces. The bumper is meshed with bilinear
axisymmetric quadrilateral elements with reduced integration and hybrid formulation (CAX4RH).

Analysis Steps

The analysis will be performed in two steps. In the first step, interference between jounce bumper and
mandrel is resolved. In the second step top plate is moved downwards which compresses the bumper
between bottom and top plates. The steps have already been defined with a total time period set to 1.0 and
the initial time increment to 0.01 for each.

As the top plate moves downward, large deformations and self-contact take place. To take into account the
large deformations, NLgeom option has been toggled on in both steps.

Furthermore due to large relative sliding of surfaces and friction, it is expected that the magnitude and
influence of unsymmetric terms would be significant. So the unsymmetric solver has been specified for
this step.
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Defining Contact Interactions

Now we will create a general contact interaction to define contact for the entire model..

Change to Interaction module and open the Interaction Manager by picking .

Pick Create to define a new interaction.

Enter All_General as the name of the interaction.

Pick Initial in the Step field.

In Abaqus/Standard general contact can be defined only in the initial step.

Select General contact and pick Continue to proceed.

In the Edit Interaction dialog box, pick Friction as the global contact interaction property.

Notice that All* with self is selected by default.

When “All* with self” option is used, Abaqus/Standard generates a surface that contains all exterior
element faces (with some exceptions) in the model and solves a self-contact problem for this all-inclusive
surface. The surface can span many disconnected regions/bodies in the model. Self-contact for the surface
that spans multiple bodies implies self-contact for each body as well as contact between the bodies.

It can be seen that a small interference exists between two parts. By default in general contact interactions,
small initial overclosures are resolved using strain-free adjustments to the positions of surface nodes. We
will define a contact initialization method such that the initial overclosures are treated as interference fit.

Pick to create a new contact initialization
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Enter Resolve_Interference as the name of contact initialization.

Pick Treat as interference fits in the Edit Contact Initialization dialog box.

When ”Treat as interference fits” option is selected, Abaqus resolves contact overclosures gradually during
the first step in the analysis. As these overclosures are resolved, it results in stresses and strains in the
model.

Pick OK and it completes definition of the contact initialization.

Pick to assign this contact initialization to the desired regions.

The surfaces required to specify the initialization assignment have already been defined and therefore
appear in the Edit Initialization Assignment dialog box.

Pick Mandrel-1.Surf-1 and Bumper-1.Inner in the first and second columns respectively to define the
surface pairings.
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In the third column, select the “Resolve_Interference” as the contact initialization.

Pick in the dialog box to transfer the selection to the list of initialization assignments.

Pick OK to apply the changes and exit dialog box.

Notice that Edit Interaction dialog box shows the number of initialization assignments as shown below.
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Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Boundary Conditions

Boundary conditions required for the analysis have already been defined. The boundary conditions
“BottomPlate” and “TopPlate” and “Mandrel” constrain the the motion of the respective parts. Top plate is
moved by a magnitude of 0.035 in the y-direction during Step-2.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named BumperCompress or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Postprocessing

Select BumperCompress job in the manager and pick Results

Pick to plot the contours on deformed shape. The final deformed shape of the bumper will appear as
shown in the figure below.



Solving Contact Problems Abaqus 2016

26

Select File > Save to save the changes we made so for.

Note: In this example a coarse mesh has been used to limit the problem size to less than 1000 nodes (a
limitation of student version of Abaqus). It is recommended to use a fine mesh of linear, reduced-
integration elements (CAX4R, CPE4R, CPS4R, C3D8R, etc.) for simulations involving very large mesh
distortions
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Exercise 24

In this exercise we will perform the stress analysis of a boot seal due to angular movement of the shaft. We
will use both contact pairs and general contact approach to define the contact interactions.

Boot seals are used to protect steering mechanisms in automobiles. As the seal is symmetric about a plane
passing through the axis, only half of the assembly is considered for the analysis.

Pick File > Set Work Directory and set the work directory to SealBoot folder

Open the model database BootSeal.cae. It will appear as shown below.

The model consists of two three-dimensional parts: shaft and seal. The shaft is modeled as an analytical
rigid part. There is an initial interference between the seal and the mandrel. The seal is assumed to be made
of rubber, which is modeled as a Mooney-Rivlin material with C10= 5.2 MPa, C01 = 0.98 MPa and
D=0.002 MPa-1. A coefficient of friction of 0.15 is assumed between contacting surfaces. The seal is
meshed with 8-node brick elements with reduced integration and hybrid formulation (C3D8RH).

Analysis Steps

The analysis will be performed in two steps. In the first step, interference between the seal and the shaft is
resolved. In the second step the shaft is rotated. The steps have already been defined with a total time
period set to 1.0 and the initial time increment to 0.01 for each.

As the shaft rotates, large deformations and self-contact take place. To take into account the large
deformations, NLgeom option has been toggled on.

Defining Contact Interaction

The shaft is modeled as an analytical rigid part. As the general contact algorithm does not consider
analytical rigid surfaces in Abaqus/Standard, we need to define contact between the shaft and the seal with
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contact pairs approach. A contact pairs interaction has already been defined for that purpose. This
interaction resolves interference between the shaft and the seal during Step-1.

Now we will create a general contact interaction to define contact for the entire model.

General contact can be used simultaneously with the contact pair algorithm. Abaqus automatically
excludes interactions that are defined with the contact pair algorithm.

Change to Interaction module and open the Interaction Manager by picking .

Pick Create to define a new interaction.

Enter All_General as the name of the interaction.

Pick Initial in the Step field.

In Abaqus/Standard general contact can be defined only in the initial step.

Select General contact and pick Continue to proceed.

In the Edit Interaction dialog box, pick Friction as the global contact interaction property.

Pick OK and it completes the definition of interaction.

Pick Dismiss to close the manager.

Boundary Conditions

Boundary conditions required for the analysis have already been defined. “SealBottom” boundary
condition constrains the the motion of the bottom surface of the seal. “SealSymm” applies a symmetry
boundary condition to symmetry surface of the seal. “ShaftRP” boundary condition constrain the the
motion of the shaft. An angular movement of the shaft is specified during Step-2.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named ShaftRotate or any other suitable name.

Pick Continue and then OK.

Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.
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Postprocessing

Select ShaftRotate job in the manager and pick Results

Pick to plot the contours on deformed shape. The final deformed shape of the bumper will appear as
shown in the figure below.

It can be observed that the surfaces on compressed side of the seal have come into self-contact .

Select File > Save to save the changes we made so for.

Note: In this example a coarse mesh has been used to limit the problem size to less than 1000 nodes (a
limitation of student version of Abaqus). It is recommended to use a fine mesh of linear, reduced-
integration elements (CAX4R, CPE4R, CPS4R, C3D8R, etc.) for simulations involving very large mesh
distortions.
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Exercise 25

In this exercise we will perform the stress analysis of a door seal. We will use general contact approach to
define the contact interactions.

Pick File > Set Work Directory and set the work directory to SealDoor folder

Open the model database SealDoorGeneral.cae. It will appear as shown below.

The model consists of two parts: seal and door. The door is modeled as discrete rigid part. The seal is
assumed to be made of rubber, which is modeled as an incompressible Mooney-Rivlin material with C10=
3.1 MPa and C01 = 0.85 MPa. A coefficient of friction of 0.1 is assumed between the door and the seal and
a coefficient of friction of 0.15 is assumed for self contacting surfaces of the seal. The seal is meshed with
bilinear plane strain quadrilateral elements with reduced integration and hybrid formulation (CPE4RH).

Analysis Steps

The analysis will be performed in one step. The step has already been defined with a total time period set
to 1.0 and the initial time increment to 0.01.

As seal is modeled as a hyperelastic material, it may undergo large deformations. To take into account
these large deformations, NLgeom option has been toggled on in the step. Furthermore due to large relative
sliding of surfaces and friction, it is expected that the magnitude and influence of unsymmetric terms
would be significant. So the unsymmetric solver has been specified for this step.

Defining Contact Interaction

Now we will create a general contact interaction to define contact for the entire model.

Change to Interaction module and open the Interaction Manager by picking .
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Pick Create to define a new interaction.

Enter All_General as the name of the interaction.

Pick Initial in the Step field.

Select General contact and pick Continue to proceed.

In the Edit Interaction dialog box, pick Friction_15 as the global contact interaction property.

“Friction_15” interaction property defines a friction coefficient of 0.15. As we intend to specify a friction
coefficient of 0.1 between the door and the seal, we will define an individual property
assignment. Individual property assignments are used to assign different contact properties to individual
surface pairs.

Pick to create individual property assignment.

The surfaces required to specify the property assignment have not been defined beforehand, therefore we
will define new surfaces.

Pick to define a new surface.
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Enter Surf-Door as the name of the surface and pick Continue.

Pick the following edges while holding down Shift key.

Pick Done and notice that not all of the desired sides of the selected edges are of the same color as shown
in the figure below.
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So pick Flip a surface icon and select the left-most edge to reverse the orientation of this face. After
flipping it will appear as shown below.

“Flip a surface” option allows to reverse the orientation of any individual face before creating the surface
definition

Pick Yellow for the side of surface in contact.

As a surface can contact on either side, so it is important to specify the desired side of the surface to be in
contact. It is done by choosing the color associated with the desired side.

Again pick to define a new surface.

Enter Surf-Seal as the name of the surface and pick Continue.

Pick the following edges while holding down Shift key.

Pick Done to complete the definition.

Pick Surf-Door and Surf-Seal in the first and second columns respectively to define the surface pairings.

In the third column, select the “Friction_1” as the contact property.
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Pick in the dialog box to transfer the selection to the list of contact property assignments.

Pick OK to apply the changes and exit dialog box.

Notice that Edit Interaction dialog box shows the number of individual property assignments to 1 as shown
below.
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We will introduce the automatic contact stabilization to alleviate the convergence difficulties. It can be
seen that stabilization assignments field is not active in the dialog box. It is because that contact
stabilization cannot be assigned in the initial step. Therefore we will assign stabilization in the Step-1.

Pick OK to apply the changes and exit.

Pick the “All_General” interaction under column “Step-1” and pick Edit.

As general contact interaction can be created only in the initial step, stabilization assignment requires to
edit a general contact interaction in a later step.

Pick to create a new contact stabilization behavior.
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Enter ConStabilization as the name of contact stabilization behavior.

Enter 1 as the reduction factor.

Reduction factor determines how the damping value changes in successive increments. A value less than
one causes the damping to decrease with each increment. A value of one causes the damping to remain
constant with each increment

Enter 0.05 as the scale factor to scale down the default damping factor.

Scale factor is used to scale the default damping coefficient by a specified factor to minimize the effects of
stabilization on the solution.

Enter 0.5 as the tangential factor .

Tangential factor is used to control tangential stabilization. If it is set to zero then no stabilization is
applied in tangential direction.



37

Pick OK and it completes definition of the contact stabilization behavior.

Pick to assign the contact stabilization to the desired regions.

Pick Global and Self in the first and second columns respectively to define the surface pairings.

In the third column, select the ConStabilization as the contact stabilization behavior.

Pick in the dialog box to transfer the selection to the list of stabilization assignments.
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Pick OK to apply the changes and exit dialog box.

Notice that Edit Interaction dialog box shows the number of stabilization assignments as 1.

Pick OK and it completes the modification of the interaction.

Pick Dismiss to close the manager.

Boundary Conditions

Boundary conditions required for the analysis have already been defined. The boundary conditions “Door”
and “Seal” constrain the the motion of the respective parts. Door is moved by a magnitude of 0.015 in the
y-direction during Step-1.

Job Submission

All the information required for analysis has been set up in the model. Now we can submit the job for
analysis.

So change to Job module and open the Job Manager by picking .

Pick Create and create a job named DoorCloseGeneral or any other suitable name.

Pick Continue and then OK.
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Pick Submit to submit the job for analysis.

Notice that analysis job completes successfully.

Postprocessing

Select DoorCloseGeneral job in the manager and pick Results

Pick to plot the contours on deformed shape.

Now select CPRESS as output variable in the Field Output toolbar.

For a three-dimensional visual effect, we will extrude the simulation results. This helps a lot to understand
the contour plots.

While in the Visualization module, pick View > ODB Display Options and check the "Extrude elements"
option located under the Sweep/Extrude tab.

Enter 0.01 in the Depth field located under Sweep/Extrude tab.

Pick OK to apply and exit the dialog box.

To see the contact pressure distribution in the self-contact area of the seal, pick and set the scale
factor to 0.6 in in the Common Plot Options dialog box.

Now the simulation results will appear as shown below.

The introduction of contact stabilization in a problem can change the solution significantly. Although the
automatically calculated damping coefficient typically provides enough damping to stabilize a problem, it
is not certain that the value is unnecessarily high and distorting the solution. Therefore it is necessary to
verify that the inclusion of contact stabilization does not significantly alters the solution. The simplest
method is to compare the energy dissipation due to stabilization (ALLSD) to the elastic strain energy of the
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model (ALLSE) or the internal energy of the model (ALLIE). Smaller the value of dissipation energy as
compared to the internal energy of the model, the better.

To plot these energies, pick and Create XY Data dialog box will appear.

Pick ODB history output > Continue

In the History Output dialog box, select ALLSD and ALLSE.

Pick Plot and the graph will appear as shown below. Note: The y-axis is displayed in a base 10
logarithmic scale.)

It can be seen that the dissipation energy is less than 2% of the strain energy of the model. So it can be
concluded that contact stabilization has a negligible effect on the solution.

Select File > Save to save the changes we made so for.
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