
Composite Datum Curve
The composite datum curve is a copy of adjacent edges and/or curves that share common
endpoints.

Copy Curve tool is used to create a composite datum curve. By default Copy Tool is inactive and
becomes active when we make any valid selection (Object-Action behavior of Creo).

The composite curve can be created as an exact or approximate copy of selected references.

Exact—Creates an exact copy of the selected references.

Approximate—Creates a datum curve that approximates a chain of tangent curves and/or
edges by a single continuous curvature spline.

An approximate curve is coincident at the segment end points, but may vary from the rest of the
curve to attain curvature continuity.

A curve is considered curvature continuous if it consists of a single arc or spline.

If the curve consists of tangent entities, it is considered curvature discontinuous.
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Methods of Trimming or Extending a Chain

1. By Dragging
2. By Value
3. By a Reference

By Dragging

System provides the Drag Handles at the ends of a chain.

The handles can be moved freely along the chain by dragging with mouse. You can move a drag
handle along a 2D or 3D chain.

By Value

The chain may also be extended or trimmed by typing a positive or negative value respectively
from the graphics window.

By a Reference

A reference can be specified to which a chain is extended or trimmed. Valid references are the
items that intersect the chain. These include surfaces, planes, curves, edges, axes, and datum
points or vertices that lie on the chain.
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Exercise 1

In this exercise we will learn how to create a Composite Datum Curve by copying three different
datum curves using One-by-One chain construction technique.

Set the working directory to the DATUMS folder and open the model COPY2.PRT

The model consists of three datum curves as shown below.

We will use the One-by-One method of constructing chains to copy the desired geometry.

Pick the Curve_1 with left mouse pick. (we assume that Geometry filter is active).

Now hold down the Shift key and select the Curve_1 once again. Then pick Curve_3 and
Curve_2, one by one, while the Shift key is pressed. (For the successful selection of curve chain,
it is important to note that you have to pick the first curve once again after holding down the Shift
key)



You must select the original curve (you selected before holding down the Shift key) first of all and
then adjacent edges in One-by-One selection technique.

We cannot use the Ctrl key to select curves or edges when constructing chains to be copied as
Composite Datum Curve. As Ctrl key causes a new chain to be started each time a new edge is
selected. And Copy Tool requires only a single chain of entities to be selected. So if multiple
edges are selected using the Ctrl key, the Copy Curve tool will not be available.

Pick copy icon ( ) on the Model tab or press Ctrl+C on the keyboard.

Pick paste icon ( ) on the Model tab or press Ctrl+V on the keyboard.

In the reference panel you can see that it has been copied as a One-by-One Chain as shown
below.

Pick icon to complete the feature.

Select File > Save to save the work done so far.
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Exercise 2

In this exercise we will learn how to create a Composite Datum Curve by copying the edges of a
protrusion using One-by-One chain construction technique.

Set the working directory to the DATUMS folder and open the model COPY3.PRT

The desired chain of edges to be copied is shown in figure below.

Select the following edge. We assume Gometry filter is active.

Now hold down the Shift key and select the following edges one by one.



Pick copy icon ( ) on the Model tab or press Ctrl+C on the keyboard.

Pick paste icon ( ) on the Model tab or press Ctrl+V on the keyboard.

Pick icon to complete the feature.

Select File > Save to save the work done so far.
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Exercise 3

In this exercise we will learn how to create a Composite Datum Curve by copying the entire loop
of edges on a surface.

Set the working directory to the DATUMS folder and open the model COPY4.PRT

The desired chain of edges to be copied is is shown in figure below.

Select the following edge using any selection technique.

Hold down the Shift key and place the mouse pointer over any edge binding the top surface of
protrusion and Right-Click to query.



You should query until “Surface loop” tool-tip displays on the screen as shown below.

Surface loop chain contains an entire loop of edges that binds the surface to which it belongs.

Pick with left mouse button to select the highlighted chain.

Pick copy icon ( ) on the Model tab or press Ctrl+C on the keyboard.

Pick paste icon ( ) on the Model tab or press Ctrl+V on the keyboard.

Pick icon to complete the feature.

Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will learn additional chain construction techniques and see how they effect
the regeneration of Datum Curve.

Set the working directory to the DATUMS folder and open the model COPY5.PRT

The desired chain of edges to be copied is shown in figure below.

We will learn different methods of constructing the chains to copy the desired geometry. (we
assume that Geometry filter is active).

The chain of edges may be constructed by any of the following three chain construction methods.

1. One-by-One Chain
2. Tangent Chain
3. From-To Chain

One-by-One Chain

Select the following edge with left mouse pick.



Now hold down the Shift key and select the following three edges one by one.

Tangent Chain

Select the following edge with left mouse pick.

The first edge selected during the definition of Tangent chain is called its Anchor.

Hold down the Shift key and place the mouse pointer over any of the tangent edges and Right-
Click to query.
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You should query until Tangent tool-tip displays on the screen as shown below.

Pick with left mouse button to select the highlighted chain.

Tangent chain consists of all edges that are tangent to their neighboring edges and tangent to
the anchor. In other words Tangent chain consists of Anchor and the extent to which adjacent
entities are tangent.

From-To Chain

Select the following edge with left mouse pick.

The first edge selected during the definition of From-To chain is called its Anchor.



Hold down the Shift key and Right-Click to query the following edge.

The edge used to query the chain is called the Extent Reference.

You should query until “Surface loop from to” tool-tip displays on the screen as shown below.

Pick the highlighted chain with left mouse button to select it.

From-To chain consists of all edges located between the Anchor and the Extent Reference.
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You may use any of the above mentioned techniques to select the desired chain according to the
intent.

After chain selection, pick Edit > Copy or press Ctrl+C on the keyboard.

Pick paste icon ( ) on the Model tab or press Ctrl+V on the keyboard.

Pick icon to complete the feature.

Select File > Save to save the work done so far.

The chain construction technique influences the regeneration of the Composite Curve when
geometry is added before curve feature. The following diagram explains the effect of chain
construction technique when an extruded protrusion is added in the model before the curve
feature.



Intersected Datum Curve
An Intersected Datum Curve is created at the intersection of

 Surfaces with other surfaces
 Surfaces with datum plane
 Projection of two sketches or sketched datum curves

The surfaces may belong to a quilt or solid.

Intersect tool is used to create the Intersected Datum Curve. By default Intersect Tool
is inactive and becomes active when we make any valid selection (Object-Action behavior of
Creo).
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Exercise 1

In this exercise we will learn how to create an Intersected Datum Curve at the intersection of two
surfaces.

Set the working directory to the DATUMS folder and open the model INTERSECT1.PRT

The model consists of two quilts as shown below.

Now we will use the Intersect tool to create the Intersected Datum Curve.

By default Intersect Tool is inactive and becomes active only when we make any valid selection
(Object-Action behavior of Creo).

First pick the extruded quilt with left mouse click. Use the Feature filter for ease of selection.

Now hold down the Ctrl key and pick the swept surface.



Pick on the Model tab to invoke the Intersect Tool.

The Intersected Datum Curve will appear as shown below.

The Intersect feature automatically completes without opening the Intersect dashboard.
Automatic completion occurs because the Intersect process is fully defined by pre-selecting
references, and no optional settings are possible.

Select File > Save to save the work done so far.
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Exercise 2

In this exercise we will learn how to create an Intersected Datum Curve at the intersection of a
surface and all solid geometry of a part.

Set the working directory to the DATUMS folder and open the model INTERSECT2.PRT

The model will appear as shown below.

First pick the surface with left mouse click. You may need to query (Right-click) to pre-highlight
the surface.

Pick on the Model tab to invoke the Intersect Tool.

Intersect Tool becomes active after the selection of first valid reference.

Intersect Dashboard will appear as shown below.



Notice that References tab is red. It is to tell you that system requires you to select the required
references.

So hold down the Ctrl key and move the mouse pointer over the solid geometry.

Right-Click to query until “SolidGeom” tool-tip displays on the screen as shown below.

Pick with left mouse button to select the solid geometry of the part and then release the Ctrl key.

Alternatively you can also use the Solid Geometry filter.

Keep in mind that Solid Geometry Filter is available only in Intersect Tool.

Now pick tab to access Reference slide-up panel and you will notice that selected
references appear in the Surfaces collector as shown below.

Pick icon to complete the feature.

The Intersected Datum Curve will appear as shown below. (After hiding the swept surface)
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Select File > Save to save the work done so far.

The most common purpose of generating such curves is to use them as hinge while creating the
Draft feature.

The same technique can also be used to intersect a datum plane with the solid geometry of the
part. An example is shown below.



Exercise 3

In this exercise we will learn how to create an Intersected Datum Curve.

Set the working directory to the DATUMS folder and open the model INTERSECT3.PRT

Notice that model consists of two sketched datum curves on different planes as shown below.

Pick both of the datum curves by holding down the Ctrl key.

Pick on the Model tab to invoke the Intersect Tool.

The Intersected Datum Curve will appear as shown below.
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Notice that Sketched datum curves used to create the Intersected curve are automatically hidden.

The Intersect feature automatically completes without opening the Intersect dashboard.
Automatic completion occurs because the Intersect process is fully defined.

The resultant datum curve is the intersection of the two sketches when projected normal to the
sketching planes.

Select File > Save to save the work done so far.

If you look in the model tree you will notice that sketched datum curves are copied into the
Intersect Feature as dependent copies. (It is evident by the names of the sketches.) Remember
that a dependent section shares its name with the parent.)

This dependent section is fully associative with the parent sketched datum curve. If you modify
the sketched datum curves the Intersected Curve will update accordingly. However a copied

section can be made independent by redefining the Intersect feature and picking in the
Reference slide-up panel.

When we unlink a sketch, the system breaks the association with parent sketch and creates an
independent copy as internal sketch in the Intersect Tool.



Wrapped Datum Curve
The wrapped datum curve is created by wrapping a sketch around a solid or quilt. Wrapped
datum curve is 'wrapped' onto a surface as opposed to Projected which is projected from a
single direction. It preserves the length of the original sketched curve, when possible. The
destination of the wrapped curve must be a developable surface e.g. extruded surfaces.

Wrapped datum curves are used to simulate items such as labels or screw threads.

Wrap tool is used to create wrapped datum curves.

Origin of Wrapped Datum Curve

The origin of a wrapped datum curve is the reference point around which the sketch is wrapped
onto a destination. This point must be able to be projected onto the destination. Otherwise, the
Wrap feature fails.

There are two options to specify the Origin of the Wrapped Datum Curve.

1. Center
2. Sketcher CSYS

Center option uses the geometric center of the sketch as the origin.

Sketcher CSYS option uses any coordinate system in the sketch as the origin.
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Exercise 1

In this exercise we will learn how to create a datum curve by wrapping a sketched curve around
a cylinder.

Set the working directory to the DATUMS folder and open the model WRAP1.PRT

The model consists of a sketched datum curve and a cylinder.

Now we will use the Wrap tool to create the Wrapped datum curve.

Pick on the Model tab to invoke the Wrap Tool.

Pick References tab to access Reference slide-up panel. Notice that Sketch reference collector
is active by default.

So select the sketched datum curve i.e. “SKETCH 1” with left mouse pick.

You should also notice that system has automatically selected the Solid Geometry as
Destination as highlighted in the figure below. It is so because Creo Parametric automatically
selects the first available destination in the default wrapping direction.



Also notice that origin of wrapped datum curve is set to Center.

Center option uses the geometric center of the sketch as the origin.

Pick icon to complete the feature.

The Wrapped Curve will appear as shown below.

Select File > Save to save the work done so far.
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The following figures explain how the curve is wrapped onto the Destination.

1. System determines the geometric center of the Sketched Datum Curve.

2. The geometric center of the Sketched Datum Curve is projected to the Destination. The
projection direction is normal to Sketch Plane. This determines the Origin of the Wrapped
Datum Curve.



3. The Sketched Datum Curve is wrapped around the Origin (of Wrapped Datum Curve)
onto the destination to construct the Wrapped Datum Curve.

4. Notice that length of the original sketched curve is preserved.
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Exercise 2

In this exercise we will learn to wrap a sketched entity using the Sketcher CSYS as the Origin.

Set the working directory to the DATUMS folder and open the model WRAP2.PRT

Pick on the Model tab to invoke the Wrap Tool.

Pick References tab to access References slide-up panel.

Pick to sketch the internal section for wrapping.

Pick the DTM1 as Sketching Plane and TOP as Right reference.

In the sketcher, pick to insert a coordinate system. Dimension the coordinate
system as shown below.



Now sketch a straight line as shown below.

Pick to complete the sketch. Notice that system has automatically selected the “Sketcher
CSYS” as the method of determining the Origin.

Sketcher CSYS option uses the coordinate system in the sketched datum curve as the origin.

Now the model will appear as shown below.
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Pick icon to complete the feature.

Select File > Save to save the work done so far.

The following figures explain how the curve is wrapped onto the Destination.

1. The coordinate system of the Sketched Curve is projected to the Destination. The
projection direction is normal to Sketch Plane. This determines the Origin of the Wrapped
Datum Curve.

2. The Sketched Datum Curve is wrapped around the Origin (of Wrapped Datum Curve)
onto the destination to construct the Wrapped Datum Curve.

3. Notice that length of the original sketched curve is preserved.



Exercise 3

In this exercise we will learn how to wrap the text onto a cylinder.

Set the working directory to the DATUMS folder and open the model WRAP3.PRT

The model consists of a sketched datum curve and a cylinder as shown below.

The following figure shows the sketched datum curve in sketcher mode. It can be seen that a
sketcher coordinate system has been placed at the start of the text.

We will use this sketcher coordinate system to setup the Origin of the Wrapped Datum Curve.

Pick on the Model tab to invoke the Wrap Tool.

Using the Feature filter, pick the sketched text with left mouse pick.

Now look at the model and notice that text appears mirrored onto the cylinder as shown below.
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So pick on the dashboard to change the direction of wrap.

Now the model will appear as shown below.

Pick icon to complete the feature. The Wrapped Curve will appear as shown below.



Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will learn to create a helical curve around a cylinder.

Set the working directory to the DATUMS folder and open the model WRAP4.PRT

The model consists of a cylinder as shown below.

Pick on the Model tab to invoke the Wrap Tool.

Pick References tab to access Reference slide-up panel.

Select and pick the TOP datum as Sketching Plane and RIGHT datum as Left
Orientation reference.

In the sketcher, pick to insert a coordinate system as shown below.



Now sketch a straight line as shown in the figure below.

The vertical dimension represents the multiple of Pitch and Number of Coils. The horizontal
dimension represents the multiple of Pi, Diameter of Cylinder and Number of Coils.

For the above sketch we considered
Pitch = 10
Number of Coils = 4
Cylinder Diameter = 30 (Diameter of extrusion)
40 = Pitch * Number of Coils
376.99 = π * Cylinder Dia * Number of Coils

Pick to complete the sketch.

Pick icon to complete the feature.

The Wrapped Curve will appear as shown below.
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Select File > Save to save the work done so far.



Exercise 5

In this exercise we will learn to create a non-circular helical curve.

Set the working directory to the DATUMS folder and open the model WRAP5.PRT

The model consists of an extruded surface. We will wrap a curve around this surface to create
the desired helical curve.

Pick on the Model tab to invoke the Wrap Tool.

Pick References tab to access Reference slide-up panel.

Select and pick the TOP datum as Sketching Plane and RIGHT datum as Left
Orientation reference.

In the sketcher, pick to insert a coordinate system at the intersection of default
references as shown below.

Now sketch a straight line as shown in the figure below.

The vertical dimension (i.e. in above figure) represents the multiple of Pitch and Number of Coils.
The horizontal dimension represents the multiple of perimeter (of the cross-section of extruded
surface) and Number of Coils.

For the above sketch we considered
Pitch = 5
Number of Coils = 6
Perimeter = 111.416 (measured within model by Length tool)
The dimensions showed in above figure can be derived as
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30 = Pitch * Number of Coils
668.496 = Perimeter * Number of Coils

Pick to complete the sketch.

Pick icon to complete the feature.

The Wrapped Curve will appear as shown below after hiding the surface.

Select File > Save to save the work done so far.

The perimeter of the extruded surface can be measured with the Length measurement
functionality as shown below. Measure dialog box can be accessed by picking Measure >
Length under the the Analysis tab.

To measure the length of multiple entities, select an edghe and right click. In the menu check the
Use as Chain option.



Using the Rule-based option, perimeter of the extruded surface can be measured easily.
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From Equation Datum Curve
“From Equation” option is used to define a datum curve by specifying a mathematical equation.

For use in equation the system provides a pre-defined parameter “t” which varies form 0 to 1. At
the start point of the datum curve, t is 0 and increases to 1 till the end point.

From the basic mathematics, we know that a point in space can be located with any of the
following three coordinate systems.

1. Cartesian Coordinate System
2. Cylindrical Coordinate System
3. Spherical Coordinate System

Cartesian Coordinate System

In Cartesian Coordinate System any point may be represented by three signed numbers (x, y, z).
Any of these numbers is called a coordinate.

A coordinate is the perpendicular distance from the plane formed by the other two axes. So
following are true for points measured in Cartesian coordinate systems.

1. Points located on x-axis have y and z coordinates equal to zero (x, 0, 0).
2. Points located on y-axis have x and z coordinates equal to zero (0, y, 0).
3. Points located on z-axis have x and y coordinates equal to zero (0, 0, z).

Cylindrical Coordinate System



In cylindrical coordinate system, a point is represented by three variables r, theta and z

“r” is the projected distance of a point from z-axis in xy-plane
“theta” is the angle of projection with x-axis in xy-plane.
“z” is rectangular vertical coordinate

Spherical Coordinate System

In this coordinate system a point is located by three variables “rho”, “theta” and “phi”.

“rho” is the distance of the point from origin
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“theta” is the angle between the vector, joining the point with origin, and the z-axis.
“phi” is the angle between the projection of vector, that joins the point with origin, and x-axis.

In the following exercises we will see how to create the datum curves by defining equations in
the three coordinate systems.



Exercise 1

In this exercise we will learn how to create a straight line in Cartesian Coordinate System with
“From Equation” datum curve tool.

Set the working directory to the DATUMS folder and open the model EQUATION1.PRT

Pick on the Model tab to create a curve from equation.

Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

The curve is interpolated about this coordinate system.

Notice that Cartesian is selected by default.

Pick and in the pop-up text editor window enter the following equations.

x = 50 * t

y = 5 + 10 * t

Text editor window will appear as shown below.
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In the above equations “t” is the pre-defined system parameter which varies form 0 to 1. It must
appear in at least one equation.

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.

The following figure explains the concept that value of t varies from 0 to 1 and how the equations
are evaluated accordingly.



Select File > Save to save the work done so far.
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Exercise 2

In this exercise we will learn how to create a sine curve in Cartesian Coordinate System with
From Equation datum curve tool.

Set the working directory to the DATUMS folder and open the model EQUATION2.PRT

Pick on the Model tab to create a curve from equation.

Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

Notice that Cartesian is selected by default.

Pick and in the pop-up text editor window enter the following equations.

x = 100 * t

y = 10 * sin ( 360 * 5 * t)

In the above equations

“100” is the length of curve along x-axis.
“10” is the amplitude of the waves.
“5” are the number of waves.
“t” is the pre-defined system parameter which varies form 0 to 1. It must appear in at least one
equation.

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.

The following figure explains the concept.



Select File > Save to save the work done so far.
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Exercise 3

In this exercise we will learn how to create an ellipse in Cartesian Coordinate System with From
Equation datum curve tool.

Set the working directory to the DATUMS folder and open the model EQUATION3.PRT

Pick on the Model tab to create a curve from equation.

Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

Notice that Cartesian is selected by default.

Pick and in the pop-up text editor window enter the following equations.

x = 16 * sin ( 360 * t )

y = 10 * cos ( 360 * t )

In the above equations

“16” is the half of the major diameter of ellipse
“10” is the half of the minor diameter of ellipse

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.

The following figure explains the concept.



You can switch the major and minor diameters along the axis so that major diameter is along the
y-axis and minor diameter is along x-axis. It can be elaborated by the following figure.

We can also create a circle by modifying the equations as elaborated by the following figure.

Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will learn how to create helical curve in Cartesian Coordinate System with
From Equation datum curve tool.

In the previous exercises we learned to create the geometry in 2D plane but now we will create
the curve in 3D space by using the third coordinate, z.

Set the working directory to the DATUMS folder and open the model EQUATION4.PRT

Pick on the Model tab to create a curve from equation.

Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

Notice that Cartesian is selected by default.

Pick and in the pop-up text editor window enter the following equations.

x = 10 * sin ( 5 * 360 * t )

y = 10 * cos ( 5 * 360 * t )

z = 40 * t
In the above equations

“10” is the radius of the helical curve
“5” are the number of turns
“40” is the overall height

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.



The following figure explains the concept.

We can also create an elliptical helix by modifying the equations as elaborated by the following
figure.

Select File > Save to save the work done so far.
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Exercise 5

In this exercise we will learn how to create ripples around the circumference of a circle in
Cylindrical Coordinate System.

Set the working directory to the DATUMS folder and open the model EQUATION5.PRT

Pick on the Model tab to create a curve from equation.

Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

Pick Cylindrical in the drop-down list to create the curve using Cylindrical coordinate system.

Pick and in the pop-up text editor window enter the following equations.

r = 15

theta = t * 360

In the above equations

“15” is the radius of the circle

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.



Now redefine the datum curve and modify the equations as shown below.

r = 15 + 2 * sin ( 12 * 360 * t )

theta = t * 360

In the above equations

“2” is the amplitude of ripples
“12” are the number of ripples

After saving the changes the datum curve will appear as shown below.

Select File > Save to save the work done so far.
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Exercise 6

In this exercise we will learn how to create an Archimedes' spiral in Cylindrical Coordinate
System.

First of all we will review some basic information about Archimedes' spiral. A spiral is a curve in a
plane or in space, which runs around a center. In Archimedes' spiral the radius "r" is proportional
to the angle "θ" at any given point of the spiral.

Mathematically an Archimedes’ spiral is expressed as

r = R1 + ( R2 - R1 ) * t

r=radius of curve at any point (a variable)
R1=Radius at start point (a constant)
R2=Radius at the end of curve (a constant)
t=a variable which changes from 0 to 1 from start to end

Now we will create the Archimedes' spiral using the From Equation datum curve tool.

Set the working directory to the DATUMS folder and open the model EQUATION6.PRT

Pick on the Model tab to create a curve from equation.



Now the system will ask to select the Coordinate System. So pick the PRT_CSYS_DEF with
mouse.

Pick Cylindrical in the drop-down list to create the curve using Cylindrical coordinate system.

Pick and in the pop-up text editor window enter the following equations.

r = 10 + ( 20 - 10 ) * t

theta = 3 * t * 360

In the above equations

“10” is the radius at start point
“20” is the radius at the end of curve
“3” are the number of turns

Pick to save the changes and exit the editor.

Pick to complete the feature. The datum curve will appear as shown below.

The following figure explains the concept.
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Select File > Save to save the work done so far.
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