Exercise 1

In this exercise we will create a door handle. The completed part is shown below.

You will notice that the handle is slim in the center but fat at the ends. This is evident in the top
view shown in the figure below

Set the working directory to the EXAMPLES folder and open the model DOOR_HANDLE.PRT

You can see a surface on screen created by a sweep feature as shown below.

—> Modify the surface

We will redefine the Sweep feature and add relations to make it slim in center.

il
Pick the “Sweep 1” in model tree and select *
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Pick — and sketcher will appear as shown below.
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Notice that sketch consists of an ellipse. We will add relations so that the dimensions vary during
the sweep operation according to our requirement.

Pick 9= Relitons o the Tools tab and Relations dialog box will appear.
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Now enter the following relations in the dialog box.
sd7 = 4-1.5 *sin (trajpar * 180)

sd4 = 3.5-1.75* sin ( trajpar * 180 )



The “sd7” and “sd4” are symbols assigned to the ellipse dimensions in sketcher. These symbols
might be different depending upon the circumstances. The following figure elaborates clearly.
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Using the trajectory parameter, trajpar, in a relation for a sweep feature allows to map any
function, along the Origin Trajectory. The value of trajpar changes from 0 to 1 as the section is
swept along the Origin Trajectory from start to end.

Pick  “C  tosave changes and exit the Relations dialog box.
pick ¥ to complete the sketch.

Pick .l to complete the feature and surface will appear as shown below.
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Now we need to close the open ends so that quilt can be converted to a solid. For this, we will
merge an extruded surface with the swept surface. The extruded surface has already been

created but hidden.
So select the “Extrude 1” feature and pick Show ( © ) to unhide.
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= Merging the surfaces

Now select both quilts while holding down the Ctrl key as shown below. (Tip: You can use the
Quilt filter for selection or drag the pointer over the both quilts to select them.)

| Geometry
Edge
Surface
Datums
Curve
Quilt
Annotation

Yertex

| Feature

Pick &% 41 the Model tab to invoke Merge tool.

Pick on the arrow to flip its direction as shown in figure below. This is necessary to keep the
desired side of the quilt.



Pick on this arrow

K
(Note: Instead of picking on arrow, you can also use A or / icons on the dashboard to
change the side of quilt to keep.)

Now the preview will appear as shown below.

Pick ‘, or middle-click to complete the merge feature. The quilt will appear as shown below.
(If it does not appear as shown below then you need to redefine the merge feature and fix it.)

Notice that the joint between both quilts appears magenta which means that both surfaces have
been merged into a single quilt.

= Solidifying the quilt

Now select the quilt as shown below.
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Select this quilt

Pick T 59 on the Model tab to invoke Solidify tool.
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Solidify dashboard will appear as shown below.
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References Properties

Pick v or middle-click to complete the feature. The part will appear as shown below.

The black color of contours shows that now it is no more a quilt but a solid.

Select File > Save to save the work done so far.



Exercise 2

In this exercise we will create the surface model of a hand grip.
Set the working directory to the BASICS folder and open the model HAND GRIP.PRT

The model consists of four datum curves as shown below.
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—> Creating the surface

Pick “I=¥*% icon to invoke the Sweep tool.

Pick the straight datum curve (Sketch 1) with left mouse pick to make it Origin Trajectory. (Set
the view to Default Orientation to avoid any confusion)
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Now hold down the Ctrl key and pick the other three curves to add them as chains.
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The order, in which chains are selected have no effect on the sweep geometry. Only the desired
Origin Trajectory should be selected first.

[

Pick | "' [4ah to open the References slide-up panel and confirm that there are three
chains in addition to Origin Trajectory.

Trajectories X M T
Origin ] i |
Chain 1 =) ] EE
Chain 2 ] L] EHE
Chain 3 i [l EE

Details...

Section plane control
Mormal To Trajectory b

HorizontalVertical control

Automatic -

X direction reference at start
Default

Pick 'Sweep as surface' icon (" . ) to create a surface with this sweep feature.

U

dalz a - =E o %o v x

References Options Tangency Properties

7
Pick — to sketch the cross section.

Notice that system has placed cross-hair at the start point of the Origin trajectory and also a
reference to each chain. You can rotate the view to have a look at it clearly.



Pick " *FI"* and sketch a three point spline that passes through the references for chains as

shown below (View shown after picking & ).
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To add spline tangency dimension at a point, click the spline, then click the geometry to which
the spline tangency is to be defined and then click the endpoint where the tangency is to be
defined. Then click the middle mouse button to place the dimension.

pick ¥ to complete the sketch.

Pick ‘, to complete the feature and surface will display as shown below.

Notice that cross-section remains aligned to the chains all along the sweep feature.

=> Mirroring the surfaces

Now we will mirror the surface, so select it as shown below.

Pick this quilt

While the surface geometry is selected, pick JEwror 5 the Model tab to invoke the Mirror tool.

Select the FRONT datum as Mirror plane.

Pick ‘, to complete the feature. Part will appear as shown below.



= Merging the surfaces

Now we will merge the surfaces together.

So select the surfaces, shown in the figure below, while holding down the Ctrl key. (order of
selection is not important)

Select these quilts

Pick &' 51 the Model tab to invoke Merge tool.

Pick - Cptions l tab and change the merge type to Join.
WL I © w6 vx
References | Options i Properties
) Intersect
® Join

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick ‘/ or middle-click to complete the merge feature.

Select File > Save to save the work done so far.
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Exercise 3

In this exercise we will fix a distorted boundary blended surface.
Set the working directory to the EXAMPLES folder and open the model BASE_NECK.PRT

The part will appear as shown below.

Distorted surface

You should notice that neck of this part appears distorted. This neck is defined by a boundary
blended surface. So we will fix this surface. This problem occurs often while creating boundary
blended surfaces, so it is important to know how to fix it.

= Modify the surface
We will redefine this surface feature and fix it.

Pick the “Boundary Blend 1” feature in model tree and select ¥

7 DT o
- T i
[ fﬂ Sweep 1 J}‘\.ir
i 4 kdit Definition (Ctrl+E)
P ] Sweep 2 L ; NS 5
== Edit the definition of the selected object.
[ 3 _ﬁ Extrude 2

[ 3 ;ﬂ Extrude 3
7 Boundary Blend 1
% Insert Here

Notice the location of start point for fist Chain as shown below.



Pick !.c"ms tab to view Curves slide-up panel. Here pick on the second chain as shown below.

Curves Constraints Control Points Options Properties
First direction Second direction
] Chain Click here ...
2 Chain | + +
+ 4
Cloze blend

Now system will show the Start Point for second chain as shown below.

If you compare the location of Start Point for first and second chain then you can easily conclude
that surface is distorted due to mismatch of Start Points. So we will change the location of Start
Point of second chain so that it corresponds to the Start Point of first Chain.

Take your mouse pointer over the Start Point and hold down left mouse button. Then drag and
drop it as shown in the figure below.
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Now the surface will appear as shown below.

Apply the Tangent constraint for second chains as shown below.



) Mormal

Select File > Save to save the work done so far.
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Exercise 4

In this exercise we will build a shampoo bottle. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model BOTTLE.PRT

— Building Body
First we will build the quilts that represent the body of the bottle.

We need to offset the outer quilt to create the quilt for the step visible in above figure.

So pick the quilt as shown below. You can use the Quilt filter if you have difficulty in selecting
the quilts.

Pick this quilt

Geometry
Edge
Surface
Daturns

Curve

Cuilt

Annotation
Vertex

Feature

Pick 7 offset on the Model tab to invoke Offset tool and enter 2 as the offset value on the
dashboard.



Pick A to reverse the direction of feature creation so that surface is offset inwards as shown
below.

Pick v icon to complete the feature. (Leave the offset type to Standard, which is default)
Now we will merge the quilts. So select quilts, shown in the figure below, while holding down the

Ctrl key. (Notice that offset quilt is not selected but the original quilt). You can use the Quilt filter
if you have difficulty in selecting the quilts.

Pick this quilt first Fick this quilt after halding Ctrl key

Pick &% 01 the Model tab to invoke Merge tool and preview will appear as shown below.
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Pick J or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below.

Now we will merge the new quilt (created after merge operation) with the quilt created by offset
operation.

So select quilts, shown in the figure below, while holding down the Ctrl key. (You can use the
Quilt filter if you have difficulty in selecting the quilts)



Pick this quilt first Fick thiz quilt after holding Ctrl key

Geometry
Edge
Surface
Daturms
Curve
Quilt
Annotation

Vertex

Feature

K
Pick &' ™% {4 invoke Merge tool and then 7 so that preview appears as shown below.
(Notice the direction of arrows)

Pick bl or middle-click after making sure that arrows direction is as shown in the above figure.

Now the part should appear as shown below. (If not then go back and fix it)
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Shaded view Wireframe view

—> Building Neck

Now we will create the neck details for the bottle. For this purpose we have already created a
surface but it is hidden.

So select the “NECK” feature in the model tree and pick Show.

Now part will appear as shown below.

We will create a boundary blended surface that connects NECK with main body.

4
Pick g and select the edge chain shown in figure below. (Tip: Place the mouse pointer over the
edge of the surface and right-click repeatedly until IntentEdg tooltip appears. When the tooltip
appears, select the chain with left mouse pick.)



Now hold down the Ctrl key and pick the second chain using the Intent chain technique as
shown below.

If the preview of surface appears distorted, then fix it before proceeding. The procedure to fix the
distorted boundary blended surface was explained in previous exercise.

Apply the Tangent constraints for both chains as shown below.

O Mormal - ) MNormal

O Curvature (O Curvature
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Pick b to complete the feature and surface will display as shown below.

= Building Bottom

Now we will create the bottom details for the bottle. For this purpose we have already created a
surface but it is hidden.

So right-click the “BOTTOM_CLOSE” feature in the model tree and pick Show.

We will merge the BOTTOM_CLOSE with the main quilt.

So select quilts, shown in the figure below, while holding down the Ctrl key.

1: Pick this quilt 2: Pick this quilt

Pick &% 41 the Model tab to invoke Merge tool and preview will appear as shown below.



Pick ha or middle-click after making sure that arrows direction is as shown in the above figure.

Pick """ t5 access the Round tool.

Select the following edge chain for applying round.

N

IntentEdg:F21(MERGE_4)

Enter 3 as the radius value

Pick el icon to complete the feature.
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—> Thickening the Quilt

Before thickening the quilt, all surfaces should be merged together to form a single quilt. So first
merge operation will be performed.

First we will merge the boundary blended surface of neck with the main quilts.

So select quilts, shown in the figure below, while holding down the Ctrl key.

1: Pick this quilt 2: Pick this quilt

Pick &% 41 the Model tab to invoke Merge tool.

Pick “P""*  tab and change the merge type to Join.

Il © I 6d & x
References Options Properties

() Intersect
® Join

Join option is used when two surfaces have a common edge. Join option is faster than Intersect
option.

Pick .l or middle-click to complete the merge feature.

Now we will merge the NECK surface with the main quilts.



So select quilts, shown in the figure below, while holding down the Ctrl key.

1: Pick this quilt 2: Pick this quilt

A <A

Pick & 41 the Model tab to invoke Merge tool.

Pick | °P"°"* | tab and change the merge type to Join.

Pick i or middle-click to complete the merge feature.

The part will appear as shown below. Notice that all the edges, except at opening, appear
magenta which means that all surfaces have been merged into a single quilt.

Now we will thicken the quilt. So select the quilt.

Pick = to invoke Thicken tool.
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Enter 1 as the thickness on the dashboard.

Pick A to reverse the direction of feature creation so that material is added to the inner side
of the quilt as shown below.

Pick il or middle-click to complete the feature. The part will appear as shown below.

Select File > Save to save the work done so far.



Exercise 5

In this exercise we will complete a surface model of a door of drawer. The completed part is
shown below.

Set the working directory to the EXAMPLES folder and open the model DRAWER_DOOR.PRT

Before creating the desired surface, first we will create the datum curves which will be used to
construct the surface.

= Creating the datum curves

We will create the datum curves using through points option.

Pick 7 CurvethroughPoints o0 4he Model tab as shown below.

Maodel Analysis Annotate Tools View Flexible Modeling Apr
jt" igC .f User-Defined Feature U r; Az (‘\b K é _uio Revolve
A= i 1 My oo e A :
2 Paste ~ I5- Copy Geometry x - Point = W] Sweep - W Rov
Regenerate = Plane Sketch | Bxdtrude
- X Delete = Ii"} Shrinkowrap ﬁ* Coordinate System &7 Swept Blend | 3 Che
Operations ™ Get Data = Daturn = Shapes ™ I
o Curve kil mne | Curve through Points
EE_EII Reference ~Jg | Curve from Equation
b Graph Mt Curve from Cross Section
Ribbon

ﬂ‘g Offset Planes
Default Coordinate System

Pick the following vertex as first point for curve. (Set the view to ISO3 and part will appear as
shown below.)
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Standard Orientation | & |
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Pick the datum points one-by-one in the following order, PNT4 > PNTO > PNT5, as shown in
figure below.

Second Pick Third Pick Fourth Pick

Pick the following vertex as last point for curve.

Now we will specify the tangent constraints for the ends of the curve.

Ends Condition

So pick tab and change the 'End condition' for Start Point to Tangent.



Placement Ends Condition | Options Properties

Curve side

@ Start Point End condition || Tangent -|
End Point = '

Tangent to

@ Select iterms

Now system wants to know a reference to which the new curve will be tangent, so pick the
following surface to make the new datum curve tangent to it.

Surf:FS(EXTRUDE_1)

Now change the 'End condition' for End Point to Tangent as shown below.

Placement |  Ends Condition Options Properties
Curve side
start Point | Fnd condition | Tangent f |
® End Point "“ e
[ Tangent to

® Select items

Again pick the following surface to make the new datum curve tangent to it at the end point.
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Surf:F3(EXTRUDE_1)

Pick ol to complete the feature. The datum curve will appear as shown below.

Now we will create second curve so again pick " U hreuah Fenis

Pick the PNT6 as first point for curve. (Set the view to ISO3 and part will appear as shown
below.)

Standard Orientation | & |
[ Default Orientation |
(HBack
(5 BoTTOM
[ FRONT
| 1501
; 1502 !
. PNTB:F 13(DATUM POINT) | 503 v

1

iﬁ_ Rearient...

Pick the PNTO as end point.



Now we will specify the tangent constraints for the ends of the curve.

Ends Condition

So pick tab and change the End condition for Start Point to Tangent.

Now system wants to know a reference to which the new curve will be tangent, so pick the
surface shown in the figure below to make the new datum curve tangent to it at the start point.

Now change the End condition for End Point to Normal.

Select the DTM_OPENING datum plane as reference as shown below.

Curve side Curve side
Start Paoint End condition | Mormal v Start Paoint End condition | Mormal |v|
@ End Point End Point
Maormal to Maormal to
| ® Select items Flip | DTM_OPENING:F7(DATI| | Fiip |




Surface Modeling - A Practical Approach Creo 4.0

Flip

Select to reverse the direction so that curve appears as shown in figure below.

Thdsl L

Pick to complete the feature.

= Creating the surface

Now we will create a surface with Boundary Blend Tool.

Pick q and select the edge shown in the figure below.

Now hold down the Ctrl key and pick the following curve as second chain.



Pick in the 'Second direction' collector to activate either on dashboard or in Curves panel.

T 5 ; = K
7 | 2 Chains | flf | selectitems | o
Curves Constraints Control Points Options Properties
First direction Second direction
1 Chain Select items
2 Chain 4+ +
& Pick here to activate
+ ¥
Details... Details...
Close blend

Pick the edge, shown in the figure below (dynamic preview off) as first chain in second direction.
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Pick this edge

Now hold down the Ctrl key and pick the datum curve, shown in the figure below as second
chain in second direction.

Pick this curve

While holding down the Ctrl key, pick the edge, shown in the figure below as last chain in second
direction.



Pick this edge

Apply the Tangent constraints for the three chains as shown below.

Pick W to apply the changes and exit the dashboard.

Select File > Save to save the work done so far.
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Exercise 6

In this exercise we will create a model for plastic chair. The completed part is shown below.

Set the working directory to the EXAMPLES folder and open the model CHAIR.PRT. Because
this part is symmetrical so we will create half side of the part and then mirror it.

Required datum curves have already been created. You are encouraged to explore the way
these curves have been defined after completing this exercise.

= Creating the surface

We will create a boundary blended surface by using the predefined curves.

Pick ' and select the curves, while holding down the Ctrl key, in the order shown in figure
below.

First Pick Second Pick Third Pick Fn:_:urth Pick

5

-------




Pick in the Second Direction Collector to activate it and while holding down the Ctrl key, select
the curves shown in figure below.

First Pick Second Pick

n.na

Apply the Normal constraint for the chain that lies on RIGHT datum plane as shown below.

f

2

(@  Free
Tangent

Curvature

This surface will be mirrored about RIGHT datum plane. Therefore to maintain tangency
between original and mirrored surface, the surface has been constrained Normal to the RIGHT
datum plane.

To make the mirrored and parent surface tangent to each other, we need to make the parent
surface normal to mirror plane.
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Pick ‘, to complete the feature.

= Creating the Datum Curve for Trimming

Now we will create a datum curve that will lie on the surface we have created and then trim the
surface with this curve. First we will create four datum points to be used as reference for the
datum curve.

Pick ** ™ on the Model tab to invoke Datum Point tool.

Model Analysis Annotate Tools View Flexible Modeling
o =3 Copy . f User-Defined Feature / Pxis o e , dio Revolve
A= 5 . X f :

2 Paste = | [j Copy Geometry % * Paint = = ] Sweep ~
Regenerate Plane Sketch | Bxtrude
- K Delete ~ _I?H Shrinkwrap &H Coordinate System f Swept Blend
Operations = Get Data = Datum = Shapes =

Now pick on the surface near bottom right corner. Look at the position of mouse pointer in the
figure below.

SurfF20(BOUNDARY_BLEND_1)

Pick in the Offset references collector to activate it.



Datum Point x

Placement | Properties

:PNT-# « | References
| g Surf:F20(BOUMDARY... On~

(Offset references
. Select items

Cancel

Now select the edge shown in figure below as offset reference and enter 45 as the Offset value.

Datum Point x

Placement | Properties

TF'NT-# « | References
Surf:F20(BOUNDARY... On~

[ bl

Offzet references
Edge:F20{BOUNDARY_... | 45.00

Pick this edge

& :

Cancel

Hold down the Ctrl key and select the side edge as second offset reference. Enter 25 as the
Offset value as shown below.
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Datum Point x
Placement | Properties
] PNT4 .| References
$ MNew Point Surf:F20(BOUNDARY... On~
Pick this edge N
Offzet references
Edge:F20(BECUMDARY_... 45.00
E Edge:F20(BECUMDARY ... |25.00
0K | Cancel |

OK

Pick ' ' to complete the definition of datum point.

Now we will create another datum point so again pick * * P on the Model tab.

Pick the following datum curve as reference.

Pick this curve

Pick  MeXEnd 4 change the measurement reference to right end of curve

Change the Offset option to Real and enter 55 as the Offset value as shown below.



Placement | Properties

Datum Point

References

Offset
55.00

& Mew Point Curve:F14(CURVE]

On~-

| 55.00

|-

Real

Offset reference

T5 ® End of curve i___NE:ct End !
- | O Reference

ick here to ad..,

oK

| | Cancel

OK

= |
Pick : - to complete the definition of datum point.

¥ Point

Again pick *

Pick this curve

Change the Offset option to Real and enter 25 as the Offset value as shown below.

on the Model tab and select the following datum curve as reference.
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Datum Point x
Properties
_PNTE « | References
& Mew Point Curve:F17{CLIRVE) On~
Offset |/ 25.00 '+ Real B

Offset reference

i® End of curve | Mext End I

_| © Reference C ol

O || Cancel |

OKi

Pick | - to complete the definition of datum point.

Again pick  x Point on the Model tab and pick the surface near top right corner. Look at the

position of mouse pointer in the figure below.

SurfF20(BOUNDARY_BLEND_1)

LT 6

Pick in the Offset references collector to activate it.

Now select the top edge of surface as offset reference and enter 35 as the Offset value as
shown below.



Pick this edge

MTE

Placement

% PNTY

Properties

.

Datum Point

References

 Surf:F20(BOUNDARY...

(Offset references

On~-

Edge:F20(BOUNDARY _...

35.00

Cancel

Hold down the Ctrl key and select the side edge as second offset reference. Enter 35 as the
Offset value as shown below.

Pick this edge

Pick ~ 2¢

Placement | Properties
BNTT -
% DNew Point

Daturmn Point

References
Surf:F20(BOUNDARY... On~
Offset references
| EdgeF20(BOUNDARY._... 35.00
Edge:F20(BOUNDARY._.
K | Cancel |

| to complete the definition of datum point.

Now we will create a datum curve using through points option, passing through the four points

that we just created.

Pick MJ  Curve through Points

on the Model tab to invoke Curve through Points tool.
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Pick the following vertex as first point for curve.

T 7

MTE

T3

Pick this vertex _FK

Vertex:Edge F20{BOUNDARY_BLEND_1)

Pick the datum points one-by-one in the following order, PNT4 > PNT5 > PNT6 > PNT7

o\ 74— Fifth Pick |

Te<— Fourth Pick

-—] Third Pick

—

4‘1—| Second Pick |

Pick the following vertex as last point for curve.

Creo 4.0



Pick this vertex —h_

Vertex Edge: F20{BOUNDARY _BLEND_1})

Pick "“““™="™ {5 access the Placement panel and check the 'Place curve on surface' option.

As the Surface collector becomes active so pick the surface as shown below.

Placement Ends Condition Options Properties

Point 1 | Point
Point 2 Vertex:Edge:F20(BOUNDARY _EL

Point 3 : .

Connect to previous point b

Point 4 g i

Point 3

Point &

Add Point 4+

Place curve on surface

Surface | Surf:F20(BOUNDARY _BEL

'Place curve on surface' option is used to create a spline curve that passes through the selected
points and lies on a specific surface patch.

Now we will specify the normal constraints for the ends of the curve.

Ends Condition

So pick tab and change the End condition for 'Start Point' to Normal.

Now system wants to know a reference to which the new curve will be normal, so select the
RIGHT datum plane as reference
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Placement | Ends Condition

Curve side

Start Point
End Point

Options - Properties

Creo 4.0

End condition | Mormal

Mormal to

| RIGHT:F1(DATUM PLAN

| Fiip |

Change end condition for 'End Point' to Normal and select the RIGHT datum plane as reference.

Placement | Ends Condition

Curve side
Start Point
End Point

Options - Properties

-Endmnditin:rn Marmal

Mormal to

| RIGHT:F1(DATUM PLAN

| Fiip |

If you look at the end of curve, you will notice that it is twisted as shown below.




It is due to the wrong direction of normal constraint. So pick Flip to reverse the direction.

Pick bl to complete the feature. The datum curve will appear as shown below.

TG

= Trimming the Quilt
Now we will trim the quilt with this curve. So first select the quilt.

Pick (Sl Trim on the Model tab to invoke Trim tool.

Select the newly created datum curve as trimming object and preview will appear as shown
below.
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or middle-click to complete the feature.

=> Mirroring the Quilt

Now we will mirror the quilt so first select the trimmed quilt.

Pick this quilt

Creo 4.0

Pick UL M™r o1 the Model tab to invoke Mirror tool and select the RIGHT datum as Mirror plane.



Pick @ to complete the feature. Part will appear as shown below.

Now you can merge both surfaces together.

Select File > Save to save the work done so far.
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